]> git.pld-linux.org Git - SPECS.git/blob - jail.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / jail.spec
1 Summary:        Tool that builds a chrooted environment
2 Summary(pl.UTF-8):      Narzędzie tworzące środowisko w chroocie
3 Name:           jail
4 Version:        1.9a
5 Release:        3
6 License:        GPL
7 Group:          Applications/Communications
8 Source0:        http://www.jmcresearch.com/static/dwn/projects/jail/%{name}_%{version}.tar.gz
9 # Source0-md5:  06824a1255ce3da1bb86cb806bf15535
10 Patch0:         %{name}-install.patch
11 URL:            http://www.jmcresearch.com/projects/jail/
12 BuildRequires:  rpmbuild(macros) >= 1.202
13 Requires(postun):       /usr/sbin/groupdel
14 Requires(pre):  /usr/bin/getgid
15 Requires(pre):  /usr/sbin/groupadd
16 Requires:       strace
17 Provides:       group(jail)
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Jail Chroot Project is an attempt of write a tool that builds a
22 chrooted environment. The main goal of Jail is to be as simple as
23 possible, and highly portable. The most difficult step when building a
24 chrooted environment is to set up the right libraries and files. Here,
25 Jail comes to the rescue with a tool to automagically configures and
26 builds all the required files, directories and libraries.
27
28 %description -l pl.UTF-8
29 Jail Chroot Project to próba napisania narzędzia tworzącego środowisko
30 w chroocie. Głównym celem Jaila jest bycie tak prostym jak to tylko
31 możliwe, a przy tym bardzo przenośnym. Najtrudniejszym krokiem przy
32 tworzeniu środowiska w chroocie jest właściwe dobranie bibliotek i
33 plików. Tutaj z pomocą przychodzi Jail z narzędziem automatycznie
34 konfigurującym i tworzącym wszystkie wymagane pliki, katalogi i
35 biblioteki.
36
37 %prep
38 %setup -q -n %{name}
39 %patch0 -p1
40
41 %build
42 %{__make} -C src \
43         CC="%{__cc}" \
44         CFLAGS="%{rpmcflags}"
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} -C src install \
50         DESTDIR=$RPM_BUILD_ROOT \
51         PREFIX=%{_prefix} \
52         SYSCONFDIR=%{_sysconfdir}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %pre
58 %groupadd -g 35 jail
59
60 %postun
61 if [ "$1" = "0" ]; then
62         %groupremove jail
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %doc CHANGELOG README TODO
68 %attr(755,root,root) %{_bindir}/[!j]*
69 %attr(4750,root,jail) %{_bindir}/jail
70 %{_prefix}/lib/jail
71 %attr(640,root,root) %verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/jail.conf
This page took 0.320143 seconds and 3 git commands to generate.