]> git.pld-linux.org Git - SPECS.git/blob - ipython3.spec
SPECS updated Sat 31 Jul 20:27:02 CEST 2021
[SPECS.git] / ipython3.spec
1 #
2 # Conditional build:
3 %bcond_with     doc     # Sphinx documentation
4 %bcond_with     tests   # unit tests (need to wait for fulfilling dependencies in PLD)
5
6 Summary:        An enhanced Interactive Python shell
7 Summary(pl.UTF-8):      Interaktywna powłoka języka Python
8 Name:           ipython3
9 Version:        7.25.0
10 Release:        1
11 License:        BSD
12 Group:          Applications/Shells
13 Source0:        http://archive.ipython.org/release/%{version}/ipython-%{version}.tar.gz
14 # Source0-md5:  c83047b581398490b5d83129da73aa89
15 Patch0:         ipython-use-setuptools.patch
16 URL:            http://ipython.org/
17 BuildRequires:  pydoc3 >= 1:3.7
18 BuildRequires:  python3-devel >= 1:3.7
19 BuildRequires:  python3-devel-tools >= 1:3.7
20 BuildRequires:  python3-setuptools >= 18.5
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  rpmbuild(macros) >= 1.747
23 %if %{with tests}
24 BuildRequires:  python3-backcall
25 BuildRequires:  python3-decorator
26 BuildRequires:  python3-ipykernel
27 BuildRequires:  python3-jedi >= 0.16
28 BuildRequires:  python3-matplotlib_inline
29 BuildRequires:  python3-nbformat
30 BuildRequires:  python3-nose >= 0.10.1
31 BuildRequires:  python3-numpy >= 1.17
32 BuildRequires:  python3-pexpect > 4.3
33 BuildRequires:  python3-pickleshare
34 BuildRequires:  python3-prompt_toolkit >= 3.0.2
35 BuildRequires:  python3-prompt_toolkit < 3.1.0
36 BuildRequires:  python3-pygments
37 BuildRequires:  python3-requests
38 BuildRequires:  python3-testpath
39 BuildRequires:  python3-traitlets >= 4.2
40 %endif
41 %if %{with doc}
42 BuildRequires:  python3-docrepr
43 BuildRequires:  python3-docutils
44 BuildRequires:  python3-ipykernel
45 BuildRequires:  python3-matplotlib
46 BuildRequires:  python3-sphinx_rtd_theme
47 BuildRequires:  sphinx-pdg-3 >= 1.3
48 %endif
49 Requires:       python3-ipython = %{version}-%{release}
50 Suggests:       python3-PyQt5
51 Suggests:       python3-zmq
52 BuildArch:      noarch
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 IPython is a free software project which tries to:
57
58 1. Provide an interactive interpreter superior to Python's default.
59 IPython has many features for object introspection, shell access, and
60 its own special command system for adding functionality when working
61 interactively.
62
63 2. Serve as an embeddable, ready to use interpreter for your own
64 programs. IPython can be started with a single call from inside
65 another program, providing access to the current namespace. This can
66 be very useful both for debugging purposes and for situations where a
67 blend of batch-processing and interactive exploration are needed.
68
69 3. Offer a flexible framework which can be used as the base
70 environment for other systems with Python as the underlying language.
71 Specifically scientific environments like Mathematica, IDL and Mathcad
72 inspired its design, but similar ideas can be useful in many fields.
73
74 This package contains IPython shell.
75
76 %description -l pl.UTF-8
77 IPython jest wolnym oprogramowaniem, którego celem jest:
78
79 1. Dostarczenie interaktywnej powłoki lepszej od standardowej
80 dostarczanej z językiem Python. IPython umożliwia badanie obiektów,
81 dostęp do powłoki oraz własny system poleceń, który umożliwia
82 rozszerzanie funkcjonalności podczas pracy interaktywnej.
83
84 2. Dostarczenie gotowego interpretera, który można dołączać do własnej
85 aplikacji. IPython może zostać uruchomiony za pomocą wywołania jednej
86 funkcji z poziomu innego programu umożliwiając jednocześnie dostęp do
87 aktualnej przestrzeni nazw tego programu. Może to być bardzo użyteczne
88 do celów takich jak śledzenie programu czy też sytuacji gdzie jest
89 wymagane połączenie przetwarzania wsadowego z interaktywną
90 introspekcją.
91
92 3. Dostarczenie szkieletu, który może zostać użyty jako podstawa
93 systemu, którego polecenia opierają się na zasadach języka Python.
94 Projekt został zainspirowany przez oprogramowanie naukowe takie jak
95 Mathematica, IDL oraz Mathcad, gdzie podobne idee mogą być realizowane
96 w wielu przypadkach.
97
98 Pakiet ten zawiera powłokę IPython.
99
100 %package -n python3-ipython
101 Summary:        An enhanced Interactive Python shell modules
102 Summary(pl.UTF-8):      Moduły interaktywnej powłoki języka Python
103 Group:          Libraries/Python
104 Requires:       pydoc3 >= 1:3.7
105 Requires:       python3-devel-tools >= 1:3.7
106
107 %description -n python3-ipython
108 IPython is a free software project which tries to:
109
110 1. Provide an interactive interpreter superior to Python's default.
111 IPython has many features for object introspection, shell access, and
112 its own special command system for adding functionality when working
113 interactively.
114
115 2. Serve as an embeddable, ready to use interpreter for your own
116 programs. IPython can be started with a single call from inside
117 another program, providing access to the current namespace. This can
118 be very useful both for debugging purposes and for situations where a
119 blend of batch-processing and interactive exploration are needed.
120
121 3. Offer a flexible framework which can be used as the base
122 environment for other systems with Python as the underlying language.
123 Specifically scientific environments like Mathematica, IDL and Mathcad
124 inspired its design, but similar ideas can be useful in many fields.
125
126 This package contains IPython modules.
127
128 %description -n python3-ipython -l pl.UTF-8
129 IPython jest wolnym oprogramowaniem, którego celem jest:
130
131 1. Dostarczenie interaktywnej powłoki lepszej od standardowej
132 dostarczanej z językiem Python. IPython umożliwia badanie obiektów,
133 dostęp do powłoki oraz własny system poleceń, który umożliwia
134 rozszerzanie funkcjonalności podczas pracy interaktywnej.
135
136 2. Dostarczenie gotowego interpretera, który można dołączać do własnej
137 aplikacji. IPython może zostać uruchomiony za pomocą wywołania jednej
138 funkcji z poziomu innego programu umożliwiając jednocześnie dostęp do
139 aktualnej przestrzeni nazw tego programu. Może to być bardzo użyteczne
140 do celów takich jak śledzenie programu czy też sytuacji gdzie jest
141 wymagane połączenie przetwarzania wsadowego z interaktywną
142 introspekcją.
143
144 3. Dostarczenie szkieletu, który może zostać użyty jako podstawa
145 systemu, którego polecenia opierają się na zasadach języka Python.
146 Projekt został zainspirowany przez oprogramowanie naukowe takie jak
147 Mathematica, IDL oraz Mathcad, gdzie podobne idee mogą być realizowane
148 w wielu przypadkach.
149
150 Pakiet ten zawiera moduły interaktywnej powłoki języka Python.
151
152 %package -n python3-ipython-apidocs
153 Summary:        API documentation for Python IPython module
154 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona IPython
155 Group:          Documentation
156
157 %description -n python3-ipython-apidocs
158 API documentation for Python IPython module.
159
160 %description -n python3-ipython-apidocs -l pl.UTF-8
161 Dokumentacja API modułu Pythona IPython.
162
163 %prep
164 %setup -q -n ipython-%{version}
165 %patch0 -p1
166
167 %{__sed} -i -e '1s,/usr/bin/env python,%{__python},' \
168         examples/Embedding/embed_class_long.py \
169         "examples/IPython Kernel/ipython-get-history.py" \
170         "examples/IPython Kernel/gui"/gui-*.py
171
172 %build
173 %py3_build
174
175 %if %{with tests}
176 PYTHONPATH=$(pwd) \
177 %{__python3} IPython/testing/iptest.py IPython
178 %endif
179
180 %if %{with doc}
181 PYTHONPATH=$(pwd) \
182 %{__make} -C docs html \
183         PYTHON=%{__python3} \
184         SPHINXBUILD=sphinx-build-3
185 %endif
186
187 %install
188 rm -rf $RPM_BUILD_ROOT
189 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
190
191 %py3_install
192
193 cp -pr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
194
195 # test suite
196 %{__rm} $RPM_BUILD_ROOT%{_bindir}/iptest*
197 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/IPython/{core/tests,extensions/tests,lib/tests,terminal/tests,testing/tests,utils/tests}
198
199 %clean
200 rm -rf $RPM_BUILD_ROOT
201
202 %files
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_bindir}/ipython
205 %attr(755,root,root) %{_bindir}/ipython3
206 %{_mandir}/man1/ipython.1*
207
208 %files -n python3-ipython
209 %defattr(644,root,root,755)
210 %doc COPYING.rst LICENSE README.rst
211 %{py3_sitescriptdir}/IPython
212 %{py3_sitescriptdir}/ipython-%{version}-py*.egg-info
213 %{_examplesdir}/%{name}-%{version}
214
215 %if %{with doc}
216 %files -n python3-ipython-apidocs
217 %defattr(644,root,root,755)
218 %doc docs/build/html/{_images,_static,about,api,config,coredev,development,install,interactive,parallel,whatsnew,*.html,*.js}
219 %endif
This page took 0.661247 seconds and 3 git commands to generate.