]> git.pld-linux.org Git - SPECS.git/blob - input-pad.spec
SPECS updated Sun 1 Aug 15:50:02 CEST 2021
[SPECS.git] / input-pad.spec
1 Summary:        On-screen Input Pad to Send Characters with Mouse
2 Summary(pl.UTF-8):      Pole wprowadzania znaków na ekranie przy użyciu myszy
3 Name:           input-pad
4 Version:        1.0.3
5 Release:        6
6 License:        LGPL v2+
7 Group:          Libraries
8 #Source0Download: https://github.com/fujiwarat/input-pad/releases
9 Source0:        https://github.com/fujiwarat/input-pad/releases/download/%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  70f3d0273da97d576e80b4f45a112fec
11 URL:            https://github.com/fujiwarat/input-pad
12 BuildRequires:  eekboard-devel >= 1.0.6
13 BuildRequires:  glib2-devel >= 1:2.8
14 BuildRequires:  gobject-introspection-devel >= 0.9.6
15 BuildRequires:  gtk+3-devel >= 3.0
16 BuildRequires:  intltool >= 0.35.0
17 BuildRequires:  libxklavier-devel >= 4.0
18 BuildRequires:  libxml2-devel >= 2.0
19 BuildRequires:  pkgconfig
20 BuildRequires:  python-devel >= 1:2.5
21 BuildRequires:  swig-python
22 BuildRequires:  xorg-lib-libX11-devel
23 BuildRequires:  xorg-lib-libXtst-devel
24 BuildRequires:  xorg-lib-libxkbfile-devel
25 Requires:       glib2 >= 1:2.8
26 Requires:       gtk+3 >= 3.0
27 Requires:       libxklavier >= 4.0
28 Requires:       libxml2 >= 2.0
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 The input pad is a tool to send a character on button to text
33 applications.
34
35 %description -l pl.UTF-8
36 Input Pad to narzędzie pozwalające na wysyłanie znaków do aplikacji
37 tekstowych przyciskiem myszy.
38
39 %package devel
40 Summary:        Development files for input-pad
41 Summary(pl.UTF-8):      Pliki programistyczne biblioteki input-pad
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       glib2-devel >= 1:2.8
45 Requires:       gtk+3-devel >= 3.0
46 Requires:       libxklavier-devel >= 4.0
47 Requires:       libxml2-devel >= 2.0
48
49 %description devel
50 The input-pad-devel package contains the header files.
51
52 %description devel -l pl.UTF-8
53 Ten pakiet zawiera pliki nagłówkowe biblioteki input-pad.
54
55 %package -n python-input-pad
56 Summary:        Input Pad for Python
57 Summary(pl.UTF-8):      Biblioteka Input Pad dla Pythona
58 Group:          Libraries/Python
59 Requires:       %{name} = %{version}-%{release}
60
61 %description -n python-input-pad
62 The input-pad-python package contains the Python wrapper files.
63
64 %description -n python-input-pad -l pl.UTF-8
65 Ten pakiet zawiera pliki obudowania Pythona dla biblioteki input-pad.
66
67 %package eek
68 Summary:        Input Pad with eekboard extension
69 Summary(pl.UTF-8):      Rozszerzenie eekboard dla biblioteki input-pad
70 Group:          Libraries
71 Requires:       %{name} = %{version}-%{release}
72
73 %description eek
74 The input-pad-eek package contains eekboard extension module.
75
76 %description eek -l pl.UTF-8
77 Ten pakiet zawiera moduł rozszerzenia eekboard dla biblioteki
78 input-pad.
79
80 %prep
81 %setup -q
82
83 %build
84 %configure \
85         --with-gtk=3.0 \
86         --enable-eek \
87         --enable-pygobject2 \
88         --enable-xtest
89
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
99 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}-1.0/modules/xkeysend/*.la
100 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}-1.0/modules/kbdui/*.la
101 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/%{name}-1.0/*.la
102 %py_postclean
103
104 %find_lang %{name}
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files -f %{name}.lang
113 %defattr(644,root,root,755)
114 %doc AUTHORS ChangeLog README TODO
115 %attr(755,root,root) %{_bindir}/input-pad
116 %attr(755,root,root) %{_libdir}/libinput-pad.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libinput-pad.so.1
118 %{_libdir}/girepository-1.0/InputPad-1.0.typelib
119 %dir %{_libdir}/%{name}-1.0
120 %dir %{_libdir}/%{name}-1.0/modules
121 %dir %{_libdir}/%{name}-1.0/modules/kbdui
122 %dir %{_libdir}/%{name}-1.0/modules/xkeysend
123 %attr(755,root,root) %{_libdir}/%{name}-1.0/modules/xkeysend/libinput-pad-xtest-gdk.so
124 %{_datadir}/%{name}
125 %{_pixmapsdir}/input-pad.png
126 %{_mandir}/man1/input-pad.1*
127
128 %files devel
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_libdir}/libinput-pad.so
131 %{_includedir}/%{name}-1.0
132 %{_pkgconfigdir}/input-pad.pc
133 %{_datadir}/gir-1.0/InputPad-1.0.gir
134
135 %files -n python-input-pad
136 %defattr(644,root,root,755)
137 %dir %{py_sitedir}/%{name}-1.0
138 %attr(755,root,root) %{py_sitedir}/%{name}-1.0/_input_pad*.so
139 %{py_sitedir}/%{name}-1.0/*.py[co]
140 %{py_sitedir}/pyinput_pad.pth
141
142 %files eek
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/%{name}-1.0/modules/kbdui/libinput-pad-eek-gtk.so
This page took 0.235256 seconds and 3 git commands to generate.