]> git.pld-linux.org Git - SPECS.git/blob - hostapd.spec
SPECS updated Sun 1 Aug 15:50:02 CEST 2021
[SPECS.git] / hostapd.spec
1 Summary:        HostAP - acts as an access point
2 Summary(es.UTF-8):      HostAP - actúa como un punto de acceso
3 Summary(pl.UTF-8):      HostAP - praca jako access point
4 Name:           hostapd
5 Version:        2.9
6 Release:        1
7 License:        BSD
8 Group:          Daemons
9 Source0:        http://w1.fi/releases/%{name}-%{version}.tar.gz
10 # Source0-md5:  f188fc53a495fe7af3b6d77d3c31dee8
11 Source1:        %{name}.init
12 Patch0:         %{name}-config.patch
13 Patch1:         %{name}-build-time-config.patch
14 URL:            http://w1.fi/hostapd/
15 BuildRequires:  libnl-devel >= 1:3.2
16 BuildRequires:  openssl-devel >= 1.0.2
17 BuildRequires:  pkgconfig
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 BuildRequires:  sed >= 4.0
20 BuildRequires:  sqlite3-devel >= 3
21 Requires(post,preun):   /sbin/chkconfig
22 Requires:       openssl >= 1.0.2
23 Requires:       rc-scripts
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This package contains utilities and userspace daemon for the Linux
28 driver for wireless LAN cards based on Intersil's Prism2/2.5/3,
29 Intersil/Conexant Prism GT/Duette/Indigo (Prism54), Atheros ar521x
30 (madwifi) chipsets. The driver supports a so called Host AP mode,
31 i.e., it takes care of IEEE 802.11 management functions in the host
32 computer and acts as an access point. This does not require any
33 special firmware for the wireless LAN card. In addition to this, it
34 has support for normal station operations in BSS and possible also in
35 IBSS.
36
37 %description -l es.UTF-8
38 Este paquete contiene unas herramientas y un servidor del espacio de
39 usuario para tarjetas LAN inalámbricas basadas en el chipset Intersil
40 Prism2/2.5/3, Intersil/Conexant Prism GT/Duette/Indigo (Prism54),
41 Atheros ar521x (madwifi). El driver soporta el llamado modo Host AP,
42 es decir, se encarga de las funciones administrativas el el host,
43 actuando como "access point". Ello no requiere ningún firmware
44 especial para la tarjeta LAN inalámbrica. Además, también hay soporte
45 para operaciones normales de estación en BSS y posiblemente también en
46 IBSS.
47
48 %description -l pl.UTF-8
49 Ten pakiet zawiera narzędzia oraz demona działającego w przestrzeni
50 użytkownika dla linuksowego sterownika kart sieci bezprzewodowych
51 opartych na układach Intersil Prism2/2.5/3, Intersil/Conexant Prism
52 GT/Duette/Indigo (Prism54), Atheros ar521x (madwifi). Sterownik
53 obsługuje tak zwany tryb Host AP, czyli dba o funkcje zarządzające
54 IEEE 802.11 na komputerze i działa jako access point. Nie wymaga to
55 żadnego specjalnego firmware dla karty sieci bezprzewodowej. Ponadto
56 ma obsługę normalnych operacji stacyjnych w BSS, a być może także
57 IBSS.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62 %patch1 -p1
63
64 %{__sed} '/CFLAGS =/{s/-g//; s/-O2/$(OPTCFLAGS)/}' -i hostapd/Makefile
65
66 %build
67 %{__make} -C hostapd all nt_password_hash hlr_auc_gw \
68         V=1 \
69         CC="%{__cc}" \
70         OPTCFLAGS="%{rpmcflags} %{rpmcppflags}" \
71         LDFLAGS="%{rpmcflags} %{rpmldflags}"
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{/sbin,%{_sysconfdir}/{hostap,pcmcia},%{_mandir}/man{1,8}}
76 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
77
78 # hostapd hostapd_cli nt_password_hash hlr_auc_gw
79 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/hostapd
80 install -p hostapd/hostapd $RPM_BUILD_ROOT/sbin
81 install -p hostapd/hostapd_cli $RPM_BUILD_ROOT/sbin
82 install -p hostapd/nt_password_hash $RPM_BUILD_ROOT/sbin
83 install -p hostapd/hlr_auc_gw $RPM_BUILD_ROOT/sbin
84 cp -p hostapd/hostapd.8 $RPM_BUILD_ROOT%{_mandir}/man8
85 cp -p hostapd/hostapd_cli.1 $RPM_BUILD_ROOT%{_mandir}/man1
86
87 # hostapd configuration
88 cp -a hostapd/hostapd.accept $RPM_BUILD_ROOT%{_sysconfdir}/hostap
89 cp -a hostapd/hostapd.conf $RPM_BUILD_ROOT%{_sysconfdir}/hostap
90 cp -a hostapd/hostapd.deny $RPM_BUILD_ROOT%{_sysconfdir}/hostap
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post
96 /sbin/chkconfig --add hostapd
97 %service hostapd restart "HostAP Daemon"
98
99 %preun
100 if [ "$1" = "0" ]; then
101         %service hostapd stop
102         /sbin/chkconfig --del hostapd
103 fi
104
105 %files
106 %defattr(644,root,root,755)
107 %doc COPYING hostapd/{ChangeLog,README,README-WPS}
108 %dir %{_sysconfdir}/hostap
109 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostap/hostapd.accept
110 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostap/hostapd.conf
111 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostap/hostapd.deny
112 %attr(755,root,root) /sbin/hlr_auc_gw
113 %attr(755,root,root) /sbin/hostapd
114 %attr(755,root,root) /sbin/hostapd_cli
115 %attr(755,root,root) /sbin/nt_password_hash
116 %attr(754,root,root) /etc/rc.d/init.d/hostapd
117 %{_mandir}/man1/hostapd_cli.1*
118 %{_mandir}/man8/hostapd.8*
This page took 0.253521 seconds and 3 git commands to generate.