]> git.pld-linux.org Git - SPECS.git/blob - horde-ingo.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / horde-ingo.spec
1 %define         hordeapp ingo
2 #
3 Summary:        Ingo - an email filter rules manager
4 Summary(pl.UTF-8):      Ingo - zarządca reguł filtrowania poczty elektronicznej
5 Name:           horde-%{hordeapp}
6 Version:        1.2.6
7 Release:        3
8 License:        GPL v2
9 Group:          Applications/WWW
10 Source0:        ftp://ftp.horde.org/pub/ingo/%{hordeapp}-h3-%{version}.tar.gz
11 # Source0-md5:  d8549db0b8ceeb08dd16e0f99a275e05
12 Source1:        %{hordeapp}-apache.conf
13 Source2:        %{hordeapp}-httpd.conf
14 Patch0:         %{hordeapp}-path.patch
15 Patch1:         %{hordeapp}-maildir-prefix.patch
16 Patch2:         %{hordeapp}-folders-in-maildir.patch
17 URL:            http://www.horde.org/ingo/
18 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 Requires:       horde >= 3.0
21 Requires:       php(imap)
22 Requires:       webapps
23 Suggests:       php-pear-Net_Sieve >= 1.0.1
24 Suggests:       php-pear-Net_Socket
25 Obsoletes:      ingo
26 Conflicts:      apache-base < 2.4.0-1
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _noautoreq_pear /usr/share/horde.* Horde.*
31
32 %define         hordedir        /usr/share/horde
33 %define         _appdir         %{hordedir}/%{hordeapp}
34 %define         _webapps        /etc/webapps
35 %define         _webapp         horde-%{hordeapp}
36 %define         _sysconfdir     %{_webapps}/%{_webapp}
37
38 %description
39 Ingo currently supports the following filtering drivers:
40 - Sieve (using timsieved)
41 - procmail (using VFS FTP driver)
42 - IMAP client-side filtering
43
44 Ingo has replaced IMP's internal filtering code and is the default
45 filtering agent in IMP H3 (4.0).
46
47 The Horde Project writes web applications in PHP and releases them
48 under the GNU General Public License. For more information (including
49 help with Ingo) please visit <http://www.horde.org/>.
50
51 %description -l pl.UTF-8
52 Ingo aktualnie obsługuje następujące sterowniki filtrowania:
53 - Sieve (przy użyciu timsieved)
54 - procmail (przy użyciu sterownika VFS FTP)
55 - filtrowanie po stronie klienta IMAP
56
57 Ingo zastąpił wewnętrzny kod filtrujący IMP-a i jest domyślnym agentem
58 filtrowania w IMP-ie H3 (4.0).
59
60 Projekt Horde pisze aplikacje WWW w PHP i wydaje je na Powszechnej
61 Licencji Publicznej GNU (General Public License). Więcej informacji
62 (wraz z pomocą do Ingo) można znaleźć na stronie
63 <http://www.horde.org/>.
64
65 %prep
66 %setup -q -n %{hordeapp}-h3-%{version}
67 %patch0 -p1
68 %patch1 -p1
69 %patch2 -p1
70
71 rm */.htaccess
72 for i in config/*.dist; do
73         mv $i config/$(basename $i .dist)
74 done
75 # considered harmful (horde/docs/SECURITY)
76 rm test.php
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/docs}
81
82 cp -a *.php $RPM_BUILD_ROOT%{_appdir}
83 cp -a config/* $RPM_BUILD_ROOT%{_sysconfdir}
84 echo '<?php ?>' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.php
85 touch $RPM_BUILD_ROOT%{_sysconfdir}/conf.php.bak
86 cp -a js lib locale templates themes $RPM_BUILD_ROOT%{_appdir}
87 cp -a docs/CREDITS $RPM_BUILD_ROOT%{_appdir}/docs
88
89 ln -s %{_sysconfdir} $RPM_BUILD_ROOT%{_appdir}/config
90 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
91 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post
97 if [ ! -f %{_sysconfdir}/conf.php.bak ]; then
98         install /dev/null -o root -g http -m660 %{_sysconfdir}/conf.php.bak
99 fi
100
101 %triggerin -- apache1 < 1.3.37-3, apache1-base
102 %webapp_register apache %{_webapp}
103
104 %triggerun -- apache1 < 1.3.37-3, apache1-base
105 %webapp_unregister apache %{_webapp}
106
107 %triggerin -- apache-base
108 %webapp_register httpd %{_webapp}
109
110 %triggerun -- apache-base
111 %webapp_unregister httpd %{_webapp}
112
113 %files
114 %defattr(644,root,root,755)
115 %doc README docs/*
116 %dir %attr(750,root,http) %{_sysconfdir}
117 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
118 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
119 %attr(660,root,http) %config(noreplace) %{_sysconfdir}/conf.php
120 %attr(660,root,http) %config(noreplace) %ghost %{_sysconfdir}/conf.php.bak
121 %attr(640,root,http) %config(noreplace) %{_sysconfdir}/[!c]*.php
122 %attr(640,root,http) %{_sysconfdir}/conf.xml
123
124 %dir %{_appdir}
125 %{_appdir}/*.php
126 %{_appdir}/config
127 %{_appdir}/docs
128 %{_appdir}/js
129 %{_appdir}/lib
130 %{_appdir}/locale
131 %{_appdir}/templates
132 %{_appdir}/themes
This page took 0.339756 seconds and 3 git commands to generate.