]> git.pld-linux.org Git - SPECS.git/blob - gtk-webkit.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / gtk-webkit.spec
1 #
2 # Conditional build:
3 %bcond_without  introspection   # disable introspection
4 #
5 # it's not possible to build this with debuginfo on 32bit archs due to
6 # memory constraints during linking
7 %ifarch %{ix86} x32
8 %define         _enable_debug_packages          0
9 %endif
10 Summary:        Port of WebKit embeddable web component to GTK+ 2
11 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 2
12 Name:           gtk-webkit
13 # note: 2.4.x is the last series with webkitgtk-1 API and GTK+ 2.x support
14 Version:        2.4.11
15 Release:        8
16 License:        BSD-like
17 Group:          X11/Libraries
18 Source0:        http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
19 # Source0-md5:  24a25ccc30a7914ae50922aedf24b7bc
20 Patch0:         x32.patch
21 Patch1:         abs.patch
22 Patch2:         %{name}-icu59.patch
23 Patch3:         %{name}-icu65.patch
24 URL:            http://webkitgtk.org/
25 BuildRequires:  /usr/bin/ld.gold
26 BuildRequires:  EGL-devel
27 BuildRequires:  OpenGL-GLX-devel
28 BuildRequires:  at-spi2-core-devel >= 2.6.0
29 BuildRequires:  autoconf >= 2.60
30 BuildRequires:  automake
31 BuildRequires:  bison >= 1.875
32 BuildRequires:  cairo-devel >= 1.10
33 BuildRequires:  enchant-devel >= 0.22
34 BuildRequires:  flex >= 2.5.33
35 BuildRequires:  fontconfig-devel >= 2.5.0
36 BuildRequires:  freetype-devel >= 1:2.1.8
37 BuildRequires:  gcc-c++ >= 6:4.7
38 BuildRequires:  geoclue2-devel >= 2.1.5
39 BuildRequires:  gettext-tools
40 BuildRequires:  glib2-devel >= 1:2.36.0
41 BuildRequires:  glibc-misc
42 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
43 BuildRequires:  gperf
44 BuildRequires:  gstreamer-devel >= 1.0.3
45 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.3
46 BuildRequires:  libstdc++-devel >= 6:4.7
47 BuildRequires:  gtk+2-devel >= 2:2.24.10
48 BuildRequires:  gtk-doc >= 1.10
49 BuildRequires:  harfbuzz-devel >= 0.9.7
50 BuildRequires:  harfbuzz-icu-devel >= 0.9.7
51 BuildRequires:  libicu-devel >= 59
52 BuildRequires:  libjpeg-devel
53 BuildRequires:  libpng-devel
54 BuildRequires:  libsecret-devel
55 BuildRequires:  libsoup-devel >= 2.42.0
56 BuildRequires:  libstdc++-devel
57 # libtool with -fuse-ld= gcc option support
58 BuildRequires:  libtool >= 2:2.4.2-13
59 BuildRequires:  libwebp-devel
60 BuildRequires:  libxml2-devel >= 1:2.6.30
61 BuildRequires:  libxslt-devel >= 1.1.7
62 BuildRequires:  pango-devel >= 1:1.32.0
63 BuildRequires:  perl-base
64 BuildRequires:  pkgconfig
65 BuildRequires:  python
66 BuildRequires:  rpmbuild(macros) >= 1.592
67 BuildRequires:  ruby
68 BuildRequires:  sqlite3-devel >= 3
69 BuildRequires:  tar >= 1:1.22
70 BuildRequires:  udev-glib-devel
71 BuildRequires:  xorg-lib-libXcomposite-devel
72 BuildRequires:  xorg-lib-libXdamage-devel
73 BuildRequires:  xorg-lib-libXrender-devel
74 BuildRequires:  xorg-lib-libXt-devel
75 BuildRequires:  xz
76 BuildRequires:  zlib-devel
77 Requires:       cairo >= 1.10
78 Requires:       enchant >= 0.22
79 Requires:       fontconfig-libs >= 2.5.0
80 Requires:       freetype >= 1:2.1.8
81 Requires:       glib2 >= 1:2.36.0
82 Requires:       gstreamer >= 1.0.3
83 Requires:       gstreamer-plugins-base >= 1.0.3
84 Requires:       gtk+2 >= 2:2.24.10
85 Requires:       harfbuzz >= 0.9.7
86 Requires:       libsoup >= 2.42.0
87 Requires:       libxml2 >= 1:2.6.30
88 Requires:       libxslt >= 1.1.7
89 Requires:       pango >= 1:1.32.0
90 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 # __once_call, __once_called non-function symbols from libstdc++
94 %define         skip_post_check_so      lib.*gtk-1.0.*
95
96 %description
97 gtk-webkit is a port of the WebKit embeddable web component to GTK+ 2.
98
99 %description -l pl.UTF-8
100 gtk-webkit to port osadzalnego komponentu WWW WebKit do GTK+ 2.
101
102 %package devel
103 Summary:        Development files for WebKit for GTK+ 2
104 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 2
105 Group:          X11/Development/Libraries
106 Requires:       %{name} = %{version}-%{release}
107 Requires:       glib2-devel >= 1:2.36.0
108 Requires:       gtk+2-devel >= 2:2.24.10
109 Requires:       libsoup-devel >= 2.42.0
110 Requires:       libstdc++-devel
111
112 %description devel
113 Development files for WebKit for GTK+ 2.
114
115 %description devel -l pl.UTF-8
116 Pliki programistyczne komponentu WebKit dla GTK+ 2.
117
118 %prep
119 %setup -q -n webkitgtk-%{version}
120 %patch0 -p1
121 %patch1 -p1
122 %patch2 -p1
123 %patch3 -p1
124
125 %build
126 %{__libtoolize}
127 %{__aclocal} -I Source/autotools
128 %{__autoconf}
129 %{__autoheader}
130 %{__automake}
131 %if "%{cxx_version}" >= "4.9"
132 CXXFLAGS="%{rpmcxxflags} -fno-delete-null-pointer-checks"
133 %endif
134 %configure \
135 %ifarch %{x8664}
136         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
137 %else
138         LDFLAGS="%{rpmldflags} -fuse-ld=bfd -Wl,--no-keep-memory" \
139 %endif
140         --disable-gtk-doc \
141         --disable-silent-rules \
142         --disable-webkit2 \
143         --enable-geolocation \
144         --enable-glx \
145         %{__enable_disable introspection} \
146         --enable-webgl \
147         --with-gtk=2.0 \
148         --with-html-dir=%{_gtkdocdir}
149
150 %{__make} -j1
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154
155 %{__make} install \
156         DESTDIR=$RPM_BUILD_ROOT
157
158 # obsoleted by pkg-config
159 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*-1.0.la
160 # packaged in gtk-webkit3
161 %{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}/{webkitgtk,webkitdomgtk}
162
163 %find_lang WebKitGTK-2.0
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %post   -p /sbin/ldconfig
169 %postun -p /sbin/ldconfig
170
171 %files -f WebKitGTK-2.0.lang
172 %defattr(644,root,root,755)
173 %doc ChangeLog NEWS
174 %attr(755,root,root) %{_bindir}/jsc-1
175 %attr(755,root,root) %{_libdir}/libwebkitgtk-1.0.so.*.*.*
176 %attr(755,root,root) %ghost %{_libdir}/libwebkitgtk-1.0.so.0
177 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-1.0.so.*.*.*
178 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-1.0.so.0
179 %if %{with introspection}
180 %{_libdir}/girepository-1.0/JavaScriptCore-1.0.typelib
181 %{_libdir}/girepository-1.0/WebKit-1.0.typelib
182 %endif
183 %dir %{_datadir}/webkitgtk-1.0
184 %{_datadir}/webkitgtk-1.0/images
185 %{_datadir}/webkitgtk-1.0/resources
186
187 %files devel
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-1.0.so
190 %attr(755,root,root) %{_libdir}/libwebkitgtk-1.0.so
191 %if %{with introspection}
192 %{_datadir}/gir-1.0/JavaScriptCore-1.0.gir
193 %{_datadir}/gir-1.0/WebKit-1.0.gir
194 %endif
195 %{_includedir}/webkitgtk-1.0
196 %{_pkgconfigdir}/javascriptcoregtk-1.0.pc
197 %{_pkgconfigdir}/webkit-1.0.pc
This page took 0.237817 seconds and 3 git commands to generate.