]> git.pld-linux.org Git - SPECS.git/blob - graphite2.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / graphite2.spec
1 #
2 # Conditional build:
3 %bcond_without  python   # Python module (any)
4 %bcond_without  python2  # CPython 2.x module
5 %bcond_without  python3  # CPython 3.x module
6
7 %if %{without python}
8 %undefine       with_python2
9 %undefine       with_python3
10 %endif
11 Summary:        Font rendering capabilities for complex non-Roman writing systems
12 Summary(pl.UTF-8):      Wsparcie renderowania złożonych systemów pisma nierzymskiego
13 Name:           graphite2
14 Version:        1.3.14
15 Release:        2
16 License:        LGPL v2.1+ or GPL v2+ or MPL
17 Group:          Libraries
18 Source0:        https://downloads.sourceforge.net/silgraphite/%{name}-%{version}.tgz
19 # Source0-md5:  1bccb985a7da01092bfb53bb5041e836
20 Patch0:         %{name}-fix_wrong_linker_opts.patch
21 Patch1:         %{name}-includes-libs-perl.patch
22 Patch2:         %{name}-python.patch
23 URL:            http://graphite.sil.org/
24 BuildRequires:  cmake >= 2.8.0
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  pkgconfig
27 # the rest for tests only
28 BuildRequires:  freetype-devel >= 2
29 BuildRequires:  glib2-devel >= 2.0
30 BuildRequires:  libicu-devel
31 %if %{with python2}
32 BuildRequires:  python-devel >= 1:2.7
33 BuildRequires:  python-setuptools
34 %endif
35 %if %{with python3}
36 BuildRequires:  python3-devel >= 1:3.2
37 BuildRequires:  python3-setuptools
38 BuildRequires:  rpmbuild(macros) >= 1.605
39 %endif
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Graphite is a project within SIL's Non-Roman Script Initiative and
44 Language Software Development groups to provide rendering capabilities
45 for complex non-Roman writing systems. Graphite can be used to create
46 "smart fonts" capable of displaying writing systems with various
47 complex behaviors. With respect to the Text Encoding Model, Graphite
48 handles the "Rendering" aspect of writing system implementation.
49
50 %description -l pl.UTF-8
51 Graphite to projekt w ramach grup SIL Non-Roman Script Initiative
52 (inicjatywy pism nierzymskich SIL) oraz Language Software Development
53 (tworzenia oprogramowania językowego) mający na celu zapewnienie
54 wsparcia dla złożonych systemów pisma nierzymskiego. Graphite może być
55 używany do tworzenia "inteligentnych fontów", będących w stanie
56 wyświelać systemy pisma o różnych złożonych zachowaniach.
57 Uwzględniając model kodowania tekstu (Text Encoding Model) Graphite
58 obsługuje aspekt renderowania całości implementacji systemów pisma.
59
60 %package devel
61 Summary:        Header files for graphite2 library
62 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki graphite2
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       libstdc++-devel
66
67 %description devel
68 Header files for graphite2 library.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe biblioteki graphite2.
72
73 %package -n python-graphite2
74 Summary:        Python 2 interface for graphite2 library
75 Summary(pl.UTF-8):      Interfejs Pythona 2 do biblioteki graphite2
76 Group:          Libraries/Python
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       python-modules >= 1:2.7
79
80 %description -n python-graphite2
81 Python 2 interface for graphite2 library.
82
83 %description -n python-graphite2 -l pl.UTF-8
84 Interfejs Pythona 2 do biblioteki graphite2
85
86 %package -n python3-graphite2
87 Summary:        Python 3 interface for graphite2 library
88 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki graphite2
89 Group:          Libraries/Python
90 Requires:       %{name} = %{version}-%{release}
91 Requires:       python3-modules >= 1:3.2
92
93 %description -n python3-graphite2
94 Python 3 interface for graphite2 library.
95
96 %description -n python3-graphite2 -l pl.UTF-8
97 Interfejs Pythona 3 do biblioteki graphite2
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 %patch1 -p1
103 %patch2 -p1
104
105 %build
106 install -d build
107 cd build
108 %cmake .. \
109         -DGRAPHITE2_VM_TYPE=direct
110
111 %{__make}
112 cd ..
113
114 %if %{with python2}
115 %py_build
116 %endif
117
118 %if %{with python3}
119 %py3_build
120 %endif
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} -C build install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 # cmake's fake (with no dependencies); also obsoleted by pkg-config
129 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgraphite2.la
130
131 %if %{with python2}
132 %py_install
133 %endif
134
135 %if %{with python3}
136 %py3_install
137 %endif
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144
145 %files
146 %defattr(644,root,root,755)
147 %doc COPYING ChangeLog doc/*.txt
148 %attr(755,root,root) %{_bindir}/gr2fonttest
149 %attr(755,root,root) %{_libdir}/libgraphite2.so.*.*.*
150 %attr(755,root,root) %ghost %{_libdir}/libgraphite2.so.3
151
152 %files devel
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/libgraphite2.so
155 %{_includedir}/graphite2
156 %{_pkgconfigdir}/graphite2.pc
157 %{_datadir}/graphite2
158
159 %if %{with python2}
160 %files -n python-graphite2
161 %defattr(644,root,root,755)
162 %{py_sitescriptdir}/graphite2
163 %{py_sitescriptdir}/graphite2-%{version}-py*.egg-info
164 %endif
165
166 %if %{with python3}
167 %files -n python3-graphite2
168 %defattr(644,root,root,755)
169 %{py3_sitescriptdir}/graphite2
170 %{py3_sitescriptdir}/graphite2-%{version}-py*.egg-info
171 %endif
This page took 0.468573 seconds and 3 git commands to generate.