]> git.pld-linux.org Git - SPECS.git/blob - gle.spec
SPECS updated Sun 1 Aug 15:50:02 CEST 2021
[SPECS.git] / gle.spec
1 Summary:        C functions that draw extruded surfaces
2 Summary(pl.UTF-8):      Funkcje C do rysowania skomplikowanych przestrzeni
3 Name:           gle
4 Version:        3.1.0
5 Release:        4
6 License:        IBM (library), Artistic (documentation) or GPL v2
7 Group:          X11/Libraries
8 Source0:        http://downloads.sourceforge.net/gle/%{name}-%{version}.tar.gz
9 # Source0-md5:  da5b45c6906343d4a3672c3de35513ad
10 Patch0:         %{name}-amfix.patch
11 URL:            http://www.linas.org/gle/
12 BuildRequires:  OpenGL-GLU-devel
13 BuildRequires:  OpenGL-glut-devel >= 3.7
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libtool >= 1:1.4.2-9
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 GLE is a library package of C functions that draw extruded surfaces,
21 including surfaces of revolution, sweeps, tubes, polycones,
22 polycylinders and helicoids. Generically, the extruded surface is
23 specified with a 2D polyline that is extruded along a 3D path. A local
24 coordinate system allows for additional flexibility in the primitives
25 drawn. Extrusions may be texture mapped in a variety of ways. The GLE
26 library generates 3D triangle coordinates, lighting normal vectors and
27 texture coordinates as output. GLE uses the GL or OpenGL(R) API's to
28 perform the actual rendering.
29
30 %description -l pl.UTF-8
31 GLE jest biblioteką funkcji C, które pozwalają na rysowanie
32 powierzchni tłoczonych, w tym powierzchni obrotowych, rozciągnięć,
33 walców, stożków i spirali. Ogólnie, powierzchnia tłoczona jest
34 określona krzywą 2D rozciąganą wzdłuż ścieżki w 3D. Lokalny układ
35 współrzędnych pozwala na dodatkową elastyczność przy rysowaniu
36 krzywych. Powierzchnie tłoczone mogą mieć przypisane tekstury na wiele
37 sposobów. Biblioteka GLE generuje współrzędne trójkątów w 3D, wektory
38 normalne dla oświetlenia i współrzędne tekstury; do właściwego
39 renderowania sceny używa API GL lub OpenGL(R).
40
41 %package devel
42 Summary:        Libraries, includes, etc to develop gle applications
43 Summary(pl.UTF-8):      Biblioteki, pliki nagłówkowe i dokumentacja dla programisty gle
44 License:        IBM or GPL (code), Artistic or GPL (examples and docs)
45 Group:          X11/Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       OpenGL-GLU-devel
48
49 %description devel
50 Include files and documentation you can use to develop gle
51 applications.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe i dokumentacja dla programisty gle.
55
56 %package static
57 Summary:        Static gle library
58 Summary(pl.UTF-8):      Biblioteka statyczna libgle
59 Group:          X11/Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static libgle library.
64
65 %description static -l pl.UTF-8
66 Biblioteka statyczna libgle.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71
72 %build
73 %{__libtoolize}
74 %{__aclocal}
75 %{__autoconf}
76 %{__autoheader}
77 %{__automake}
78 %configure
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 %{__make} clean -C examples
90 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
91
92 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc/gle
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc AUTHORS ChangeLog NEWS README COPYING src/COPYING.src
103 %attr(755,root,root) %{_libdir}/libgle.so.*.*.*
104 %attr(755,root,root) %ghost %{_libdir}/libgle.so.3
105
106 %files devel
107 %defattr(644,root,root,755)
108 %doc doc/html/*.{html,gif}
109 %attr(755,root,root) %{_libdir}/libgle.so
110 %{_libdir}/libgle.la
111 %{_includedir}/GL/gle.h
112 %{_mandir}/man3/gle*.3gle*
113 %{_examplesdir}/%{name}-%{version}
114
115 %files static
116 %defattr(644,root,root,755)
117 %{_libdir}/libgle.a
This page took 0.252771 seconds and 3 git commands to generate.