]> git.pld-linux.org Git - SPECS.git/blob - gjs.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / gjs.spec
1 #
2 # Conditional build:
3 %bcond_without  sysprof         # sysprof profiling
4 %bcond_without  systemtap       # systemtap/dtrace trace support
5 #
6 Summary:        JavaScript bindings for GNOME
7 Summary(pl.UTF-8):      Wiązania JavaScriptu dla GNOME
8 Name:           gjs
9 Version:        1.68.1
10 Release:        1
11 License:        MIT and (MPL v1.1 or GPL v2+ or LGPL v2+)
12 Group:          Libraries
13 Source0:        https://download.gnome.org/sources/gjs/1.68/%{name}-%{version}.tar.xz
14 # Source0-md5:  2e41aeb154d62baab4a16a5042e09977
15 URL:            https://wiki.gnome.org/Projects/Gjs
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake >= 1:1.11.1
18 BuildRequires:  cairo-devel
19 BuildRequires:  cairo-gobject-devel
20 BuildRequires:  gettext-tools
21 BuildRequires:  glib2-devel >= 1:2.66.0
22 BuildRequires:  gobject-introspection-devel >= 1.66.1
23 BuildRequires:  libffi-devel
24 BuildRequires:  libstdc++-devel >= 6:7.0
25 BuildRequires:  libtool >= 2:2.2.0
26 BuildRequires:  meson >= 0.52.0
27 BuildRequires:  mozjs78-devel >= 78
28 BuildRequires:  ninja >= 1.5
29 BuildRequires:  pkgconfig
30 BuildRequires:  readline-devel
31 BuildRequires:  rpm-build >= 4.6
32 BuildRequires:  rpmbuild(macros) >= 1.736
33 # pkgconfig(sysprof-capture-4)
34 %{?with_sysprof:BuildRequires:  sysprof-devel >= 3.36}
35 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  xz
38 Requires:       glib2 >= 1:2.66.0
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Gjs allows using GNOME libraries from JavaScript. It is mainly based
43 on Spidermonkey JavaScript engine and the GObject introspection
44 framework.
45
46 %description -l pl.UTF-8
47 Gjs pozwala używać bibliotek GNOME z JavaScriptem. Jest oparty głównie
48 na silniku JavaScriptu Spidermonkey i systemie GObject introspection.
49
50 %package devel
51 Summary:        Header files for gjs library
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gjs
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       cairo-devel
56 Requires:       cairo-gobject-devel
57 Requires:       glib2-devel >= 1:2.66.0
58 Requires:       gobject-introspection-devel >= 1.66.0
59 Requires:       libffi-devel
60 Requires:       mozjs78-devel >= 78
61
62 %description devel
63 Header files for gjs library.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe biblioteki gjs.
67
68 %package -n systemtap-gjs
69 Summary:        systemtap/dtrace probes for gjs
70 Summary(pl.UTF-8):      Sondy systemtap/dtrace dla gjs
71 Group:          Development/Tools
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       systemtap-client
74 BuildArch:      noarch
75
76 %description -n systemtap-gjs
77 systemtap/dtrace probes for gjs.
78
79 %description -n systemtap-gjs -l pl.UTF-8
80 Sondy systemtap/dtrace dla gjs.
81
82 %prep
83 %setup -q
84
85 %build
86 %meson build \
87         -Dprofiler=%{?with_sysprof:enabled}%{!?with_sysprof:disabled} \
88         -Dsystemtap=%{__true_false systemtap} \
89         -Ddtrace=%{__true_false systemtap}
90
91 %ninja_build -C build
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
96
97 %ninja_install -C build
98
99 cp -p examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
100
101 # belongs to installed-tests
102 %{__rm} $RPM_BUILD_ROOT%{_datadir}/glib-2.0/schemas/org.gnome.GjsTest.gschema.xml
103 %{__rm} -r $RPM_BUILD_ROOT{%{_datadir},%{_libexecdir}}/installed-tests
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -p /sbin/ldconfig
109 %postun -p /sbin/ldconfig
110
111 %files
112 %defattr(644,root,root,755)
113 %doc COPYING NEWS README.md
114 %attr(755,root,root) %{_bindir}/gjs
115 %attr(755,root,root) %{_bindir}/gjs-console
116 %attr(755,root,root) %{_libdir}/libgjs.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libgjs.so.0
118 %dir %{_libdir}/gjs
119 %dir %{_libdir}/gjs/girepository-1.0
120 %{_libdir}/gjs/girepository-1.0/GjsPrivate-1.0.typelib
121 %{_datadir}/gjs-1.0
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libgjs.so
126 %{_includedir}/gjs-1.0
127 %{_pkgconfigdir}/gjs-1.0.pc
128 %{_examplesdir}/%{name}-%{version}
129
130 %if %{with systemtap}
131 %files -n systemtap-gjs
132 %defattr(644,root,root,755)
133 %{_datadir}/systemtap/tapset/gjs.stp
134 %endif
This page took 0.078102 seconds and 3 git commands to generate.