]> git.pld-linux.org Git - SPECS.git/blob - ghc-hxt-regex-xmlschema.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / ghc-hxt-regex-xmlschema.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname hxt-regex-xmlschema
6 Summary:        A regular expression library for W3C XML Schema regular expressions
7 Name:           ghc-%{pkgname}
8 Version:        9.2.0.3
9 Release:        1
10 License:        MIT
11 Group:          Development/Languages
12 #Source0Download: http://hackage.haskell.org/package/hxt-regex-xmlschema
13 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
14 # Source0-md5:  7b875bedc63771bad57e42164387c4db
15 URL:            http://hackage.haskell.org/package/hxt-regex-xmlschema
16 BuildRequires:  ghc >= 6.12.3
17 BuildRequires:  ghc-hxt-charproperties
18 %if %{with prof}
19 BuildRequires:  ghc-prof
20 BuildRequires:  ghc-hxt-charproperties-prof
21 %endif
22 BuildRequires:  rpmbuild(macros) >= 1.608
23 %requires_eq    ghc
24 Requires(post,postun):  /usr/bin/ghc-pkg
25 Requires:       ghc-hxt-charproperties
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 # debuginfo is not useful for ghc
29 %define         _enable_debug_packages  0
30
31 # don't compress haddock files
32 %define         _noautocompressdoc      *.haddock
33
34 %description
35 This library supports full W3C XML Schema regular expressions
36 inclusive all Unicode character sets and blocks. The complete grammar
37 can be found under http://www.w3.org/TR/xmlschema11-2/#regexs. It is
38 implemented by the technique of derivations of regular expressions.
39
40 %package prof
41 Summary:        Profiling %{pkgname} library for GHC
42 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       ghc-hxt-charproperties-prof
46
47 %description prof
48 Profiling %{pkgname} library for GHC.  Should be installed when
49 GHC's profiling subsystem is needed.
50
51 %description prof -l pl.UTF-8
52 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
53 kiedy potrzebujemy systemu profilującego z GHC.
54
55 %prep
56 %setup -q -n %{pkgname}-%{version}
57
58 %build
59 runhaskell Setup.hs configure -v2 \
60         %{?with_prof:--enable-library-profiling} \
61         --prefix=%{_prefix} \
62         --libdir=%{_libdir} \
63         --libexecdir=%{_libexecdir} \
64         --docdir=%{_docdir}/%{name}-%{version}
65
66 runhaskell Setup.hs build
67 runhaskell Setup.hs haddock --executables
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
72
73 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
74
75 # work around automatic haddock docs installation
76 %{__rm} -rf %{name}-%{version}-doc
77 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
78 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
79
80 runhaskell Setup.hs register \
81         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post
87 %ghc_pkg_recache
88
89 %postun
90 %ghc_pkg_recache
91
92 %files
93 %defattr(644,root,root,755)
94 %doc %{name}-%{version}-doc/*
95 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
96 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
97 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.so
98 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
99 %exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
100
101 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text
102 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex
103 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Glob
104 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Glob/*.hi
105 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Glob/*.dyn_hi
106 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Glob/Generic
107 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Glob/Generic/*.hi
108 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Glob/Generic/*.dyn_hi
109 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/XMLSchema
110 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/XMLSchema/*.hi
111 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/XMLSchema/*.dyn_hi
112 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/XMLSchema/Generic
113 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/XMLSchema/Generic/*.hi
114 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/XMLSchema/Generic/*.dyn_hi
115
116 %if %{with prof}
117 %files prof
118 %defattr(644,root,root,755)
119 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
120 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Glob/*.p_hi
121 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Glob/Generic/*.p_hi
122 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/XMLSchema/*.p_hi
123 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/XMLSchema/Generic/*.p_hi
124 %endif
This page took 0.116297 seconds and 3 git commands to generate.