]> git.pld-linux.org Git - SPECS.git/blob - gettext.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / gettext.spec
1 #
2 # Conditional build:
3 %bcond_without  asprintf        # libasprintf C++ library
4 %bcond_with     xemacs          # po-mode for xemacs
5 %bcond_without  java            # convenience bcond to disable Java (any)
6 %bcond_with     gcj             # Java support by gcj (preferred over javac)
7 %bcond_without  javac           # Java support by some javac
8 %bcond_without  dotnet          # .NET support package
9 %bcond_with     bootstrap       # no system GLib, libcroco, libxml2 (for bootstrap)
10
11 %ifnarch %{ix86} %{x8664} %{arm} hppa ppc s390 s390x
12 %undefine with_dotnet
13 %endif
14 %ifarch i386
15 # plain i386 is not supported; mono uses cmpxchg/xadd which require i486
16 %undefine with_dotnet
17 %endif
18 %if %{with javac}
19 %undefine with_gcj
20 %endif
21 %if %{without java}
22 %undefine with_gcj
23 %undefine with_javac
24 %endif
25
26 %define build_java      %{?with_gcj:1}%{!?with_gcj:%{?with_javac:1}%{!?with_javac:0}}
27 %define build_javaexe   %{?with_gcj:1}%{!?with_gcj:0}
28 Summary:        Utilties for program national language support
29 Summary(de.UTF-8):      Utilities zum Programmieren von nationaler Sprachunterstützung
30 Summary(es.UTF-8):      Utilitarios para el programa de soporte a lenguas locales
31 Summary(fr.UTF-8):      Utilitaires pour le support de la langue nationnalepar les programmes
32 Summary(ja.UTF-8):      マルチリンガルメッセージを生成するためのGNU ライブラリ/ユーティリティ
33 Summary(pl.UTF-8):      Narzędzia dla programów ze wsparciem dla języków narodowych
34 Summary(pt_BR.UTF-8):   Utilitários para o programa de suporte de línguas locais
35 Summary(ru.UTF-8):      Библиотеки и утилиты для поддержки национальных языков
36 Summary(tr.UTF-8):      Desteği için kitaplık ve araçlar
37 Summary(uk.UTF-8):      Бібліотеки та утиліти для підтримки національних мов
38 Name:           gettext
39 Version:        0.21
40 Release:        1
41 License:        LGPL v2.1+ (libintl), GPL v3+ (tools)
42 Group:          Development/Tools
43 Source0:        https://ftp.gnu.org/gnu/gettext/%{name}-%{version}.tar.xz
44 # Source0-md5:  40996bbaf7d1356d3c22e33a8b255b31
45 Patch0:         %{name}-info.patch
46 Patch1:         %{name}-killkillkill.patch
47 Patch3:         %{name}-libdir.patch
48 URL:            http://www.gnu.org/software/gettext/
49 BuildRequires:  acl-devel
50 BuildRequires:  autoconf >= 2.63
51 BuildRequires:  automake >= 1:1.13
52 %{?with_gcj:BuildRequires:      gcc-java >= 3.0}
53 %{!?with_bootstrap:BuildRequires:       glib2-devel >= 2.0}
54 %if %{build_java}
55 BuildRequires:  jar
56 %endif
57 %{?with_javac:BuildRequires:    jdk >= 1.6}
58 %{!?with_bootstrap:BuildRequires:       libcroco-devel >= 0.6.1}
59 %if "%{cc_version}" >= "4.2"
60 BuildRequires:  libgomp-devel
61 %endif
62 %{?with_asprintf:BuildRequires: libstdc++-devel}
63 BuildRequires:  libtool >= 2:2
64 BuildRequires:  libunistring-devel
65 %{!?with_bootstrap:BuildRequires:       libxml2-devel}
66 %{?with_dotnet:BuildRequires:   mono-csharp}
67 BuildRequires:  ncurses-devel
68 BuildRequires:  rpmbuild(macros) >= 1.453
69 BuildRequires:  sed >= 4.0
70 BuildRequires:  tar >= 1:1.22
71 BuildRequires:  texinfo
72 %{?with_xemacs:BuildRequires:   xemacs}
73 BuildRequires:  xz
74 Obsoletes:      gettext-base
75 Conflicts:      intltool < 0.28
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 # adjust -f when needed (e.g. 0.18.3.x used ABI 0.18.3, 0.19.5.x uses full version)
79 %define         intabi  %(echo %{version} | cut -d. -f1-3)
80 # similarly for its data
81 %define         dataver %(echo %{version} | cut -d. -f1-3)
82
83 %description
84 The GNU gettext package provides a set of tools and documentation for
85 producing multi-lingual messages in programs. Tools include a set of
86 conventions about how programs should be written to support message
87 catalogs, a directory and file naming organization for the message
88 catalogs, a runtime library which supports the retrieval of translated
89 messages, and stand-alone programs for handling the translatable and
90 the already translated strings. Gettext provides an easy to use
91 library and tools for creating, using, and modifying natural language
92 catalogs and is a powerful and simple method for internationalizing
93 programs.
94
95 %description -l de.UTF-8
96 Die gettext-Library enthält eine einfach anzuwendende Library und
97 Tools zum Erstellen, Verwenden und Ändern von
98 natürlichsprachigen-Kataloge. Es ist ein einfaches und
99 leistungsfähiges Verfahren zum Lokalisieren von Programmen.
100
101 %description -l es.UTF-8
102 La biblioteca gettext nos ofrece una biblioteca fácil de usar y
103 herramientas para creación, uso y modificación de catálogos de
104 lenguaje natural. Es un potente y sencillo método de
105 internacionalización de programas.
106
107 %description -l fr.UTF-8
108 La librarie gettext fournit des outils et une librairie simple à
109 utiliser pour manipuler, créer, et modifier des catalogues de langage
110 naturel. C'est une méthode simple et puissante pour internationnaliser
111 les programmes.
112
113 %description -l ja.UTF-8
114 GNU gettext
115 パッケージはプログラム中でマルチリンガルメッセージを生成する
116 ためのツールと文書を供給する。ツールはメッセージカタログをサポートするために
117 プログラムがどのように書かれるべきかの申し合わせと、メッセージカタログのための
118 ディレクトリとファイル名の組織化と、翻訳されたメッセージの埋め合わせを
119 サポートするためのランタイムライブラリと、翻訳可能でかつすでに翻訳された文字列
120 を取り扱う独立したプログラムを含んでいる。gettext
121 は簡単に使えるライブラリ
122 と自然言語のカタログを生成、使用、修正するツールと、国際化プログラム
123 のための強力かつシンプルな方法を供給する。
124
125 %description -l pl.UTF-8
126 Pakiet gettext dostarcza narzędzi do tworzenia, używania i modyfikacji
127 katalogów języków narodowych. To jest prosta i wydajna metoda
128 lokalizacji (internacjonalizacji) programów.
129
130 %description -l pt_BR.UTF-8
131 A biblioteca gettext oferece uma biblioteca fácil de usar e
132 ferramentas para criação, uso e modificação de catálogos de linguagem
133 natural. Ele é um poderoso e simples método de internacionalização de
134 programas.
135
136 %description -l ru.UTF-8
137 Пакет gettext содержит библиотеку и простые в использовании
138 инструменты для создания, использования и модификации каталогов
139 национальных языков. Это простой и мощный метод для
140 интернационализации программ.
141
142 %description -l tr.UTF-8
143 gettext, yerel dil desteğinde kullanılan katalogları değiştirebilmek
144 için, kolayca kullanılabilen kitaplık ve araçları sağlar. Bu,
145 programları uluslararasılaştırmak için sıkça başvurulan, kuvvetli bir
146 yöntemdir.
147
148 %description -l uk.UTF-8
149 Пакет gettext містить бібліотеку та прості у використанні інструменти
150 для створення, використання та модифікації каталогів національних мов.
151 Це простий та потужний метод для інтернаціоналізації програм.
152
153 %package tools
154 Summary:        Utilties for program national language support
155 Summary(de.UTF-8):      Utilities zum Programmieren von nationaler Sprachunterstützung
156 Summary(fr.UTF-8):      Utilitaires pour le support de la langue nationnalepar les programmes
157 Summary(pl.UTF-8):      Narzędzia dla programów ze wsparciem dla języków narodowych
158 Summary(tr.UTF-8):      Desteği için kitaplık ve araçlar
159 License:        GPL v3+
160 Group:          Development/Tools
161 Requires(post,postun):  /sbin/ldconfig
162 Requires:       %{name}-libs = %{version}-%{release}
163 Requires:       iconv
164 Conflicts:      autoconf < 2.52
165 Conflicts:      rpm-build-macros < 1.744
166
167 %description tools
168 This package contains tools for creating and modifying natural
169 language catalogs.
170
171 %description tools -l pl.UTF-8
172 Ten pakiet zawiera narzędzia do tworzenia i modyfikowania katalogów
173 z obsługą języków naturalnych.
174
175 %package demo
176 Summary:        Demo for gettext
177 Summary(pl.UTF-8):      Pliki demonstracyjne dla pakietu gettext
178 Group:          Documentation
179 Requires:       %{name}-devel = %{version}-%{release}
180
181 %description demo
182 Demonstrations and samples for gettext.
183
184 %description demo -l pl.UTF-8
185 Pliki demonstracyjne i przykłady dla pakietu gettext.
186
187 %package libs
188 Summary:        Shared gettext utility libraries
189 Summary(pl.UTF-8):      Współdzielone biblioteki narzędziowe gettexta
190 License:        GPL v3+
191 Group:          Development/Libraries
192 # relaxed to allow newer package from libtextstyle.spec
193 Requires:       libtextstyle >= %{version}-%{release}
194
195 %description libs
196 This package contains shared versions of gettext utility libraries
197 (libgettextlib, libgettextsrc and libgettextpo).
198
199 %description libs -l pl.UTF-8
200 Ten pakiet zawiera współdzielone wersje bibliotek narzędziowych
201 gettext (libgettextlib, libgettextsrc i libgettextpo).
202
203 %package devel
204 Summary:        Development files for gettext libraries
205 Summary(pl.UTF-8):      Pliki programistyczne bibliotek gettexta
206 License:        GPL v3+
207 Group:          Development/Libraries
208 Requires:       %{name}-libs = %{version}-%{release}
209 # relaxed to allow newer package from libtextstyle.spec
210 Requires:       libtextstyle-devel >= %{version}-%{release}
211
212 %description devel
213 Development files for gettext libraries.
214
215 %description devel -l pl.UTF-8
216 Pliki programistyczne bibliotek gettexta.
217
218 %package static
219 Summary:        Static gettext utility libraries
220 Summary(pl.UTF-8):      Statyczne biblioteki narzędziowe gettext
221 License:        GPL v3+
222 Group:          Development/Libraries
223 Requires:       %{name}-devel = %{version}-%{release}
224
225 %description static
226 This package contains static versions of gettext utility libraries
227 (libgettextlib, libgettextsrc and libgettextpo).
228
229 %description static -l pl.UTF-8
230 Ten pakiet zawiera statyczne wersje bibliotek narzędziowych gettext
231 (libgettextlib, libgettextsrc i libgettextpo).
232
233 %package -n libasprintf
234 Summary:        GNU libasprintf - automatic formatted output to strings in C++
235 Summary(pl.UTF-8):      GNU libasprintf - automatyczne formatowanie wyjścia do łańcuchów w C++
236 License:        LGPL v2.1+
237 Group:          Libraries
238
239 %description -n libasprintf
240 This package makes the C formatted output routines (`fprintf' et al.)
241 usable in C++ programs, for use with the `<string>' strings and the
242 `<iostream>' streams.
243
244 %description -n libasprintf -l pl.UTF-8
245 Ten pakiet czyni funkcje C formatujące wyjście (fprintf i inne)
246 używalnymi w programach w C++, z łańcuchami <string> i strumieniami
247 <iostream>.
248
249 %package -n libasprintf-devel
250 Summary:        Header file and documentation for libasprintf
251 Summary(pl.UTF-8):      Plik nagłówkowy i dokumentacja dla libasprintf
252 License:        LGPL v2.1+
253 Group:          Development/Libraries
254 Requires:       libasprintf = %{version}-%{release}
255
256 %description -n libasprintf-devel
257 Header file and documentation for libasprintf.
258
259 %description -n libasprintf-devel -l pl.UTF-8
260 Plik nagłówkowy i dokumentacja dla libasprintf.
261
262 %package -n libasprintf-static
263 Summary:        Static libasprintf library
264 Summary(pl.UTF-8):      Statyczna biblioteka libasprintf
265 License:        LGPL v2.1+
266 Group:          Development/Libraries
267 Requires:       libasprintf-devel = %{version}-%{release}
268
269 %description -n libasprintf-static
270 Static libasprintf library.
271
272 %description -n libasprintf-static -l pl.UTF-8
273 Statyczna biblioteka libasprintf.
274
275 %package -n libtextstyle
276 Summary:        GNU libtextstyle - Text styling library
277 Summary(pl.UTF-8):      GNU libtextstyle - biblioteka do obsługi stylu tekstu
278 License:        GPL v3+
279
280 %description -n libtextstyle
281 This library provides an easy way to add styling to programs that
282 produce output to a console or terminal emulator window.
283
284 libtextstyle is for you if your application produces text that is more
285 readable when it is accompanied with styling information, such as
286 color, font attributes (weight, posture), or underlining.
287
288 %description -n libtextstyle -l pl.UTF-8
289 Ta biblioteka zapewnia łatwy sposób dodawania styli do programów
290 produkujących wyjście na konsoli lub w oknie emulatora terminala.
291
292 libtextstyle ma zastosowanie tam, gdzie aplikacja produkuje tekst,
293 który jest bardziej czytelny, jeśli jest wzbogacony o informacje o
294 stylu, takie jak kolor, atrybuty czcionek (grubość, nachylenie) lub
295 podkreślenie.
296
297 %package -n libtextstyle-devel
298 Summary:        Header files for libtextstyle library
299 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libtextstyle
300 License:        GPL v3+
301 Group:          Development/Libraries
302 Requires:       libtextstyle = %{version}-%{release}
303 Requires:       ncurses-devel
304
305 %description -n libtextstyle-devel
306 Header files for libtextstyle library.
307
308 %description -n libtextstyle-devel -l pl.UTF-8
309 Pliki nagłówkowe biblioteki libtextstyle.
310
311 %package -n libtextstyle-static
312 Summary:        Static libtextstyle library
313 Summary(pl.UTF-8):      Statyczna biblioteka libtextstyle
314 License:        GPL v3+
315 Group:          Development/Libraries
316 Requires:       libtextstyle-devel = %{version}-%{release}
317
318 %description -n libtextstyle-static
319 Static libtextstyle library.
320
321 %description -n libtextstyle-static -l pl.UTF-8
322 Statyczna biblioteka libtextstyle.
323
324 %package java
325 Summary:        Runtime classes for Java programs internationalization
326 Summary(pl.UTF-8):      Klasy do uruchamiania umiędzynarodowionych programów w Javie
327 License:        LGPL v2.1+
328 Group:          Development/Languages/Java
329 Requires:       %{name} = %{version}-%{release}
330
331 %description java
332 Runtime classes for Java programs internationalization.
333
334 %description java -l pl.UTF-8
335 Klasy do uruchamiania umiędzynarodowionych programów w Javie.
336
337 %package java-devel
338 Summary:        Development classes for Java programs internationalization
339 Summary(pl.UTF-8):      Klasy do umiędzynarodowiania programów w Javie dla programistów
340 License:        GPL v3+
341 Group:          Development/Tools
342 Requires:       %{name}-devel = %{version}-%{release}
343
344 %description java-devel
345 Development classes for Java programs internationalization.
346
347 %description java-devel -l pl.UTF-8
348 Klasy do umiędzynarodowiania programów w Javie dla programistów.
349
350 %package -n xemacs-po-mode-pkg
351 Summary:        Xemacs PO-mode
352 Summary(es.UTF-8):      Facilita la edición de archivos PO (internacionalización) con emacs
353 Summary(pl.UTF-8):      Tryb PO dla Xemacsa
354 Summary(pt_BR.UTF-8):   Facilita a edição de arquivos PO (internacionalização) com o emacs
355 License:        GPL v2+
356 Group:          Applications/Editors/Emacs
357 Requires:       xemacs
358
359 %description -n xemacs-po-mode-pkg
360 Emacs PO-mode.
361
362 %description -n xemacs-po-mode-pkg -l es.UTF-8
363 Este paquete suministra las herramientas para ayudar en la edición de
364 archivos PO, como documentado en el manual del usuario del GNU
365 gettext. Mira este manual para la documentación de uso, que no se
366 incluye aquí.
367
368 %description -n xemacs-po-mode-pkg -l pl.UTF-8
369 Tryb edycji PO dla emacsa.
370
371 %description -n xemacs-po-mode-pkg -l pt_BR.UTF-8
372 Este pacote provê as ferramentas para ajudar na edição de arquivos PO,
373 como documentado no manual do usuário do GNU gettext. Veja este manual
374 para a documentação de uso, a qual não é incluída aqui.
375
376 %package autopoint
377 Summary:        gettextize replacement
378 Summary(pl.UTF-8):      Zamiennik gettextize
379 License:        GPL v3+
380 Group:          Development/Tools
381 Requires:       %{name}-devel >= 0.10.35
382 Requires:       xz
383
384 %description autopoint
385 The `autopoint' program copies standard gettext infrastructure files
386 into a source package. It extracts from a macro call of the form
387 `AM_GNU_GETTEXT_VERSION(VERSION)', found in the package's
388 `configure.in' or `configure.ac' file, the gettext version used by the
389 package, and copies the infrastructure files belonging to this version
390 into the package.
391
392 %description autopoint -l pl.UTF-8
393 Program autopoint kopiuje standardowe pliki infrastruktury gettexta do
394 pakietu źródłowego. Wyciąga użytą wersję gettexta z wywołania makra w
395 postaci AM_GNU_GETTEXT_VERSION(VERSION) w pliku configure.in lub
396 configure.ac i kopiuje do pakietu pliki infrastruktury należące do tej
397 wersji.
398
399 %package -n dotnet-gettext
400 Summary:        GNU gettext for C#
401 Summary(pl.UTF-8):      GNU gettext dla C#
402 License:        LGPL v2.1+ (GNU.Gettext library), GPL v3+ (tools)
403 Group:          Development/Tools
404
405 %description -n dotnet-gettext
406 GNU gettext for C#.
407
408 %description -n dotnet-gettext -l pl.UTF-8
409 GNU gettext dla C#.
410
411 %prep
412 %setup -q
413 %patch0 -p1
414 %patch1 -p1
415 %patch3 -p1
416
417 %{__sed} -i \
418         -e 's@m4_esyscmd(\[build-aux/git-version-gen \.tarball-version\])@[%{version}]@' \
419         configure.ac
420 %{__sed} -i \
421         -e 's@m4_esyscmd(\[\.\./build-aux/git-version-gen \.\./\.tarball-version\])@[%{version}]@' \
422         gettext-runtime/configure.ac \
423         gettext-tools/configure.ac
424
425 %if %{without bootstrap}
426 %{__sed} -i -e '/gl_LIBCROCO\|gl_LIBGLIB\|gl_LIBXML/s/(\[yes\])//' libtextstyle/gnulib-m4/gnulib-comp.m4
427 %endif
428
429 %build
430 cd gettext-runtime
431 %{__libtoolize}
432 %{__aclocal} -I m4 -I ../m4 -I gnulib-m4
433 %{__autoconf}
434 %{__autoheader}
435 %{__automake}
436 cd libasprintf
437 %{__aclocal} -I ../../m4 -I ../m4 -I gnulib-m4
438 %{__autoconf}
439 %{__autoheader}
440 %{__automake}
441 cd ../../libtextstyle
442 %{__libtoolize}
443 %{__aclocal} -I m4 -I gnulib-m4
444 %{__autoconf}
445 %{__autoheader}
446 %{__automake}
447 cd ../gettext-tools
448 %{__aclocal} -I m4 -I ../gettext-runtime/m4 -I ../m4 -I gnulib-m4 -I libgrep/gnulib-m4 -I libgettextpo/gnulib-m4
449 %{__autoconf}
450 %{__autoheader}
451 %{__automake}
452 cd examples
453 %{__aclocal} -I ../../gettext-runtime/m4 -I ../../m4
454 %{__autoconf}
455 %{__automake}
456 cd ../..
457 %{__aclocal} -I m4
458 %{__autoconf}
459 %{__automake}
460 %configure \
461         %{!?with_gcj:GCJ=none} \
462         %{?with_xemacs:--with-lispdir=%{_datadir}/xemacs-packages/lisp/po-mode} \
463         %{!?with_xemacs:--without-emacs} \
464         --enable-csharp=%{?with_dotnet:mono}%{!?with_dotnet:no} \
465 %if !%{build_java}
466         --disable-java \
467 %endif
468         --enable-nls \
469         --disable-silent-rules \
470         --without-bzip2 \
471         --without-git \
472         --without-included-gettext \
473         --with-xz
474 %{__make} \
475         GMSGFMT=`pwd`/gettext-tools/src/msgfmt
476
477 # msgfmt has been built, so now we can update pl.gmos
478 %{__make} pl.gmo -C gettext-runtime/po \
479         GMSGFMT=`pwd`/gettext-tools/src/msgfmt
480 %{__make} pl.gmo -C gettext-tools/po \
481         GMSGFMT=`pwd`/gettext-tools/src/msgfmt
482
483 %if %{with xemacs}
484 cd gettext-tools/misc
485 EMACS=%{_bindir}/xemacs ./elisp-comp ./po-mode.el
486 %endif
487
488 %install
489 rm -rf $RPM_BUILD_ROOT
490 install -d $RPM_BUILD_ROOT{/bin,%{_datadir}/gettext/its}
491
492 %{__make} install \
493         examplesdir=%{_examplesdir}/%{name}-%{version} \
494         examplesbuildauxdir=%{_examplesdir}/%{name}-%{version}/build-aux \
495         DESTDIR=$RPM_BUILD_ROOT
496
497 %{__mv} $RPM_BUILD_ROOT%{_bindir}/{,n}gettext $RPM_BUILD_ROOT/bin
498
499 # these static libs are removed in install-exec-clean
500 cp -a gettext-tools/gnulib-lib/.libs/libgettextlib.a \
501         gettext-tools/src/.libs/libgettextsrc.a $RPM_BUILD_ROOT%{_libdir}
502
503 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/gettext
504 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libasprintf
505 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libtextstyle
506 %{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
507
508 %find_lang %{name}-runtime
509 %find_lang %{name}-tools
510
511 %clean
512 rm -rf $RPM_BUILD_ROOT
513
514 %post   tools -p /sbin/postshell
515 -/usr/sbin/fix-info-dir -c %{_infodir}
516
517 %postun tools -p /sbin/postshell
518 -/usr/sbin/fix-info-dir -c %{_infodir}
519
520 %post   libs -p /sbin/ldconfig
521 %postun libs -p /sbin/ldconfig
522
523 %post   devel -p /sbin/postshell
524 -/usr/sbin/fix-info-dir -c %{_infodir}
525
526 %postun devel -p /sbin/postshell
527 -/usr/sbin/fix-info-dir -c %{_infodir}
528
529 %post   -n libasprintf -p /sbin/ldconfig
530 %postun -n libasprintf -p /sbin/ldconfig
531
532 %post   -n libasprintf-devel -p /sbin/postshell
533 -/usr/sbin/fix-info-dir -c %{_infodir}
534
535 %postun -n libasprintf-devel -p /sbin/postshell
536 -/usr/sbin/fix-info-dir -c %{_infodir}
537
538 %post   -n libtextstyle -p /sbin/ldconfig
539 %postun -n libtextstyle -p /sbin/ldconfig
540
541 %post   -n libtextstyle-devel -p /sbin/postshell
542 -/usr/sbin/fix-info-dir -c %{_infodir}
543
544 %postun -n libtextstyle-devel -p /sbin/postshell
545 -/usr/sbin/fix-info-dir -c %{_infodir}
546
547 %files -f %{name}-runtime.lang
548 %defattr(644,root,root,755)
549 %attr(755,root,root) /bin/gettext
550 %attr(755,root,root) /bin/ngettext
551 %attr(755,root,root) %{_bindir}/envsubst
552 %attr(755,root,root) %{_bindir}/gettext.sh
553 %{_mandir}/man1/envsubst.1*
554 %{_mandir}/man1/gettext.1*
555 %{_mandir}/man1/ngettext.1*
556 %dir %{_libdir}/gettext
557 %dir %{_datadir}/gettext
558
559 %files tools
560 %defattr(644,root,root,755)
561 %doc AUTHORS ChangeLog NEWS README THANKS
562 %attr(755,root,root) %{_bindir}/gettextize
563 %attr(755,root,root) %{_bindir}/msg*
564 %attr(755,root,root) %{_bindir}/recode-sr-latin
565 %attr(755,root,root) %{_bindir}/xgettext
566 %attr(755,root,root) %{_libdir}/preloadable_libintl.so
567 %attr(755,root,root) %{_libdir}/gettext/cldr-plurals
568 %attr(755,root,root) %{_libdir}/gettext/hostname
569 %attr(755,root,root) %{_libdir}/gettext/project-id
570 %attr(755,root,root) %{_libdir}/gettext/urlget
571 %attr(755,root,root) %{_libdir}/gettext/user-email
572 %{_aclocaldir}/gettext.m4
573 %{_aclocaldir}/host-cpu-c-abi.m4
574 %{_aclocaldir}/iconv.m4
575 %{_aclocaldir}/intlmacosx.m4
576 %{_aclocaldir}/lib-ld.m4
577 %{_aclocaldir}/lib-link.m4
578 %{_aclocaldir}/lib-prefix.m4
579 %{_aclocaldir}/nls.m4
580 %{_aclocaldir}/po.m4
581 %{_aclocaldir}/progtest.m4
582 %{_infodir}/gettext.info*
583 %{_mandir}/man1/gettextize.1*
584 %{_mandir}/man1/msg*.1*
585 %{_mandir}/man1/recode-sr-latin.1*
586 %{_mandir}/man1/xgettext.1*
587 %{_mandir}/man3/bind_textdomain_codeset.3*
588 %{_mandir}/man3/bindtextdomain.3*
589 %{_mandir}/man3/dcgettext.3*
590 %{_mandir}/man3/dcngettext.3*
591 %{_mandir}/man3/dgettext.3*
592 %{_mandir}/man3/dngettext.3*
593 %{_mandir}/man3/gettext.3*
594 %{_mandir}/man3/ngettext.3*
595 %{_mandir}/man3/textdomain.3*
596 %{_datadir}/gettext/ABOUT-NLS
597 %attr(755,root,root) %{_datadir}/gettext/config.rpath
598 %{_datadir}/gettext/gettext.h
599 %dir %{_datadir}/gettext/its
600 %{_datadir}/gettext/msgunfmt.tcl
601 %{_datadir}/gettext/po
602 %dir %{_datadir}/gettext/projects
603 %{_datadir}/gettext/projects/index
604 %attr(755,root,root) %{_datadir}/gettext/projects/team-address
605 %dir %{_datadir}/gettext/projects/GNOME
606 %{_datadir}/gettext/projects/GNOME/teams.*
607 %attr(755,root,root) %{_datadir}/gettext/projects/GNOME/team-address
608 %attr(755,root,root) %{_datadir}/gettext/projects/GNOME/trigger
609 %dir %{_datadir}/gettext/projects/KDE
610 %{_datadir}/gettext/projects/KDE/teams.*
611 %attr(755,root,root) %{_datadir}/gettext/projects/KDE/team-address
612 %attr(755,root,root) %{_datadir}/gettext/projects/KDE/trigger
613 %dir %{_datadir}/gettext/projects/TP
614 %{_datadir}/gettext/projects/TP/teams.*
615 %attr(755,root,root) %{_datadir}/gettext/projects/TP/team-address
616 %attr(755,root,root) %{_datadir}/gettext/projects/TP/trigger
617 %{_datadir}/gettext/styles
618 %dir %{_datadir}/gettext-%{dataver}
619 %{_datadir}/gettext-%{dataver}/its
620
621 %files demo
622 %defattr(644,root,root,755)
623 %{_examplesdir}/%{name}-%{version}
624
625 %files libs -f %{name}-tools.lang
626 %defattr(644,root,root,755)
627 %attr(755,root,root) %{_libdir}/libgettextlib-%{intabi}.so
628 %attr(755,root,root) %{_libdir}/libgettextsrc-%{intabi}.so
629 %attr(755,root,root) %{_libdir}/libgettextpo.so.*.*.*
630 %attr(755,root,root) %ghost %{_libdir}/libgettextpo.so.0
631
632 %files devel
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{_libdir}/libgettextlib.so
635 %attr(755,root,root) %{_libdir}/libgettextsrc.so
636 %attr(755,root,root) %{_libdir}/libgettextpo.so
637 %{_libdir}/libgettextlib.la
638 %{_libdir}/libgettextsrc.la
639 %{_libdir}/libgettextpo.la
640 %{_includedir}/gettext-po.h
641
642 %files static
643 %defattr(644,root,root,755)
644 %{_libdir}/libgettextlib.a
645 %{_libdir}/libgettextsrc.a
646 %{_libdir}/libgettextpo.a
647
648 %if %{with asprintf}
649 %files -n libasprintf
650 %defattr(644,root,root,755)
651 %doc gettext-runtime/libasprintf/{AUTHORS,ChangeLog,README}
652 %attr(755,root,root) %{_libdir}/libasprintf.so.*.*.*
653 %attr(755,root,root) %ghost %{_libdir}/libasprintf.so.0
654
655 %files -n libasprintf-devel
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_libdir}/libasprintf.so
658 %{_libdir}/libasprintf.la
659 %{_includedir}/autosprintf.h
660 %{_infodir}/autosprintf.info*
661
662 %files -n libasprintf-static
663 %defattr(644,root,root,755)
664 %{_libdir}/libasprintf.a
665 %endif
666
667 %files -n libtextstyle
668 %defattr(644,root,root,755)
669 %doc libtextstyle/{AUTHORS,NEWS,README}
670 %attr(755,root,root) %{_libdir}/libtextstyle.so.*.*.*
671 %attr(755,root,root) %ghost %{_libdir}/libtextstyle.so.0
672
673 %files -n libtextstyle-devel
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_libdir}/libtextstyle.so
676 %{_libdir}/libtextstyle.la
677 %{_includedir}/textstyle.h
678 %{_includedir}/textstyle
679 %{_infodir}/libtextstyle.info*
680
681 %files -n libtextstyle-static
682 %defattr(644,root,root,755)
683 %{_libdir}/libtextstyle.a
684
685 %if %{build_java}
686 %files java
687 %defattr(644,root,root,755)
688 %{_datadir}/gettext/libintl.jar
689
690 %files java-devel
691 %defattr(644,root,root,755)
692 %doc gettext-runtime/intl-java/javadoc2
693 %if %{build_javaexe}
694 %attr(755,root,root) %{_libdir}/gettext/gnu.gettext.DumpResource
695 %attr(755,root,root) %{_libdir}/gettext/gnu.gettext.GetURL
696 %else
697 %{_datadir}/gettext/gettext.jar
698 %endif
699 %{_datadir}/gettext/javaversion.class
700 %endif
701
702 %if %{with xemacs}
703 %files -n xemacs-po-mode-pkg
704 %defattr(644,root,root,755)
705 %dir %{_datadir}/xemacs-packages/lisp/po-mode
706 %{_datadir}/xemacs-packages/lisp/po-mode/*.elc
707 %endif
708
709 %files autopoint
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_bindir}/autopoint
712 %{_datadir}/gettext/archive.dir.tar.xz
713 %{_mandir}/man1/autopoint.1*
714
715 %if %{with dotnet}
716 %files -n dotnet-gettext
717 %defattr(644,root,root,755)
718 %{_libdir}/GNU.Gettext.dll
719 %{_libdir}/gettext/msgfmt.net.exe
720 %{_libdir}/gettext/msgunfmt.net.exe
721 %endif
This page took 0.925441 seconds and 3 git commands to generate.