]> git.pld-linux.org Git - SPECS.git/blob - gcl.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / gcl.spec
1 # TODO:
2 # - package tk-demos?
3 # - package emacs-lisp files (if building with xemacs)
4 #
5 # Conditional build:
6 %bcond_without  xemacs  # don't build/package emacs-lisp parts
7 #
8 %define tk_ver  8.5
9 Summary:        GNU Common Lisp system
10 Summary(pl.UTF-8):      System GNU Common Lisp
11 Name:           gcl
12 Version:        2.6.10
13 Release:        1
14 License:        LGPL v2
15 Group:          Development/Languages
16 Source0:        http://ftp.gnu.org/gnu/gcl/%{name}-%{version}.tar.gz
17 # Source0-md5:  7cb9c388e9e77696f4e27e7a1d118524
18 Patch0:         %{name}-make.patch
19 Patch1:         %{name}-info.patch
20 Patch2:         %{name}-format.patch
21 URL:            http://www.gnu.org/software/gcl/
22 BuildRequires:  autoconf >= 2.61
23 BuildRequires:  automake
24 BuildRequires:  gmp-devel >= 4.0
25 BuildRequires:  readline-devel
26 BuildRequires:  texinfo
27 BuildRequires:  tk-devel >= %{tk_ver}
28 %{?with_xemacs:BuildRequires:   xemacs}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 The GNU Common Lisp system, based on KCL.
33
34 %description -l pl.UTF-8
35 System GNU Common Lisp, bazujÄ…cy na KCL.
36
37 %package tk
38 Summary:        Tcl/Tk bindings for GNU Common Lisp
39 Summary(pl.UTF-8):      Interfejs Tcl/Tk do GNU Common Lisp
40 Group:          Development/Languages
41 Requires:       %{name} = %{version}-%{release}
42
43 %description tk
44 Tcl/Tk bindings for GNU Common Lisp.
45
46 %description tk -l pl.UTF-8
47 Interfejs Tcl/Tk dla GNU Common Lisp.
48
49 %prep
50 %setup -q -n %{name}
51 %patch0 -p1
52 %patch1 -p1
53 %patch2 -p1
54
55 %build
56 %{__aclocal}
57 %{__autoconf}
58 cp -f /usr/share/automake/config.* .
59 GCC="%{__cc}"; export GCC
60 %configure \
61         %{?with_xemacs:EMACS=/usr/bin/xemacs} \
62         --enable-dynsysgmp \
63         --enable-notify=no
64
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1}
70
71 %{__make} install1 \
72         DESTDIR=$RPM_BUILD_ROOT \
73         INSTALL_LIB_DIR=%{_libdir}/gcl
74
75 mv -f $RPM_BUILD_ROOT%{_libdir}/gcl/info/* $RPM_BUILD_ROOT%{_infodir}
76 rmdir $RPM_BUILD_ROOT%{_libdir}/gcl/info
77
78 install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
79
80 ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
81
82 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
83 #!/bin/sh
84 exec %{_libdir}/gcl/unixport/saved_gcl \
85         -dir %{_libdir}/gcl/unixport/ \
86         -libdir %{_libdir}/gcl/ \
87         -eval '(setq si::*allow-gzipped-file* t)' \
88         "$@"
89 EOF
90
91 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
92 #!/bin/sh
93 exec %{_libdir}/gcl/unixport/saved_gcl \
94         -dir %{_libdir}/gcl/unixport/ \
95         -libdir %{_libdir}/gcl/ \
96         -eval '(setq si::*allow-gzipped-file* t)' \
97         -eval '(setq si::*tk-library* "/usr/lib/tk%{tk_ver}")' \
98         "$@"
99 EOF
100
101 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/{dwdoc*,gcl-si*,gcl-tk*}
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/postshell
107 -/usr/sbin/fix-info-dir -c %{_infodir}
108
109 %postun -p /sbin/postshell
110 -/usr/sbin/fix-info-dir -c %{_infodir}
111
112 %post   tk -p /sbin/postshell
113 -/usr/sbin/fix-info-dir -c %{_infodir}
114
115 %postun tk -p /sbin/postshell
116 -/usr/sbin/fix-info-dir -c %{_infodir}
117
118 %files
119 %defattr(644,root,root,755)
120 %doc readme faq ChangeLog
121 %attr(755,root,root) %{_bindir}/gcl
122 %attr(755,root,root) %{_bindir}/gcl.exe
123 %dir %{_libdir}/gcl
124 %{_libdir}/gcl/clcs
125 %{_libdir}/gcl/cmpnew
126 %{_libdir}/gcl/h
127 %{_libdir}/gcl/lsp
128 %{_libdir}/gcl/pcl
129 %{_libdir}/gcl/xgcl-2
130 %dir %{_libdir}/gcl/unixport
131 %attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
132 %{_libdir}/gcl/unixport/*.lsp
133 %{_libdir}/gcl/unixport/gcl.script
134 # to -devel?
135 %{_libdir}/gcl/unixport/libgcl.a
136 %{_libdir}/gcl/unixport/libgclp.a
137 %{_infodir}/gcl-si.info*
138 %{_mandir}/man1/gcl.1*
139
140 %files tk
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_bindir}/gcl-tk
143 %dir %{_libdir}/gcl/gcl-tk
144 %attr(755,root,root) %{_libdir}/gcl/gcl-tk/gcltkaux
145 %attr(755,root,root) %{_libdir}/gcl/gcl-tk/gcltksrv
146 %{_libdir}/gcl/gcl-tk/*.o
147 %{_libdir}/gcl/gcl-tk/*.tcl
148 %{_libdir}/gcl/gcl-tk/tk-package.lsp
149 %{_infodir}/gcl-tk.info*
This page took 0.078466 seconds and 3 git commands to generate.