]> git.pld-linux.org Git - SPECS.git/blob - eclipse-adt.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / eclipse-adt.spec
1 # TODO
2 # - how to (where to?) package web and xml and index.html
3 Summary:        ADT Plugin for Eclipse
4 Name:           eclipse-adt
5 Version:        22.0.5
6 Release:        1
7 License:        EPL v1.0
8 Group:          Libraries/Java
9 Obsoletes:      eclipse-plugin-adt
10 Source0:        http://dl.google.com/android/ADT-%{version}.zip
11 # Source0-md5:  1097fccf32063e3638a9d27aa0f295ca
12 URL:            http://developer.android.com/sdk/eclipse-adt.html
13 BuildRequires:  jpackage-utils
14 BuildRequires:  rpm-javaprov
15 BuildRequires:  rpmbuild(macros) >= 1.300
16 BuildRequires:  unzip
17 Requires:       eclipse >= 3.6.2
18 Requires:       eclipse-gef
19 Requires:       eclipse-jdt
20 Requires:       eclipse-plugin-webtools
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         eclipsedir      %{_libdir}/eclipse/dropins/adt
24
25 %description
26 Android Development Tools (ADT) is a plugin for the Eclipse IDE that
27 is designed to give you a powerful, integrated environment in which to
28 build Android applications.
29
30 %prep
31 %setup -qc
32 find -name '*.jar' | while read jar; do
33         dir=${jar%.jar}
34         install -d $dir
35         %{__unzip} -qq $jar -d $dir
36         rm $jar
37 done
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT%{eclipsedir}/{features,plugins}
42
43 cp -a features/* $RPM_BUILD_ROOT%{eclipsedir}/features
44 cp -a plugins/* $RPM_BUILD_ROOT%{eclipsedir}/plugins
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %dir %{eclipsedir}
52 %dir %{eclipsedir}/features
53 %dir %{eclipsedir}/plugins
54 %{eclipsedir}/features/com.android.ide.eclipse.*
55 %{eclipsedir}/plugins/com.android.ide.eclipse.*
56 %{eclipsedir}/plugins/overlay.com.android.ide.eclipse.adt.*
This page took 0.040304 seconds and 3 git commands to generate.