]> git.pld-linux.org Git - SPECS.git/blob - docker-ce.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / docker-ce.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4 %bcond_with     vim                     # build vim syntax package (bundled in vim 7.4.979-2)
5 %bcond_with     doc                     # build manual pages
6
7 # TODO: drop P docker when docker-compose updated to use docker(engine) dep
8
9 # NOTES
10 # - https://github.com/docker/docker-ce/releases
11 # - https://github.com/moby/moby/blob/master/project/PACKAGERS.md#build-dependencies
12
13 # v1.0.0-rc10
14 %define runc_commit dc9208a
15 # v1.3.9
16 %define containerd_commit ea765ab
17 # v0.8.0-dev.2-1075-g1b91bc94
18 %define libnetwork_commit 55e924b
19 #define subver -rc2
20 Summary:        Docker CE: the open-source application container engine
21 Name:           docker-ce
22 # Using Docker-CE, Stay on Stable channel
23 # https://docs.docker.com/engine/installation/
24 Version:        19.03.14
25 Release:        1
26 License:        Apache v2.0
27 Group:          Applications/System
28 # https://github.com/docker/docker-ce/releases
29 #Source0:       https://github.com/docker/docker-ce/archive/v%{version}-ce%{subver}/%{name}-%{version}-ce%{subver}.tar.gz
30 Source0:        https://github.com/docker/docker-ce/archive/v%{version}/%{name}-%{version}.tar.gz
31 # Source0-md5:  f932ff952a0411223a90baaf5b829883
32 Source1:        https://github.com/opencontainers/runc/archive/%{runc_commit}/runc-%{runc_commit}.tar.gz
33 # Source1-md5:  b593d63c7df5a27fba615afcf411762f
34 Source2:        https://github.com/containerd/containerd/archive/%{containerd_commit}/containerd-%{containerd_commit}.tar.gz
35 # Source2-md5:  c5cee10a5fb8f6e1d5e186912725a052
36 Source3:        https://github.com/docker/libnetwork/archive/%{libnetwork_commit}/libnetwork-%{libnetwork_commit}.tar.gz
37 # Source3-md5:  a54f3443dbf78696e2470d6657fa03c1
38 Source4:        https://github.com/krallin/tini/archive/v0.18.0/tini-0.18.0.tar.gz
39 # Source4-md5:  cc3b205a1b83b8e6ed6892fc5e8ef2c3
40 Source5:        dockerd.sh
41 Source7:        docker.init
42 Source8:        docker.sysconfig
43 Patch0:         systemd.patch
44 URL:            https://www.docker.com/community-edition/
45 BuildRequires:  btrfs-progs-devel >= 3.16.1
46 BuildRequires:  cmake
47 BuildRequires:  device-mapper-devel >= 2.02.89
48 BuildRequires:  golang >= 1.12
49 BuildRequires:  libseccomp-devel >= 2.3
50 BuildRequires:  rpmbuild(macros) >= 1.644
51 BuildRequires:  sqlite3-devel >= 3.7.9
52 BuildRequires:  xxd
53 Requires(post,preun):   /sbin/chkconfig
54 Requires(postun):       /usr/sbin/groupdel
55 Requires(pre):  /usr/bin/getgid
56 Requires(pre):  /usr/sbin/groupadd
57 Requires:       ca-certificates
58 Requires:       iproute2 >= 3.5
59 Requires:       iptables
60 Requires:       rc-scripts >= 0.4.0.10
61 Requires:       systemd-units >= 38
62 Requires:       tar >= 1:1.26
63 Requires:       uname(release) >= 3.8
64 Requires:       xz
65 Suggests:       docker-credential-helpers
66 Suggests:       git-core >= 1.7
67 Suggests:       libcgroup
68 Suggests:       xz >= 1:4.9
69 Provides:       docker = %{version}
70 Provides:       docker(engine) = %{version}
71 Provides:       group(docker)
72 Requires:       libseccomp >= 2.3
73 Obsoletes:      docker < 18.0
74 Obsoletes:      lxc-docker < 1.1.1
75 # only runs on x64 hosts for now:
76 # https://github.com/docker/docker/issues/136
77 # https://github.com/docker/docker/issues/611
78 ExclusiveArch:  %{x8664} aarch64
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %define         bash_compdir    %{_datadir}/bash-completion/completions
82 %define         zsh_compdir     %{_datadir}/zsh/site-functions
83 %define         _vimdatadir             %{_datadir}/vim
84 %define         _libexecdir             %{_prefix}/lib
85
86 # binary stripped or something
87 %define         _enable_debug_packages 0
88
89 %description
90 Docker is an open source project to pack, ship and run any application
91 as a lightweight container
92
93 Docker containers are both hardware-agnostic and platform-agnostic.
94 This means that they can run anywhere, from your laptop to the largest
95 EC2 compute instance and everything in between - and they don't
96 require that you use a particular language, framework or packaging
97 system. That makes them great building blocks for deploying and
98 scaling web apps, databases and backend services without depending on
99 a particular stack or provider.
100
101 Docker is an open-source implementation of the deployment engine which
102 powers dotCloud, a popular Platform-as-a-Service. It benefits directly
103 from the experience accumulated over several years of large-scale
104 operation and support of hundreds of thousands of applications and
105 databases.
106
107 %package -n bash-completion-%{name}
108 Summary:        bash-completion for Docker
109 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla Dockera
110 Group:          Applications/Shells
111 Requires:       %{name}
112 Requires:       bash-completion >= 2.0
113 Obsoletes:      bash-completion-lxc-docker < 1.1.1
114 BuildArch:      noarch
115
116 %description -n bash-completion-%{name}
117 This package provides bash-completion for Docker.
118
119 %description -n bash-completion-%{name} -l pl.UTF-8
120 Pakiet ten dostarcza bashowe uzupełnianie nazw dla Dockera.
121
122 %package -n zsh-completion-%{name}
123 Summary:        zsh completion for Docker
124 Summary(pl.UTF-8):      Uzupełnianie parametrów w zsh dla poleceń Dockera
125 Group:          Applications/Shells
126 Requires:       %{name}
127 BuildArch:      noarch
128
129 %description -n zsh-completion-%{name}
130 This package provides zsh completion for Docker.
131
132 %description -n zsh-completion-%{name} -l pl.UTF-8
133 Pakiet ten dostarcza uzupełnianie w zsh dla poleceń Dockera.
134
135 %package -n vim-syntax-%{name}
136 Summary:        Vim syntax: Docker
137 Group:          Applications/Editors/Vim
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       vim-rt >= 4:7.2.170
140 Obsoletes:      vim-syntax-lxc-docker < 1.1.1
141 BuildArch:      noarch
142
143 %description -n vim-syntax-%{name}
144 This plugin provides syntax highlighting in Dockerfile.
145
146 %prep
147 %setup -q -n %{name}-%{version}%{?subver} -a1 -a2 -a3 -a4
148
149 mv runc-%{runc_commit}* runc
150 mv runc/vendor runc/src
151 ln -s ../../.. runc/src/github.com/opencontainers/runc
152
153 mv containerd-%{containerd_commit}* containerd
154 mv containerd/vendor containerd/src
155 ln -s ../../.. containerd/src/github.com/containerd/containerd
156
157 mv libnetwork-%{libnetwork_commit}* libnetwork
158 install -d libnetwork/gopath
159 mv libnetwork/vendor libnetwork/gopath/src
160 ln -s ../../../.. libnetwork/gopath/src/github.com/docker/libnetwork
161
162 mv tini-* tini
163
164 install -d components/cli/.gopath/src/github.com/docker
165 ln -s ../../../.. components/cli/.gopath/src/github.com/docker/cli
166
167 %patch0 -p1 -d components/engine
168
169 %build
170 grep -rhE "=%{runc_commit}|=%{containerd_commit}|=%{libnetwork_commit}" $(pwd)/components/engine/hack/dockerfile/install/
171
172 export VERSION=%{version}-ce # for `docker version`
173 export GITCOMMIT="PLD-Linux/%{version}" # for cli
174 export DOCKER_GITCOMMIT="PLD-Linux/%{version}" # for engine
175
176 # build runc
177 sed -i -e 's,shell git,shell false,' runc/Makefile
178 GOPATH=$(pwd)/runc \
179 %{__make} -C runc \
180         COMMIT=$RUNC_COMMIT
181 ./runc/runc -v
182
183 # build containerd
184 GOPATH=$(pwd)/containerd \
185 %{__make} -C containerd \
186         GIT_COMMIT=$CONTAINERD_COMMIT
187
188 # build docker-proxy
189 cd libnetwork
190 GOPATH=$(pwd)/gopath \
191 go build -ldflags="-linkmode=external" \
192         -o docker-proxy \
193         github.com/docker/libnetwork/cmd/proxy
194 cd ..
195
196 # build docker-init
197 cd tini
198 cmake .
199 %{__make}
200
201 # docker cli
202 cd ../components/cli
203 GOPATH=$(pwd)/.gopath \
204 DISABLE_WARN_OUTSIDE_CONTAINER=1 \
205 %{__make} dynbinary
206 ./build/docker -v
207
208 cd ../engine
209 AUTO_GOPATH=1 \
210 bash -x hack/make.sh dynbinary
211 ./bundles/dynbinary-daemon/dockerd -v
212 %if %{with doc}
213 man/md2man-all.sh
214 %endif
215
216 %install
217 rm -rf $RPM_BUILD_ROOT
218 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man1,/etc/{rc.d/init.d,sysconfig},%{systemdunitdir}} \
219         $RPM_BUILD_ROOT%{_libexecdir} \
220         $RPM_BUILD_ROOT/var/lib/docker/{containers,execdriver,graph,image,init,network,swarm,tmp,trust,vfs,volumes}
221
222 # docker-cli
223 install -p components/cli/build/docker $RPM_BUILD_ROOT%{_bindir}/docker
224
225 # runc
226 install -p runc/runc $RPM_BUILD_ROOT%{_sbindir}/runc
227
228 # containerd
229 install -p containerd/bin/containerd $RPM_BUILD_ROOT%{_sbindir}/containerd
230 install -p containerd/bin/containerd-shim $RPM_BUILD_ROOT%{_sbindir}/containerd-shim
231 install -p containerd/bin/ctr $RPM_BUILD_ROOT%{_sbindir}/ctr
232
233 # docker-proxy
234 install -p libnetwork/docker-proxy $RPM_BUILD_ROOT%{_sbindir}/docker-proxy
235
236 # docker-init
237 install -p tini/tini $RPM_BUILD_ROOT%{_sbindir}/docker-init
238
239 # dockerd
240 cd components/engine
241 install -p bundles/dynbinary-daemon/dockerd $RPM_BUILD_ROOT%{_sbindir}/dockerd
242 cp -p contrib/init/systemd/docker.service $RPM_BUILD_ROOT%{systemdunitdir}
243 cp -p contrib/init/systemd/docker.socket $RPM_BUILD_ROOT%{systemdunitdir}
244 install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/docker
245 install -p %{SOURCE5} $RPM_BUILD_ROOT%{_libexecdir}/dockerd
246 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/sysconfig/docker
247
248 # install udev rules
249 install -d $RPM_BUILD_ROOT/lib/udev/rules.d
250 cp -p contrib/udev/80-docker.rules $RPM_BUILD_ROOT/lib/udev/rules.d
251
252 # vim syntax
253 %if %{with vim}
254 install -d $RPM_BUILD_ROOT%{_vimdatadir}
255 cp -a contrib/syntax/vim/* $RPM_BUILD_ROOT%{_vimdatadir}
256 %{__rm} $RPM_BUILD_ROOT%{_vimdatadir}/{LICENSE,README.md}
257 %endif
258
259 # bash and zsh completion
260 cd ../cli/contrib/completion
261 install -d $RPM_BUILD_ROOT%{bash_compdir}
262 cp -p bash/docker $RPM_BUILD_ROOT%{bash_compdir}
263 install -d $RPM_BUILD_ROOT%{zsh_compdir}
264 cp -p zsh/_docker $RPM_BUILD_ROOT%{zsh_compdir}
265
266 %pre
267 %groupadd -g 296 docker
268
269 %post
270 /sbin/chkconfig --add docker
271 %service -n docker restart
272 %systemd_post docker.service
273
274 %preun
275 if [ "$1" = "0" ]; then
276         %service -q docker stop
277         /sbin/chkconfig --del docker
278 fi
279 %systemd_preun docker.service
280
281 %postun
282 if [ "$1" = "0" ]; then
283         %groupremove docker
284 fi
285 %systemd_reload
286
287 %triggerun -- docker < 17.0
288 # Prevent preun from docker from working
289 chmod a-x /etc/rc.d/init.d/docker
290
291 %triggerpostun -- docker < 17.0
292 # Restore what triggerun removed
293 chmod 754 /etc/rc.d/init.d/docker
294 # reinstall docker init.d links, which could be different
295 /sbin/chkconfig --del docker
296 /sbin/chkconfig --add docker
297
298 %clean
299 rm -rf $RPM_BUILD_ROOT
300
301 %files
302 %defattr(644,root,root,755)
303 %doc components/engine/{README.md,CHANGELOG.md,CONTRIBUTING.md,LICENSE,AUTHORS,NOTICE,MAINTAINERS}
304 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/docker
305 %attr(754,root,root) /etc/rc.d/init.d/docker
306 %attr(755,root,root) %{_bindir}/docker
307 %attr(755,root,root) %{_sbindir}/containerd
308 %attr(755,root,root) %{_sbindir}/ctr
309 %attr(755,root,root) %{_sbindir}/containerd-shim
310 %attr(755,root,root) %{_sbindir}/docker-init
311 %attr(755,root,root) %{_sbindir}/docker-proxy
312 %attr(755,root,root) %{_sbindir}/runc
313 %attr(755,root,root) %{_sbindir}/dockerd
314 %attr(755,root,root) %{_libexecdir}/dockerd
315 %{systemdunitdir}/docker.service
316 %{systemdunitdir}/docker.socket
317 /lib/udev/rules.d/80-docker.rules
318
319 %dir %attr(700,root,root) /var/lib/docker
320 %dir %attr(700,root,root) /var/lib/docker/containers
321 %dir %attr(700,root,root) /var/lib/docker/execdriver
322 %dir %attr(700,root,root) /var/lib/docker/graph
323 %dir %attr(700,root,root) /var/lib/docker/image
324 %dir %attr(700,root,root) /var/lib/docker/init
325 %dir %attr(700,root,root) /var/lib/docker/network
326 %dir %attr(700,root,root) /var/lib/docker/swarm
327 %dir %attr(700,root,root) /var/lib/docker/tmp
328 %dir %attr(700,root,root) /var/lib/docker/trust
329 %dir %attr(700,root,root) /var/lib/docker/vfs
330 %dir %attr(700,root,root) /var/lib/docker/volumes
331
332 %files -n bash-completion-%{name}
333 %defattr(644,root,root,755)
334 %{bash_compdir}/docker
335
336 %files -n zsh-completion-%{name}
337 %defattr(644,root,root,755)
338 %{zsh_compdir}/_docker
339
340 %if %{with vim}
341 %files -n vim-syntax-%{name}
342 %defattr(644,root,root,755)
343 %doc components/engine/contrib/syntax/vim/{README.md,LICENSE}
344 %{_vimdatadir}/doc/dockerfile.txt
345 %{_vimdatadir}/ftdetect/dockerfile.vim
346 %{_vimdatadir}/syntax/dockerfile.vim
347 %endif
This page took 0.334679 seconds and 3 git commands to generate.