]> git.pld-linux.org Git - SPECS.git/blob - dmalloc.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / dmalloc.spec
1 Summary:        A library for controlling and tracing dynamic memory allocations
2 Summary(pl.UTF-8):      Biblioteka do kontroli i śledzenia dynamicznej alokacji pamięci
3 Name:           dmalloc
4 Version:        5.5.2
5 Release:        1
6 License:        LGPL
7 Group:          Development/Debuggers
8 Source0:        http://dmalloc.com/releases/%{name}-%{version}.tgz
9 # Source0-md5:  f92e5606c23a8092f3d5694e8d1c932e
10 Source1:        %{name}.1
11 Patch0:         %{name}-info.patch
12 Patch1:         %{name}-pic.patch
13 Patch2:         %{name}-4.8.2-pld_man.patch
14 URL:            http://dmalloc.com/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  gcc-c++
18 BuildRequires:  texinfo
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 The debug memory allocation or "dmalloc" library has been designed as
23 a drop in replacement for the system's `malloc', `realloc', `calloc',
24 `free' and other memory management routines while providing powerful
25 debugging facilities configurable at runtime. These facilities include
26 such things as memory-leak tracking, fence-post write detection,
27 file/line number reporting, and general logging of statistics. It also
28 provides support for the debugging of threaded programs.
29
30 %description -l pl.UTF-8
31 Biblioteka do odpluskwiania programów zastępuje systemowe funkcje
32 takie jak `malloc', `realloc', `calloc', `free' i inne funkcje do
33 zarządzania pamięcią. Możliwości to wykrywanie wycieków pamięci,
34 wykrywanie zapisów poza zaalokowanym obszarem, informowanie o
35 pliku/numerze linii, w której występuje problem oraz generalne
36 statystyki. Biblioteka umożliwia odpluskwianie programów wątkowych.
37
38 %package static
39 Summary:        Static dmalloc libraries
40 Summary(pl.UTF-8):      Biblioteki statyczne dmalloc
41 Group:          Development/Debuggers
42 Requires:       %{name} = %{version}-%{release}
43
44 %description static
45 Static dmalloc libraries.
46
47 %description static -l pl.UTF-8
48 Biblioteki statyczne dmalloc.
49
50 %prep
51 %setup -q
52 install %{SOURCE1} .
53 cd docs
54 %patch0 -p1
55 cd ..
56 %patch1 -p1
57 %patch2 -p0
58
59 %build
60 %{__aclocal}
61 %{__autoconf}
62 %configure \
63         --enable-cxx \
64         --enable-threads \
65         --enable-shlib
66
67 %{__make}
68 %{__make} docs/%{name}.info
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1}
73
74 %{makeinstall} \
75         installsl installcxx installth \
76         shlibdir=$RPM_BUILD_ROOT%{_libdir} \
77         incdir=$RPM_BUILD_ROOT%{_includedir}
78
79 install docs/*.info $RPM_BUILD_ROOT%{_infodir}
80 install dmalloc.1 $RPM_BUILD_ROOT%{_mandir}/man1
81
82 %post
83 /sbin/ldconfig
84 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
85
86 %postun
87 /sbin/ldconfig
88 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc README NEWS ChangeLog*
96 %attr(755,root,root) %{_bindir}/*
97 %attr(755,root,root) %{_libdir}/lib*.so
98 %{_includedir}/*
99 %{_mandir}/man1/*
100 %{_infodir}/*.info*
101
102 %files static
103 %defattr(644,root,root,755)
104 %{_libdir}/lib*.a
This page took 0.229594 seconds and 3 git commands to generate.