]> git.pld-linux.org Git - SPECS.git/blob - dbh.spec
SPECS updated Sat 31 Jul 20:27:02 CEST 2021
[SPECS.git] / dbh.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Disk based hash library
6 Summary(pl.UTF-8):      Biblioteka obsługująca tablice haszujące na dysku
7 Name:           dbh
8 Version:        5.0.7
9 Release:        2
10 License:        LGPL
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/dbh/%{name}-%{version}.tar.gz
13 # Source0-md5:  15e1bd22aca735415dfb5ec60f48181b
14 Patch0:         am.patch
15 Patch1:         %{name}-bsd.patch
16 URL:            http://dbh.sourceforge.net/
17 BuildRequires:  autoconf >= 2.52
18 BuildRequires:  automake
19 BuildRequires:  gtk-doc >= 1.15
20 BuildRequires:  libtool
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Disk based hashes is a method to create multidimensional binary trees
25 on disk. This library permits the extension of database concept to a
26 plethora of electronic data, such as graphic information. With the
27 multidimensional binary tree it is possible to mathematically prove
28 that access time to any particular record is minimized (using the
29 concept of critical points from calculus), which provides the means to
30 construct optimized databases for particular applications.
31
32 %description -l pl.UTF-8
33 Hasze przechowywane na dysku to metoda tworzenia wielowymiarowych
34 drzew binarnych na dysku. Biblioteka pozwala rozszerzać pojęcie bazy
35 danych o bogactwo danych elektronicznych, takich jak informacje
36 graficzne. Można udowodnić matematycznie, że przy użyciu
37 wielowymiarowego drzewa binarnego czas dostępu do każdego konkretnego
38 rekordu jest minimalny (używając zasady punktów krytycznych), co daje
39 środki do tworzenia zoptymalizowanych baz danych dla aplikacji.
40
41 %package devel
42 Summary:        Disk based hash library development files
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dbh
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Obsoletes:      dbh-examples
47
48 %description devel
49 Disk based hash library development files.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki dbh.
53
54 %package static
55 Summary:        Disk based hash static library
56 Summary(pl.UTF-8):      Statyczna biblioteka dbh
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Disk based hash static library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka dbh.
65
66 %package apidocs
67 Summary:        API documentation for dbh library
68 Summary(pl.UTF-8):      Dokumentacja API biblioteki dbh
69 Group:          Documentation
70 BuildArch:      noarch
71
72 %description apidocs
73 API documentation for dbh library.
74
75 %description apidocs -l pl.UTF-8
76 Dokumentacja API biblioteki dbh.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81 %patch1 -p1
82
83 %build
84 %{__libtoolize}
85 %{__aclocal} -I m4
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         %{!?with_static_libs:--disable-static} \
91         --without-examples
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 cp -p examples/{filesystem,simple_hash}.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
103
104 # belongs to man3
105 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/dbh.h.1 $RPM_BUILD_ROOT%{_mandir}/man3/dbh.h.3
106 # just a copy of dbh.h.1, useless
107 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/dbh.1
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS ChangeLog NEWS
118 %attr(755,root,root) %{_libdir}/libdbh2.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libdbh2.so.0
120
121 %files devel
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/libdbh2.so
124 %{_libdir}/libdbh2.la
125 %{_includedir}/dbh
126 %{_pkgconfigdir}/dbh2.pc
127 %{_examplesdir}/%{name}-%{version}
128 %{_mandir}/man3/dbh.h.3*
129 %{_mandir}/man3/dbh_*.3*
130
131 %if %{with static_libs}
132 %files static
133 %defattr(644,root,root,755)
134 %{_libdir}/libdbh2.a
135 %endif
136
137 %files apidocs
138 %defattr(644,root,root,755)
139 %{_gtkdocdir}/dbh
This page took 1.025977 seconds and 3 git commands to generate.