]> git.pld-linux.org Git - SPECS.git/blob - ctl.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / ctl.spec
1 Summary:        Color Transform Language libraries
2 Summary(pl.UTF-8):      Biblioteki CTL (języka przekształceń kolorów)
3 Name:           ctl
4 Version:        1.5.2
5 Release:        3
6 License:        BSD + IP clause
7 Group:          Libraries
8 #Source0Download: https://github.com/ampas/CTL/releases
9 Source0:        https://github.com/ampas/CTL/archive/%{name}-%{version}.tar.gz
10 # Source0-md5:  4796bf258d0c66d421c864996482f952
11 Patch0:         %{name}-libdir.patch
12 Patch1:         %{name}-ctlrender.patch
13 Patch2:         %{name}-pc.patch
14 URL:            https://www.oscars.org/science-technology/sci-tech-projects/color-transformation-language
15 BuildRequires:  OpenEXR-devel
16 BuildRequires:  aces_container-devel
17 BuildRequires:  cmake >= 2.8
18 BuildRequires:  ilmbase-devel >= 2.0.0
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtiff-devel
21 BuildRequires:  pkgconfig
22 Requires:       ilmbase >= 2.0.0
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 CTL (Color Transform Language) interpreter contains the following C++
27 libraries:
28
29 IlmCtl - CTL interpreter frontend and the interpreter's public
30 programming interface.
31
32 IlmCtlSimd - interpreter's SIMD backend.
33
34 IlmCtlMath - math routines used by IlmCtlSimd: conversions between
35 standard color spaces, 1D and 3D lookup tables, 3D scattered data
36 interpolation.
37
38 %description -l pl.UTF-8
39 Interpreter CTL (Color Transform Language - języka przekształceń
40 kolorów) składa się z następujących bibliotek C++:
41
42 IlmCtl - frontend interpretera CTL i jego publiczny interfejs
43 programistyczny.
44
45 IlmCtlSimd - backend SIMD interpretera.
46
47 IlmCtlMath - funkcje matematyczne wykorzystywane przez IlmCtlSimd:
48 przekształcenia między standardowymi przestrzeniami kolorów, tablice
49 wyszukiwań 1D i 3D, interpolacja zgromadzonych danych 3D.
50
51 %package devel
52 Summary:        Header files for CTL library
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CTL
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       ilmbase-devel >= 2.0.0
57 Requires:       libstdc++-devel
58 Obsoletes:      ctl-static
59
60 %description devel
61 Header files for CTL library.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe biblioteki CTL.
65
66 %package -n openexr_ctl
67 Summary:        OpenEXR interface to CTL (Color Transform Language)
68 Summary(pl.UTF-8):      Interfejs OpenEXR do CTL (języka przekształceń kolorów)
69 Group:          Libraries
70 Requires:       ctl = %{version}-%{release}
71
72 %description -n openexr_ctl
73 IlmImfCtl provides a simplified OpenEXR interface to CTL (Color
74 Transform Language).
75
76 %description -n openexr_ctl -l pl.UTF-8
77 IlmImfCtl udostępnia uproszczony interfejs OpenEXR do CTL (języka
78 przekształceń kolorów).
79
80 %package -n openexr_ctl-devel
81 Summary:        Header files for IlmInfCtl library
82 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki IlmInfCtl
83 Group:          Development/Libraries
84 Requires:       OpenEXR-devel
85 Requires:       ctl-devel = %{version}-%{release}
86 Requires:       openexr_ctl = %{version}-%{release}
87 Obsoletes:      openexr_ctl-static
88
89 %description -n openexr_ctl-devel
90 Header files for IlmInfCtl library.
91
92 %description -n openexr_ctl-devel -l pl.UTF-8
93 Pliki nagłówkowe biblioteki IlmInfCtl.
94
95 %package -n openexr_ctl-progs
96 Summary:        Programs utilizing OpenEXR/CTL interface
97 Summary(pl.UTF-8):      Programy wykorzystujące interfejs OpenEXR/CTL
98 Group:          Applications/Graphics
99 Requires:       openexr_ctl = %{version}-%{release}
100
101 %description -n openexr_ctl-progs
102 Programs utilizing OpenEXR/CTL interface:
103
104 exrdpx is an initial version of a CTL-driven file converter that
105 translates DPX files into OpenEXR files and vice versa. The conversion
106 between the DPX and OpenEXR color spaces is handled by CTL transforms.
107
108 exr_ctl_exr is an initial version of a program that can bake the
109 effect of a series of CTL transforms into the pixels of an OpenEXR
110 file.
111
112 %description -n openexr_ctl-progs -l pl.UTF-8
113 Programy wykorzystujące interfejs OpenEXR/CTL:
114
115 exrdpx to wstępna wersja konwertera plików sterowanego CTL-em,
116 tłumaczącego pliki DPX na OpenEXR i na odwrót. Przekształcenia między
117 przestrzeniami kolorów DPX i OpenEXR są obsługiwane przez
118 przekształcenia CTL.
119
120 exr_ctl_exr to wstępna wersja programu potrafiącego zamienić efekt
121 serii przekształceń CTL na piksele w pliku OpenEXR.
122
123 %package -n ctlrender
124 Summary:        CLI application to apply CTL transforms to an image
125 Summary(pl.UTF-8):      Uruchamiany z linii poleceń program do nakładania przekształceń CTL na obraz
126 Group:          Applications/Graphics
127 Requires:       ctl = %{version}-%{release}
128
129 %description -n ctlrender
130 ctlrender is a command line application for applying CTL transforms to
131 an image using one or more CTL scripts, potentially converting the
132 file format in the process.
133
134 ctlrender supports OpenEXR, TIFF, DPX, and ACES container file
135 formats.
136
137 %description -n ctlrender
138 ctlrender to uruchamiany z linii poleceń program do nakładania
139 przekształceń CTL na obraz przy użyciu jednego lub więcej skryptów
140 CTL, potencjalnie także zmieniając w trakcie format pliku.
141
142 ctlrender obsługuje formaty plików OpenEXR, TIFF, DPX oraz ACES.
143
144 %prep
145 %setup -q -n CTL-%{name}-%{version}
146 %patch0 -p1
147 %patch1 -p1
148 %patch2 -p1
149
150 %build
151 %cmake . \
152         -DINSTALL_CMAKE_DIR=%{_libdir}/cmake/CTL \
153         -DINSTALL_LIB_DIR=%{_libdir}
154 %{__make}
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158
159 %{__make} install \
160         DESTDIR=$RPM_BUILD_ROOT
161
162 # packaged as %doc
163 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/CTL
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %post   -p /sbin/ldconfig
169 %postun -p /sbin/ldconfig
170
171 %files
172 %defattr(644,root,root,755)
173 %doc AUTHORS CHANGELOG LICENSE README.md
174 %attr(755,root,root) %{_libdir}/libIlmCtl.so.*.*.*
175 %attr(755,root,root) %{_libdir}/libIlmCtlMath.so.*.*.*
176 %attr(755,root,root) %{_libdir}/libIlmCtlSimd.so.*.*.*
177 %dir %{_datadir}/CTL
178
179 %files devel
180 %defattr(644,root,root,755)
181 %doc doc/CtlManual.pdf
182 %attr(755,root,root) %{_libdir}/libIlmCtl.so
183 %attr(755,root,root) %{_libdir}/libIlmCtlMath.so
184 %attr(755,root,root) %{_libdir}/libIlmCtlSimd.so
185 %{_includedir}/CTL
186 %{_pkgconfigdir}/CTL.pc
187 %{_libdir}/cmake/CTL
188
189 %files -n openexr_ctl
190 %defattr(644,root,root,755)
191 %doc OpenEXR_CTL/README
192 %attr(755,root,root) %{_libdir}/libIlmImfCtl.so
193
194 %files -n openexr_ctl-devel
195 %defattr(644,root,root,755)
196 #%attr(755,root,root) %{_libdir}/libIlmImfCtl.so
197 %{_includedir}/OpenEXR/ImfCtlApplyTransforms.h
198 %{_pkgconfigdir}/OpenEXR_CTL.pc
199
200 %files -n openexr_ctl-progs
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_bindir}/exr_ctl_exr
203 %attr(755,root,root) %{_bindir}/exrdpx
204 %{_datadir}/CTL/change_saturation.ctl
205 %{_datadir}/CTL/transform_DPX_EXR.ctl
206 %{_datadir}/CTL/transform_EXR_DPX.ctl
207 %{_datadir}/CTL/utilities.ctl
208
209 %files -n ctlrender
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_bindir}/ctlrender
This page took 0.99486 seconds and 3 git commands to generate.