]> git.pld-linux.org Git - SPECS.git/blob - crossmingw32-lib3ds.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / crossmingw32-lib3ds.spec
1 %define         realname        lib3ds
2 Summary:        The 3D Studio File Format Library - Mingw32 cross version
3 Summary(pl.UTF-8):      Biblioteka obsługująca format plików 3D Studio - wersja skrośna dla Mingw32
4 Name:           crossmingw32-%{realname}
5 Version:        1.2.0
6 Release:        4
7 License:        LGPL
8 Group:          Development/Libraries
9 Source0:        http://dl.sourceforge.net/lib3ds/%{realname}-%{version}.tar.gz
10 # Source0-md5:  3a7f891d18af0151876b98bc05d3b373
11 URL:            http://lib3ds.sourceforge.net/
12 Requires:       crossmingw32-runtime
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  crossmingw32-gcc
16 BuildRequires:  crossmingw32-w32api
17 BuildRequires:  libtool
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         no_install_post_strip   1
21
22 %define         target          i386-mingw32
23 %define         target_platform i386-pc-mingw32
24 %define         arch            %{_prefix}/%{target}
25
26 %define         __cc            %{target}-gcc
27 %define         __cxx           %{target}-g++
28
29 %ifarch alpha sparc sparc64 sparcv9
30 %define         optflags        -O2
31 %endif
32
33 %description
34 lib3ds is a free alternative to Autodesk's 3DS File Toolkit for
35 handling 3DS files. It's main goal is to simplify the creation of 3DS
36 import and export filters.
37
38 %description -l pl.UTF-8
39 lib3ds to wolnodostępna alternatywa dla 3DS File Toolkit Autodeska do
40 obsługi plików 3DS. Głównym celem biblioteki jest uproszczenie
41 tworzenia filtrów importujących i eksportujących 3DS.
42
43 %package dll
44 Summary:        %{realname} - DLL library for Windows
45 Summary(pl.UTF-8):      %{realname} - biblioteka DLL dla Windows
46 Group:          Applications/Emulators
47
48 %description dll
49 %{realname} - DLL library for Windows.
50
51 %description dll -l pl.UTF-8
52 %{realname} - biblioteka DLL dla Windows.
53
54 %prep
55 %setup -q -n %{realname}-%{version}
56
57 %build
58 CC=%{target}-gcc ; export CC
59 CXX=%{target}-g++ ; export CXX
60 LD=%{target}-ld ; export LD
61 AR=%{target}-ar ; export AR
62 AS=%{target}-as ; export AS
63 CROSS_COMPILE=1 ; export CROSS_COMPILE
64 CPPFLAGS="-I%{arch}/include" ; export CPPFLAGS
65 RANLIB=%{target}-ranlib ; export RANLIB
66 LDSHARED="%{target}-gcc -shared" ; export LDSHARED
67 TARGET="%{target}" ; export TARGET
68
69 tail -n 116 aclocal.m4 | head -n 102 > acinclude.m4
70 %{__libtoolize}
71 %{__aclocal}
72 %{__autoconf}
73 %{__autoheader}
74 %{__automake}
75 %configure \
76         --host=%{_host} \
77         --target=%{target}
78
79 # glut is broken
80 echo "int main(){}" > examples/player.c
81
82 %{__make}
83
84 cd lib3ds
85 %{__cc} --shared *.o -Wl,--enable-auto-image-base -o 3ds.dll -Wl,--out-implib,lib3ds.dll.a
86
87 %if 0%{!?debug:1}
88 %{target}-strip *.dll
89 %{target}-strip -g -R.comment -R.note *.a
90 %endif
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT%{arch}/{include/lib3ds,lib}
95 install -d $RPM_BUILD_ROOT%{_datadir}/wine/windows/system
96
97 cd lib3ds
98
99 install *.h $RPM_BUILD_ROOT%{arch}/include/lib3ds
100 rm $RPM_BUILD_ROOT%{arch}/include/lib3ds/chunktable.h
101 install lib3ds{,.dll}.a $RPM_BUILD_ROOT%{arch}/lib
102 install 3ds.dll $RPM_BUILD_ROOT%{_datadir}/wine/windows/system
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files
108 %defattr(644,root,root,755)
109 %{arch}/include/*
110 %{arch}/lib/*
111
112 %files dll
113 %defattr(644,root,root,755)
114 %{_datadir}/wine/windows/system/*
This page took 0.162803 seconds and 3 git commands to generate.