]> git.pld-linux.org Git - SPECS.git/blob - crossarm-newlib.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / crossarm-newlib.spec
1 Summary:        A C library intended for use on embedded systems
2 Summary(pl.UTF-8):      Biblioteka C przeznaczona dla systemów wbudowanych
3 Name:           crossarm-newlib
4 Version:        1.12.0
5 Release:        1
6 License:        several free software licenses
7 Group:          Libraries
8 Source0:        ftp://sources.redhat.com/pub/newlib/newlib-%{version}.tar.gz
9 # Source0-md5:  c3f1fbb52a4864cf8356c124584bae72
10 Patch0:         %{name}-configure.patch
11 URL:            http://sources.redhat.com/newlib/
12 BuildRequires:  crossarm-gcc
13 Requires:       crossarm-binutils
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         target          arm-pld-linux
17 %define         arch            %{_prefix}/%{target}
18 %define         _noautostrip    .*/lib.*\\.a
19
20 %description
21 Newlib is a C library intended for use on embedded systems. It is a
22 conglomeration of several library parts, all under free software
23 licenses that make them easily usable on embedded products.
24
25 %description -l pl.UTF-8
26 Newlib to biblioteka C przeznaczona dla systemów wbudowanych. Jest to
27 połączenie różnych części biblioteki, wszystkich na wolnych
28 licencjach, co czyni je łatwo używalnymi w produktach wbudowanych.
29
30 %prep
31 %setup -q -n newlib-%{version}
32 %patch0 -p1
33
34 %build
35 rm -rf build && mkdir build && cd build
36
37 ../configure \
38         --prefix=%{_prefix} \
39         --disable-shared \
40         --enable-static \
41         --enable-multilib \
42         --enable-target-optspace \
43         --disable-newlib-iconv \
44         --disable-newlib-multithread \
45         --disable-newlib-io-float \
46         --disable-newlib-hw-fp \
47         --disable-newlib-supplied-syscalls \
48         --target=%{target}
49
50 %{__make} \
51         CFLAGS_FOR_TARGET="-mthumb -mthumb-interwork"
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} -C build install-target-newlib \
57         CFLAGS_FOR_TARGET="-mthumb -mthumb-interwork" \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %{target}-strip -g $RPM_BUILD_ROOT%{arch}/lib/libc.a
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc COPYING* ChangeLog README
68 %{arch}/include
69 %{arch}/lib/libc.a
This page took 0.302777 seconds and 3 git commands to generate.