]> git.pld-linux.org Git - SPECS.git/blob - courier-sox.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / courier-sox.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static libraries
4 %bcond_without  tests           # "make check"
5
6 Summary:        Courier Socks 5 client libraries
7 Summary(pl.UTF-8):      Biblioteki klienckie Socks 5
8 Name:           courier-sox
9 Version:        0.12
10 Release:        3
11 License:        GPL v3 with OpenSSL exception
12 Group:          Networking/Utilities
13 Source0:        http://downloads.sourceforge.net/courier/%{name}-%{version}.tar.bz2
14 # Source0-md5:  c5f3778d9c5d7136b707b5f8ebb80515
15 Patch0:         %{name}-init.patch
16 URL:            http://www.courier-mta.org/
17 BuildRequires:  courier-authlib-devel >= 0.56.20050702
18 BuildRequires:  gdbm-devel
19 BuildRequires:  libltdl-devel >= 2:2.0
20 BuildRequires:  perl-base
21 BuildRequires:  rpm-perlprov
22 BuildRequires:  rpmbuild(macros) >= 1.268
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This is a generic Socks 5 client support library.
27
28 %description -l pl.UTF-8
29 Ogólna biblioteka kliencka Socks 5.
30
31 %package devel
32 Summary:        Socks 5 client header files
33 Summary(pl.UTF-8):      Pliki nagłówkowe klienta socks 5
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 This package contains header files for building applications that use
39 Socks 5 proxies.
40
41 %description devel -l pl.UTF-8
42 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji używających
43 proxy Socks 5.
44
45 %package static
46 Summary:        Socks 5 client static libraries
47 Summary(pl.UTF-8):      Biblioteki statyczne klienta socks 5
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 This package contains static libraries for building applications that
53 use Socks 5 proxies.
54
55 %description static -l pl.UTF-8
56 Ten pakiet zawiera biblioteki statyczne do tworzenia aplikacji
57 używających proxy Socks 5.
58
59 %package server
60 Summary:        Socks 5 server
61 Summary(pl.UTF-8):      Serwer socks 5
62 Group:          Networking/Daemons
63 Requires(post,preun):   /sbin/chkconfig
64 Requires:       %{name} = %{version}-%{release}
65 # requires library and courierlogger
66 Requires:       courier-authlib >= 0.56.20050702
67
68 %description server
69 This package contains the Courier Socks 5 server.
70
71 %description server -l pl.UTF-8
72 Ten pakiet zawiera serwer Courier Socks 5.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77
78 %build
79 %configure \
80         --libexecdir=%{_libexecdir}/courier-sox \
81         %{!?with_static_libs:--disable-static}
82
83 %{__make}
84
85 %if %{with tests}
86 %{__make} check
87 %endif
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 install -D courier-sox.sysvinit $RPM_BUILD_ROOT/etc/rc.d/init.d/courier-sox
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %post server
104 /sbin/chkconfig --add courier-sox
105 %service courier-sox restart
106
107 %preun server
108 if [ "$1" = "0" ]; then
109         %service courier-sox stop
110         /sbin/chkconfig --del courier-sox
111 fi
112
113 %files
114 %defattr(644,root,root,755)
115 %doc AUTHORS ChangeLog NEWS README *.html
116 %attr(755,root,root) %{_bindir}/mkbl4
117 %attr(755,root,root) %{_bindir}/socksify
118 %attr(755,root,root) %{_libdir}/libsocks.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libsocks.so.0
120 %attr(755,root,root) %{_libdir}/libsockswrap.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libsockswrap.so.0
122 %{_mandir}/man1/socksify.1*
123 %{_mandir}/man5/socksrc.5*
124 %{_mandir}/man8/mkbl4.8*
125 %dir %{_sysconfdir}/socksrc
126 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/socksrc/system
127
128 %files devel
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_libdir}/libsocks.so
131 %attr(755,root,root) %{_libdir}/libsockswrap.so
132 %{_libdir}/libsocks.la
133 %{_libdir}/libsockswrap.la
134 %{_includedir}/socks.h
135 %{_mandir}/man3/socks.3*
136
137 %if %{with static_libs}
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/libsocks.a
141 %{_libdir}/libsockswrap.a
142 %endif
143
144 %files server
145 %defattr(644,root,root,755)
146 %attr(754,root,root) /etc/rc.d/init.d/courier-sox
147 %attr(755,root,root) %{_sbindir}/sockd
148 %dir %{_libexecdir}/courier-sox
149 %attr(755,root,root) %{_libexecdir}/courier-sox/sockd
150 %{_mandir}/man1/sockd.1*
This page took 0.119035 seconds and 3 git commands to generate.