]> git.pld-linux.org Git - SPECS.git/blob - catfish.spec
SPECS updated Sun 1 Aug 10:49:02 CEST 2021
[SPECS.git] / catfish.spec
1 Summary:        Versatile file search utility for the Xfce desktop
2 Name:           catfish
3 Version:        4.16.2
4 Release:        1
5 License:        GPL v2
6 Group:          X11/Applications/Graphics
7 Source0:        https://archive.xfce.org/src/apps/catfish/4.16/%{name}-%{version}.tar.bz2
8 # Source0-md5:  67c65785add8924cc90ef689724d0302
9 URL:            https://docs.xfce.org/apps/catfish/
10 BuildRequires:  glib2-devel >= 1:2.50.0
11 BuildRequires:  gtk+3-devel >= 3.22.0
12 BuildRequires:  python3-dbus
13 BuildRequires:  python3-distutils-extra
14 BuildRequires:  python3-modules
15 BuildRequires:  python3-pexpect
16 BuildRequires:  python3-pygobject3
17 BuildRequires:  python3-setuptools
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 BuildRequires:  xfconf-devel >= 4.14.0
21 Requires:       gtk-update-icon-cache
22 Requires:       hicolor-icon-theme
23 Requires:       mlocate
24 Requires:       python3-dbus
25 Requires:       python3-pexpect
26 Requires:       python3-pygobject3
27 Suggests:       python3-zeitgeist
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Catfish is a versatile file search utility for the Xfce desktop.
33 Powered by Python and GTK, it is fast, flexible, and exceptional at
34 finding files.
35
36 %prep
37 %setup -q
38
39 # fix #!/usr/bin/env python -> #!/usr/bin/python3:
40 find -name '*.py' | xargs %{__sed} -i -e '1s,^#!.*python$,#!%{__python3},'
41
42 %build
43 %{__python3} setup.py build
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_localedir}}
48
49 cp -a build/share/applications/org.xfce.Catfish.desktop $RPM_BUILD_ROOT%{_desktopdir}/
50
51 %{__python3} setup.py install \
52         --skip-build \
53         --prefix=%{_prefix} \
54         --install-purelib=%{py3_sitescriptdir} \
55         --install-platlib=%{py3_sitedir} \
56         --root=$RPM_BUILD_ROOT
57
58 cp -a build/mo/* $RPM_BUILD_ROOT%{_localedir}/
59
60 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{hye,ie}
61 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{hy_AM,hy}
62 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
63
64 %find_lang %{name}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 %update_desktop_database_post
71 %update_icon_cache hicolor
72
73 %postun
74 %update_desktop_database_postun
75 %update_icon_cache hicolor
76
77 %files -f %{name}.lang
78 %defattr(644,root,root,755)
79 %doc AUTHORS NEWS README.md
80 %attr(755,root,root) %{_bindir}/%{name}
81 %{_desktopdir}/org.xfce.Catfish.desktop
82 %{_datadir}/metainfo/catfish.appdata.xml
83 %{_iconsdir}/hicolor/*/*/*
84 %{py3_sitescriptdir}/catfish-*.egg-info
85 %{py3_sitescriptdir}/catfish
86 %{py3_sitescriptdir}/catfish_lib
87 %{_datadir}/catfish
88 %{_mandir}/man1/catfish.1*
This page took 0.132141 seconds and 3 git commands to generate.