]> git.pld-linux.org Git - SPECS.git/blob - babeltrace2.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / babeltrace2.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4 %bcond_without  python  # Python binding
5 #
6 Summary:        Trace Format Babel Tower
7 Summary(pl.UTF-8):      Wieża Babel formatów narzędzi śledzących
8 Name:           babeltrace2
9 Version:        2.0.3
10 Release:        2
11 License:        MIT
12 Group:          Applications/System
13 Source0:        https://www.efficios.com/files/babeltrace/%{name}-%{version}.tar.bz2
14 # Source0-md5:  9a8f40ddc18dac6c11af9a3fd0207feb
15 Patch0:         %{name}-python.patch
16 URL:            https://babeltrace.org/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake >= 1:1.12
19 %{?with_apidocs:BuildRequires:  doxygen}
20 BuildRequires:  elfutils-devel >= 0.154
21 BuildRequires:  glib2-devel >= 1:2.28.0
22 BuildRequires:  libtool >= 2:2
23 BuildRequires:  libuuid-devel
24 BuildRequires:  pkgconfig
25 BuildRequires:  popt-devel
26 %{?with_python:BuildRequires:   python3-devel >= 1:3.2}
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.507
29 BuildRequires:  swig-python >= 2.0.0
30 Requires:       elfutils >= 0.154
31 Requires:       glib2 >= 1:2.28.0
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 This project provides trace read and write libraries, as well as a
36 trace converter. A plugin can be created for any trace format to allow
37 its conversion to/from another trace format.
38
39 %description -l pl.UTF-8
40 Ten projekt udostępnia biblioteki do odczytu i zapisu śladów, a także
41 konwerter śladów. Można tworzyć wtyczki dla dowolnego formatu śladów,
42 aby umożliwić konwersję do/z innego formatu.
43
44 %package devel
45 Summary:        Header files for Babeltrace libraries
46 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Babeltrace
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       elfutils-devel >= 0.154
50 Requires:       glib2-devel >= 1:2.28.0
51 Requires:       libuuid-devel
52 Requires:       popt-devel
53
54 %description devel
55 Header files for Babeltrace libraries.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe bibliotek Babeltrace.
59
60 %package static
61 Summary:        Static Babeltrace 2 libraries
62 Summary(pl.UTF-8):      Statyczne biblioteki Babeltrace 2
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static Babeltrace 2 libraries.
68
69 %description static -l pl.UTF-8
70 Statyczne biblioteki Babeltrace 2.
71
72 %package apidocs
73 Summary:        API documentation for Babeltrace 2 libraries
74 Summary(pl.UTF-8):      Dokumentacja API bibliotek Babeltrace 2
75 Group:          Documentation
76 BuildArch:      noarch
77
78 %description apidocs
79 API documentation for Babeltrace 2 libraries.
80
81 %description apidocs -l pl.UTF-8
82 Dokumentacja API bibliotek Babeltrace 2.
83
84 %package -n python3-babeltrace2
85 Summary:        Python 3 binding to Babeltrace 2 library
86 Summary(pl.UTF-8):      Wiązanie Pythona 3 do biblioteki Babeltrace 2
87 Group:          Libraries/Python
88 Requires:       %{name} = %{version}-%{release}
89
90 %description -n python3-babeltrace2
91 Python 3 binding to Babeltrace 2 library.
92
93 %description -n python3-babeltrace2 -l pl.UTF-8
94 Wiązanie Pythona 3 do biblioteki Babeltrace 2.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99
100 %build
101 %{__libtoolize}
102 %{__aclocal} -I m4
103 %{__autoconf}
104 %{__autoheader}
105 %{__automake}
106 %configure \
107         %{?with_apidocs:--enable-api-doc} \
108         %{?with_python:--enable-python-bindings} \
109         --disable-silent-rules
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 %{__rm} $RPM_BUILD_ROOT%{_libdir}/babeltrace2/plugins/*.{la,a}
119 # obsoleted by pkg-config
120 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
121
122 # packaged as %doc
123 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/babeltrace2
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc ChangeLog LICENSE README.adoc mit-license.txt std-ext-lib.txt
134 %attr(755,root,root) %{_bindir}/babeltrace2
135 %attr(755,root,root) %{_libdir}/libbabeltrace2.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace2.so.0
137 %attr(755,root,root) %{_libdir}/libbabeltrace2-ctf-writer.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace2-ctf-writer.so.0
139 %dir %{_libdir}/babeltrace2
140 %dir %{_libdir}/babeltrace2/plugins
141 %attr(755,root,root) %{_libdir}/babeltrace2/plugins/babeltrace-plugin-ctf.so
142 %attr(755,root,root) %{_libdir}/babeltrace2/plugins/babeltrace-plugin-lttng-utils.so
143 %attr(755,root,root) %{_libdir}/babeltrace2/plugins/babeltrace-plugin-text.so
144 %attr(755,root,root) %{_libdir}/babeltrace2/plugins/babeltrace-plugin-utils.so
145 %{_mandir}/man1/babeltrace2.1*
146 %{_mandir}/man1/babeltrace2-convert.1*
147 %{_mandir}/man1/babeltrace2-help.1*
148 %{_mandir}/man1/babeltrace2-list-plugins.1*
149 %{_mandir}/man1/babeltrace2-query.1*
150 %{_mandir}/man1/babeltrace2-run.1*
151 %{_mandir}/man7/babeltrace2*.7*
152
153 %files devel
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/libbabeltrace2.so
156 %attr(755,root,root) %{_libdir}/libbabeltrace2-ctf-writer.so
157 %{_includedir}/babeltrace2
158 %{_includedir}/babeltrace2-ctf-writer
159 %{_pkgconfigdir}/babeltrace2.pc
160 %{_pkgconfigdir}/babeltrace2-ctf-writer.pc
161
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/libbabeltrace2.a
165 %{_libdir}/libbabeltrace2-ctf-writer.a
166
167 %if %{with apidocs}
168 %files apidocs
169 %defattr(644,root,root,755)
170 %doc doc/api/libbabeltrace2/output/html/{search,*.css,*.html,*.js,*.png}
171 %endif
172
173 %if %{with python}
174 %files -n python3-babeltrace2
175 %defattr(644,root,root,755)
176 %dir %{py3_sitedir}/bt2
177 %attr(755,root,root) %{py3_sitedir}/bt2/_native_bt.cpython-*.so
178 %{py3_sitedir}/bt2/*.py
179 %{py3_sitedir}/bt2/__pycache__
180 %{py3_sitedir}/bt2-%{version}-py*.egg-info
181 %endif
This page took 0.124357 seconds and 3 git commands to generate.