]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
This commit was manufactured by cvs2git to create tag 'auto-ac-php-5_2_1-6'.
[packages/php.git] / php.spec
index cc508659c0edec798439c819601d0cc1a885c879..2cdee3bd112cc761c6bdc6cc4a1d92b59f9af66a 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -1,4 +1,5 @@
-# TODO:
+# TODO
+# - fix -threads-acfix.patch
 # - deal with modules removed from php and not moved to PECL, still not obsoleted anywhere
 #   - removed from php 5.0 (currently in php4):
 #   db, hyperwave, java, mcal, overload, qtdom
 %undefine      with_mm
 %endif
 
-%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha
-# ppc disabled (broken on th-ppc)
+%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
 %undefine      with_interbase
 %endif
 
-%if !%{with apache1} && !%{with apache2}
+%if %{without apache1} && %{without apache2}
 ERROR: You need to select at least one Apache SAPI to build shared modules.
 %endif
 
@@ -69,7 +69,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define        _rel 11
+%define        _rel 6
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr):   Le langage de script embarque-HTML PHP
 Summary(pl):   Jêzyk skryptowy PHP
@@ -77,13 +77,13 @@ Summary(pt_BR):     A linguagem de script PHP
 Summary(ru):   PHP ÷ÅÒÓÉÉ 5 - ÑÚÙË ÐÒÅÐÒÏÃÅÓÓÉÒÏ×ÁÎÉÑ HTML-ÆÁÊÌÏ×, ×ÙÐÏÌÎÑÅÍÙÊ ÎÁ ÓÅÒ×ÅÒÅ
 Summary(uk):   PHP ÷ÅÒÓ¦§ 5 - ÍÏ×Á ÐÒÅÐÒÏÃÅÓÕ×ÁÎÎÑ HTML-ÆÁÊ̦×, ×ÉËÏÎÕ×ÁÎÁ ÎÁ ÓÅÒ×ÅÒ¦
 Name:          php
-Version:       5.2.0
+Version:       5.2.1
 Release:       %{_rel}%{?with_hardening:hardened}
 Epoch:         4
 License:       PHP
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{name}-%{version}.tar.bz2
-# Source0-md5: e6029fafcee029edcfa2ceed7a005333
+# Source0-md5: 261218e3569a777dbd87c16a15f05c8d
 Source2:       zend.gif
 Source3:       %{name}-mod_%{name}.conf
 Source4:       %{name}-cgi-fcgi.ini
@@ -106,9 +106,7 @@ Patch8:             %{name}-no-metaccld.patch
 Patch9:                %{name}-sh.patch
 Patch10:       %{name}-ini.patch
 Patch11:       %{name}-acam.patch
-Patch12:       %{name}-curl.patch
-Patch13:       %{name}-bug-40073.patch
-Patch15:       %{name}-threads-acfix.patch
+#Patch15:      %{name}-threads-acfix.patch
 Patch16:       %{name}-tsrmlsfetchgcc2.patch
 Patch17:       %{name}-no_pear_install.patch
 Patch18:       %{name}-zlib.patch
@@ -124,9 +122,8 @@ Patch32:    %{name}-builddir.patch
 Patch33:       %{name}-zlib-for-getimagesize.patch
 Patch35:       %{name}-versioning.patch
 Patch36:       %{name}-linkflags-clean.patch
-Patch38:       %{name}-memory-limit.patch
+
 Patch39:       %{name}-pear.patch
-Patch40:       %{name}-db4.5.patch
 Patch41:       %{name}-config-dir.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
@@ -164,7 +161,7 @@ BuildRequires:      libwrap-devel
 BuildRequires: libxml2-devel >= 2.5.10
 BuildRequires: libxslt-devel >= 1.1.0
 %{?with_mhash:BuildRequires:   mhash-devel}
-%{?with_ming:BuildRequires:    ming-devel >= 0.2a-11}
+%{?with_ming:BuildRequires:    ming-devel >= 0.3}
 %{?with_mm:BuildRequires:      mm-devel >= 1.3.0}
 BuildRequires: mysql-devel >= 4.0.0
 %{?with_mysqli:BuildRequires:  mysql-devel >= 4.1.0}
@@ -201,6 +198,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                php_sysconfdir          /etc/php
 %define                php_extensiondir        %{_libdir}/php
+%define                _sysconfdir             %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
 %define                php_api_version         20041225
@@ -1125,6 +1123,8 @@ Summary(pl):      Modu
 Group:         Libraries
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Provides:      php(pgsql)
+Provides:      php-pecl-PDO_PGSQL
+Obsoletes:     php-pecl-PDO_PGSQL
 
 %description pgsql
 This is a dynamic shared object (DSO) for PHP that will add PostgreSQL
@@ -1310,6 +1310,7 @@ Group:            Libraries
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Provides:      php(sybase)
 Obsoletes:     php-sybase-ct
+Conflicts:     php-sybase-ct
 
 %description sybase
 This is a dynamic shared object (DSO) for PHP that will add Sybase and
@@ -1329,6 +1330,7 @@ Group:            Libraries
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Provides:      php(sybase-ct)
 Obsoletes:     php-sybase
+Conflicts:     php-sybase
 
 %description sybase-ct
 This is a dynamic shared object (DSO) for PHP that will add Sybase and
@@ -1562,11 +1564,7 @@ cp php.ini-dist php.ini
 # for ac2.53b/am1.6b - AC_LANG_CXX has AM_CONDITIONAL, so cannot be invoked
 # conditionally...
 %patch11 -p1
-%patch12 -p1
-cd ext/exif
-%patch13 -p0
-cd ../../
-%patch15 -p1
+#%patch15 -p1 # breaks with ac cache vars, but later -lpthread is missing ...
 %patch16 -p1
 %patch17 -p1
 %patch18 -p1
@@ -1584,12 +1582,10 @@ patch -p1 < %{PATCH30} || exit 1
 %patch31 -p1
 %patch32 -p1
 %patch33 -p1
+
 %{?with_versioning:%patch35 -p1}
-%ifarch %{x8664} alpha
-%patch38 -p1
-%endif
+
 %patch39 -p1
-%patch40 -p1
 %patch41 -p1
 
 # conflict seems to be resolved by recode patches
@@ -1800,7 +1796,7 @@ done
 %{__make} build-modules
 
 %if %{with apache1}
-%{__make} libtool-sapi LIBTOOL_SAPI=sapi/apache/libphp5.la -f Makefile.apxs1
+%{__make} libtool-sapi LIBTOOL_SAPI=sapi/apache/libphp5.la -f Makefile.apxs1 LDFLAGS=-lpthread
 %endif
 
 %if %{with apache2}
@@ -1810,18 +1806,18 @@ done
 # FCGI
 %if %{with fcgi}
 cp -af php_config.h.fcgi main/php_config.h
-%{__make} sapi/cgi/php -f Makefile.fcgi
+%{__make} sapi/cgi/php -f Makefile.fcgi LDFLAGS=-lpthread
 cp -r sapi/cgi sapi/fcgi
 rm -rf sapi/cgi/.libs sapi/cgi/*.lo
 %endif
 
 # CGI
 cp -af php_config.h.cgi main/php_config.h
-%{__make} sapi/cgi/php -f Makefile.cgi
+%{__make} sapi/cgi/php -f Makefile.cgi LDFLAGS=-lpthread
 
 # CLI
 cp -af php_config.h.cli main/php_config.h
-%{__make} sapi/cli/php -f Makefile.cli
+%{__make} sapi/cli/php -f Makefile.cli LDFLAGS=-lpthread
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.039123 seconds and 4 git commands to generate.