]> git.pld-linux.org Git - packages/mysql.git/blobdiff - mysql.spec
- updated to Percona 29.2 rel and sphinx 2.0.6
[packages/mysql.git] / mysql.spec
index d804775a700c7c13c7cca0096e9e8b9aa316013d..e608a9b60dc4301550f649f7db736143f2b5a41c 100644 (file)
@@ -1,10 +1,4 @@
 # TODO:
-# - unpackaged files:
-#   /usr/lib/mysql/plugin/auth_pam.so
-#   /usr/lib/mysql/plugin/auth_pam_compat.so
-#   /usr/lib/mysql/plugin/daemon_example.ini
-#   /usr/lib/mysql/plugin/dialog.so
-#   /usr/bin/mysqlaccess.conf
 # - make response_time_distribution.patch compatible with i386 alpha sparc ppc arches
 # - mysqldump ... (invalid usage) prints to stdout not stderr (idiotic if you want to create dump and get usage in .sql)
 # - http://bugs.mysql.com/bug.php?id=16470
@@ -29,6 +23,7 @@
 %bcond_with    tests           # FIXME: don't run correctly
 %bcond_with    ndb             # NDB is now a separate product, this here is broken, so disable it
 
+%define        percona_rel     29.2
 %include       /usr/lib/rpm/macros.perl
 Summary:       MySQL: a very fast and reliable SQL database engine
 Summary(de.UTF-8):     MySQL: ist eine SQL-Datenbank
@@ -39,17 +34,16 @@ Summary(ru.UTF-8):  MySQL - быстрый SQL-сервер
 Summary(uk.UTF-8):     MySQL - швидкий SQL-сервер
 Summary(zh_CN.UTF-8):  MySQL数据库服务器
 Name:          mysql
-%define        percona_rel     26.0
-Version:       5.5.24
-Release:       0.1
+Version:       5.5.28
+Release:       3
 License:       GPL + MySQL FLOSS Exception
 Group:         Applications/Databases
 # Source0Download: http://dev.mysql.com/downloads/mysql/5.5.html#downloads
 # Source0:     http://vesta.informatik.rwth-aachen.de/mysql/Downloads/MySQL-5.5/%{name}-%{version}.tar.gz
-Source0:       http://www.percona.com/redir/downloads/Percona-Server-5.5/Percona-Server-5.5.24-26.0/source/Percona-Server-5.5.24-rel26.0.tar.gz
-# Source0-md5: 76f835e98ad3c71fcaa33794ee187630
-Source100:     http://sphinxsearch.com/files/sphinx-2.0.3-release.tar.gz
-# Source100-md5:       a1293aecd5034aa797811610beb7ba89
+Source0:       http://www.percona.com/redir/downloads/Percona-Server-5.5/LATEST/source/Percona-Server-%{version}-rel29.2.tar.gz
+# Source0-md5: b78987d18541d8ff22a2d523468162da
+Source100:     http://sphinxsearch.com/files/sphinx-2.0.6-release.tar.gz
+# Source100-md5:       de6be5ee20b1bfafa2a0cea7155a8331
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}.logrotate
@@ -65,12 +59,12 @@ Source13:   %{name}-client.conf
 Source14:      my.cnf
 # from fedora
 Source15:      lib%{name}.version
-Patch2:                %{name}-c++.patch
-Patch3:                %{name}-info.patch
+
+Patch3:                bug-67402.patch
 # from fedora
 Patch5:                %{name}-versioning.patch
 Patch6:                %{name}-system-users.patch
-Patch7:                %{name}-bug-34192.patch
+
 Patch8:                %{name}-client-config.patch
 Patch9:                %{name}-build.patch
 Patch11:       %{name}-upgrade.patch
@@ -128,8 +122,6 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _localstatedir  /var/lib/mysql
 %define                _mysqlhome      /home/services/mysql
 
-%define                _noautoreqdep   'perl(DBD::mysql)'
-
 %description
 MySQL is a true multi-user, multi-threaded SQL (Structured Query
 Language) database server. SQL is the most popular database language
@@ -498,13 +490,12 @@ Ten pakiet zawiera standardowego demona MySQL NDB CPC.
 mv sphinx-*/mysqlse storage/sphinx
 %patch18 -p1
 %endif
-#%patch2 -p1 # NEEDS CHECK, which exact program needs -lc++
-# obsolete, no more docs?
-#%patch3 -p1
+
+%patch3 -p1
+
 %patch5 -p1
 %patch6 -p1
-# make sure mysqldump still works with 4.0
-#%patch7 -p1
+
 %patch8 -p1
 %patch9 -p1
 %patch11 -p1
@@ -562,6 +553,8 @@ cp -a %{SOURCE15} libmysql/libmysql.version
        -DINSTALL_MYSQLTESTDIR_RPM="" \
        -DINSTALL_SQLBENCHDIR=%{_datadir} \
        -DINSTALL_SUPPORTFILESDIR=%{_datadir}/%{name}-support \
+       -DINSTALL_PLUGINDIR=%{_libdir}/%{name}/plugin \
+       -DINSTALL_LIBDIR=%{_lib} \
        ..
 
 %{__make}
@@ -588,11 +581,6 @@ cp -a %{SOURCE4} mysqld.conf
 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/clusters.conf
 touch $RPM_BUILD_ROOT/var/log/%{name}/{mysqld,query,slow}.log
 
-%if "%{_lib}" != "lib"
-# percona broke something with lib64 handling
-mv $RPM_BUILD_ROOT%{_prefix}/lib/* $RPM_BUILD_ROOT%{_libdir}
-%endif
-
 # remove innodb directives from mysqld.conf if mysqld is configured without
 %if %{without innodb}
        cp mysqld.conf mysqld.tmp
@@ -631,6 +619,9 @@ sed -i -e '/libs/s/$ldflags//' $RPM_BUILD_ROOT%{_bindir}/mysql_config
 mv $RPM_BUILD_ROOT%{_bindir}/{,mysql_}resolve_stack_dump
 mv $RPM_BUILD_ROOT%{_mandir}/man1/{,mysql_}resolve_stack_dump.1
 
+# move to _sysconfdir
+mv $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}}/mysqlaccess.conf
+
 # not useful without -debug build
 %{!?debug:%{__rm} $RPM_BUILD_ROOT%{_bindir}/mysql_resolve_stack_dump}
 %{!?debug:%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/mysql_resolve_stack_dump.1}
@@ -675,7 +666,8 @@ mv $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/mysqlcheck
 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/mysql-test
 
 # not needed
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/plugin/libdaemon_example.*
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/plugin/libdaemon_example.* \
+${__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/plugin/daemon_example.ini
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -895,8 +887,11 @@ done
 %dir %{_libdir}/%{name}/plugin
 %attr(755,root,root) %{_libdir}/%{name}/plugin/adt_null.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/auth.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/auth_pam.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/auth_pam_compat.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/auth_socket.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/auth_test_plugin.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/dialog.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/ha_archive.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/ha_blackhole.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/ha_federated.so
@@ -1006,6 +1001,7 @@ done
 %attr(755,root,root) %{_bindir}/mysql_zap
 %attr(755,root,root) %{_bindir}/mysqlaccess
 %attr(755,root,root) %{_bindir}/mysqldumpslow
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mysqlaccess.conf
 %{_mandir}/man1/mysql_convert_table_format.1*
 %{_mandir}/man1/mysql_find_rows.1*
 %{_mandir}/man1/mysql_fix_extensions.1*
This page took 0.030111 seconds and 4 git commands to generate.