]> git.pld-linux.org Git - packages/mysql.git/blobdiff - mysql.spec
8.0 still supports 32bit (and we are back to 8.0 series)
[packages/mysql.git] / mysql.spec
index 5cc8b70af6c00ded9ec1230d0d9e8d205fd5ec67..9b19edb05fc3041e1d1bf5486e0bceb3720c262d 100644 (file)
@@ -35,15 +35,16 @@ Summary(pt_BR.UTF-8):       MySQL: Um servidor SQL rápido e confiável
 Summary(ru.UTF-8):     MySQL - быстрый SQL-сервер
 Summary(uk.UTF-8):     MySQL - швидкий SQL-сервер
 Summary(zh_CN.UTF-8):  MySQL数据库服务器
-%define majorver        8.1
+%define majorver        8.0
 Name:          mysql%{majorver}
-Version:       8.1.0
+# keep stable (and not "innovation") line here
+Version:       8.0.36
 Release:        0.1
 License:       GPL v2 + MySQL FOSS License Exception
 Group:         Applications/Databases
-#Source0Download: https://dev.mysql.com/downloads/mysql/8.1.html#downloads
-Source0:       http://cdn.mysql.com/Downloads/MySQL-8.1/mysql-%{version}.tar.gz
-# Source0-md5: 13fe8f9f463b2f462763cd21459590a0
+#Source0Download: https://dev.mysql.com/downloads/mysql/8.0.html#downloads
+Source0:       http://cdn.mysql.com/Downloads/MySQL-%{majorver}/mysql-%{version}.tar.gz
+# Source0-md5: 08bc8e4307246e77d013267e2cd8fa49
 Source100:     http://www.sphinxsearch.com/files/sphinx-2.2.11-release.tar.gz
 # Source100-md5:       5cac34f3d78a9d612ca4301abfcbd666
 %if %{without system_boost}
@@ -65,7 +66,6 @@ Source13:     mysql-client.conf
 Source14:      my.cnf
 Patch0:                mysql-opt.patch
 Patch1:                mysql-system-xxhash.patch
-Patch2:         notests-workaround.patch
 
 Patch17:       mysql-5.7-sphinx.patch
 Patch18:       mysql-sphinx.patch
@@ -478,9 +478,6 @@ Ten pakiet zawiera standardowego demona MySQL NDB CPC.
 # FIXME
 #%patch1 -p1
 
-# when tests are not built there is no cstrbuf-t target
-%{!?with_tests:%patch2 -p1}
-
 %if %{with sphinx}
 # http://www.sphinxsearch.com/docs/manual-0.9.9.html#sphinxse-mysql51
 %{__mv} sphinx-*/mysqlse storage/sphinx
@@ -524,6 +521,7 @@ CPPFLAGS="%{rpmcppflags}" \
         -DINSTALL_PRIV_LIBDIR=%{_libdir}/%{name}/private \
        -DINSTALL_MYSQLTESTDIR_RPM="" \
        -DINSTALL_PLUGINDIR=%{_lib}/%{name}/plugin \
+        -DINSTALL_SECURE_FILE_PRIVDIR=/var/lib/%{name}-files \
        -DINSTALL_SQLBENCHDIR=%{_datadir} \
        -DINSTALL_SUPPORTFILESDIR=share/%{name}-support \
        -DINSTALL_MYSQLSHAREDIR=share/%{name} \
@@ -557,19 +555,20 @@ CPPFLAGS="%{rpmcppflags}" \
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig,%{name},skel} \
-          $RPM_BUILD_ROOT/var/{log/{archive,}/%{name},lib/{mysql,%{name}-files}} \
+          $RPM_BUILD_ROOT/var/{log/{archive,}/%{name},lib/{%{name},%{name}-files}} \
           $RPM_BUILD_ROOT%{_mysqlhome} \
           $RPM_BUILD_ROOT%{_libdir}
 
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
+sed -e 's#{MYSQL_MAJOR}#%{majorver}#g' %{SOURCE1} > $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
+
 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
-cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
+sed -e 's#{MYSQL_MAJOR}#%{majorver}#g' %{SOURCE3} > $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 # This is template for configuration file which is created after 'service mysql init'
-cp -a %{SOURCE4} mysqld.conf
-cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/clusters.conf
+sed -e 's#{MYSQL_MAJOR}#%{majorver}#g' %{SOURCE4} > mysqld.conf
+sed -e 's#{MYSQL_MAJOR}#%{majorver}#g' %{SOURCE5} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/clusters.conf
 touch $RPM_BUILD_ROOT/var/log/%{name}/{mysqld,query,slow}.log
 
 mv $RPM_BUILD_ROOT/etc/logrotate.d/{mysqlrouter,%{name}router}
@@ -834,7 +833,8 @@ fi
 
 %attr(700,mysql,mysql) %{_mysqlhome}
 # root:root is proper here for mysql.rpm while mysql:mysql is potential security hole
-%attr(751,root,root) /var/lib/mysql
+%attr(751,root,root) /var/lib/%{name}
+%attr(750,mysql,mysql) %dir /var/lib/%{name}-files
 %attr(750,mysql,mysql) %dir /var/log/%{name}
 %attr(750,mysql,mysql) %dir /var/log/archive/%{name}
 %attr(640,mysql,mysql) %ghost /var/log/%{name}/*
@@ -923,7 +923,7 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/mysql-client.conf
 %{_sysconfdir}/%{name}/my.cnf
 %attr(755,root,root) %{_libdir}/libmysqlclient.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libmysqlclient.so.22
+%attr(755,root,root) %ghost %{_libdir}/libmysqlclient.so.21
 %if %{with ndb}
 %attr(755,root,root) %{_libdir}/libndbclient.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libndbclient.so.3
This page took 0.033469 seconds and 4 git commands to generate.