]> git.pld-linux.org Git - packages/mysql.git/blobdiff - mysql.spec
- added align patch (workaround not to use void* alignment when accessing chars)
[packages/mysql.git] / mysql.spec
index 009eb4e600b7c5a4c40e1e709bd0e44a2b0b5bfb..8053e8679fd77d29c148020aa83854811262cda4 100644 (file)
@@ -1,6 +1,16 @@
+# TODO:
+# - trigger that prepares system from pre-cluster into cluster
+# - trigger /etc/mysqld.conf into /etc/mysql/mysqld.conf. Solve possible
+#   conflict with /var/lib/mysql/mysqld.conf
+# - what's the libwrapper constistent bcond name? I see in specs 'libwrap', 'tcpd', 'tcp_wrappers'
 #
 # Conditional build:
 %bcond_with    bdb     # Berkeley DB support
+%bcond_without innodb  # Without InnoDB support
+%bcond_without isam    # Without ISAM table format (used in mysql 3.22)
+%bcond_without raid    # Without raid
+%bcond_without ssl     # Without OpenSSL
+%bcond_without tcpd    # Without libwrap (tcp_wrappers) support
 #
 %include       /usr/lib/rpm/macros.perl
 Summary:       MySQL: a very fast and reliable SQL database engine
@@ -12,25 +22,32 @@ Summary(uk):        MySQL - 
 Summary(zh_CN):        MySQLÊý¾Ý¿â·þÎñÆ÷
 Name:          mysql
 Group:         Applications/Databases
-Version:       4.0.18
-Release:       2
-License:       GPL/LGPL
-Source0:       http://sunsite.icm.edu.pl/mysql/Downloads/MySQL-4.0/mysql-%{version}.tar.gz
-# Source0-md5: 702151a3e21d9e5f32e8850032aefdad
+Version:       4.1.10
+Release:       1
+License:       GPL + MySQL FLOSS Exception
+Source0:       http://mysql.mirror.anlx.net/Downloads/MySQL-4.1/%{name}-%{version}.tar.gz
+# Source0-md5: 27b27b74f430aaeb77fb8d4e6f32ac4d
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}.logrotate
 Source4:       %{name}d.conf
+Source5:       %{name}-clusters.conf
+Source6:       %{name}.monitrc
+Source7:       %{name}-ndb.init
+Source8:       %{name}-ndb.sysconfig
+Source9:       %{name}-ndb-mgm.init
+Source10:      %{name}-ndb-mgm.sysconfig
+Source11:      %{name}-ndb-cpc.init
+Source12:      %{name}-ndb-cpc.sysconfig
 Patch0:                %{name}-libs.patch
 Patch1:                %{name}-libwrap.patch
 Patch2:                %{name}-c++.patch
-Patch3:                %{name}-_r-link.patch
-Patch4:                %{name}-info.patch
-Patch5:                %{name}-dump_quote_db_names.patch
-Patch7:                %{name}-sql-cxx-pic.patch
-Patch8:                %{name}-noproc.patch
-Patch9:                %{name}-fix_privilege_tables.patch
-Patch10:       %{name}-nptl.patch
+Patch3:                %{name}-info.patch
+Patch4:                %{name}-sql-cxx-pic.patch
+Patch5:                %{name}-noproc.patch
+Patch6:                %{name}-fix_privilege_tables.patch
+Patch7:                %{name}-nptl.patch
+Patch8:                %{name}-align.patch
 Icon:          mysql.gif
 URL:           http://www.mysql.com/
 #BuildRequires:        ORBit-devel
@@ -40,13 +57,14 @@ BuildRequires:      automake
 %{?with_bdb:BuildRequires:     db3-devel}
 BuildRequires: libstdc++-devel >= 5:3.0
 BuildRequires: libtool
-BuildRequires: libwrap-devel
+%{?with_tcpd:BuildRequires:    libwrap-devel}
 BuildRequires: ncurses-devel >= 4.2
-BuildRequires: openssl-devel >= 0.9.7d
+%{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7d}
 BuildRequires: perl-DBI
-BuildRequires: perl-devel >= 5.6.1
+BuildRequires: perl-devel >= 1:5.6.1
 BuildRequires: readline-devel >= 4.2
-BuildRequires: rpm-perlprov
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: rpmbuild(macros) >= 1.159
 BuildRequires: texinfo
 BuildRequires: zlib-devel
 PreReq:                rc-scripts >= 0.2.0
@@ -60,18 +78,18 @@ Requires(post,preun):       /sbin/chkconfig
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      /usr/bin/setsid
 Provides:      MySQL-server
+Provides:      group(mysql)
 Provides:      msqlormysql
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+Provides:      user(mysql)
 Obsoletes:     MySQL
 Obsoletes:     mysql-server
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _libexecdir     %{_sbindir}
 %define                _localstatedir  /var/lib/mysql
 %define                _mysqlhome      /home/services/mysql
 
 %define                _noautoreqdep   'perl(DBD::mysql)'
-# workaround for buggy gcc 3.3.1
-%define        specflags_alpha "-mno-explicit-relocs"
 
 %description
 MySQL is a true multi-user, multi-threaded SQL (Structured Query
@@ -123,8 +141,8 @@ G
 MySQL oryginalnie by³ tworzony, poniewa¿ autorzy w Tcx potrzebowali
 serwera SQL do obs³ugi bardzo du¿ych baz danych z szybko¶ci± o wiele
 wiêksz±, ni¿ mogli zaoferowaæ inni producenci baz danych. U¿ywaj± go
-od 1996 roku w ¶rodowisku z ponad 40 bazami danych, 10 000 tabel,
-których ponad 500 zawiera ponad 7 milionów rekordów - w sumie oko³o
+od 1996 roku w ¶rodowisku z ponad 40 bazami danych, 10 000 tabel, z
+których ponad 500 zawiera ponad 7 milionów rekordów - w sumie oko³o
 50GB krytycznych danych.
 
 Baza, na której oparty jest MySQL, sk³ada siê ze zbioru procedur,
@@ -238,7 +256,7 @@ Summary(ru):        MySQL - 
 Summary(uk):   MySQL - ÈÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ ÐÒÏÇÒÁͦÓÔÁ
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      openssl-devel
+%{?with_ssl:Requires:  openssl-devel}
 Requires:      zlib-devel
 Obsoletes:     MySQL-devel
 Obsoletes:     libmysql10-devel
@@ -328,72 +346,129 @@ Group:           Applications/Databases
 This package contains manual in HTML format.
 
 %description doc -l pl
-Podrêcznik MySQL-a w formacie HTML. 
+Podrêcznik MySQL-a w formacie HTML.
+
+%package ndb
+Summary:       MySQL - NDB Storage Engine Daemon
+Summary(pl):   MySQL - demon silnika przechowywania danych NDB
+Group:         Applications/Databases
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description ndb
+This package contains the standard MySQL NDB Storage Engine Daemon.
+
+%description ndb -l pl
+Ten pakiet zawiera standardowego demona silnika przechowywania danych
+NDB.
+
+%package ndb-client
+Summary:       MySQL - NDB Clients
+Summary(pl):   MySQL - programy klienckie NDB
+Group:         Applications/Databases
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description ndb-client
+This package contains the standard MySQL NDB Clients.
+
+%description ndb-client -l pl
+Ten pakiet zawiera standardowe programy klienckie MySQL NDB.
+
+%package ndb-mgm
+Summary:       MySQL - NDB Management Daemon
+Summary(pl):   MySQL - demon zarz±dzaj±cy NDB
+Group:         Applications/Databases
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description ndb-mgm
+This package contains the standard MySQL NDB Management Daemon.
+
+%description ndb-mgm -l pl
+Ten pakiet zawiera standardowego demona zarz±dzaj±cego MySQL NDB.
+
+%package ndb-cpc
+Summary:       MySQL - NDB CPC Daemon
+Summary(pl):   MySQL - demon NDB CPC
+Group:         Applications/Databases
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description ndb-cpc
+This package contains the standard MySQL NDB CPC Daemon.
+
+%description ndb-cpc -l pl
+Ten pakiet zawiera standardowego demona MySQL NDB CPC.
 
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
+%{?with_tcpd:%patch1 -p1}
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
-#%patch5 -p1
 %ifarch alpha
 # this is strange: mysqld functions for UDF modules are not explicitly defined,
 # so -rdynamic is used; in such case gcc3+ld on alpha doesn't like C++ vtables
 # in objects compiled without -fPIC
-%patch7 -p1
+%patch4 -p1
 %endif
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
 %patch8 -p1
-%patch9 -p1
-%patch10 -p1
 
-%{__perl} -pi -e 's@/lib/libpthread@/%{_lib}/libpthread@' configure.in
+%{__perl} -pi -e 's@(ndb_bin_am_ldflags)="-static"@$1=""@' configure.in
 
 %build
 %{__libtoolize}
 %{__aclocal}
 %{__automake}
 %{__autoconf}
-CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions %{!?debug:-fomit-frame-pointer}"
+# The compiler flags are as per their "official" spec ;)
+CXXFLAGS="%{rpmcflags} -felide-constructors -fno-rtti -fno-exceptions %{!?debug:-fomit-frame-pointer}"
 CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}"
 %configure \
        PS='/bin/ps' \
        FIND_PROC='/bin/ps p $$PID' \
        KILL='/bin/kill' \
        CHECK_PID='/bin/kill -0 $$PID' \
-       -C \
        --enable-assembler \
        --enable-shared \
        --enable-static \
        --enable-thread-safe-client \
-       %{?with_bdb:--with-berkeley-db} \
+       --with%{!?with_bdb:out}-berkeley-db \
+       --with%{!?with_innodb:out}-innodb \
+       --with%{!?with_isam:out}-isam \
+       --with%{!?with_raid:out}-raid \
+       --with%{!?with_ssl:out}-openssl \
+       --with%{!?with_tcpd:out}-libwrap \
        --with-comment="PLD Linux Distribution MySQL RPM" \
        --with%{!?debug:out}-debug \
        --with-embedded-server \
        --with-extra-charsets=all \
-       --with-libwrap \
        --with-low-memory \
        --with-mysqld-user=mysql \
        --with-named-curses-libs="-lncurses" \
-       --with-openssl \
        --with-pthread \
-       --with-raid \
        --with-unix-socket-path=/var/lib/mysql/mysql.sock \
        --with-vio \
+       --with-ndbcluster \
        --without-readline \
        --without-docs
 #      --with-mysqlfs
 
+# NOTE that /var/lib/mysql/mysql.sock is symlink to real sock file
+# (it defaults to first cluster but user may change it to whatever
+#  cluster it wants)
+
 echo -e "all:\ninstall:\nclean:\nlink_sources:\n" > libmysqld/examples/Makefile
 
-%{__make} benchdir=$RPM_BUILD_ROOT%{_datadir}/sql-bench
+%{__make} \
+       benchdir=$RPM_BUILD_ROOT%{_datadir}/sql-bench
+
 %{__make} -C Docs mysql.info
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig} \
-          $RPM_BUILD_ROOT/var/{log/{archiv,}/mysql,lib/mysql/{db,innodb/{data,log}}} \
+install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig,mysql,monit} \
+          $RPM_BUILD_ROOT/var/{log/{archiv,}/mysql,lib/mysql} \
           $RPM_BUILD_ROOT{%{_infodir},%{_mysqlhome}}
 
 %if %{with bdb}
@@ -412,33 +487,60 @@ install Docs/mysql.info $RPM_BUILD_ROOT%{_infodir}
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/mysql
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/mysql
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/mysql
-install %{SOURCE4} $RPM_BUILD_ROOT%{_datadir}/mysql/mysqld.conf
+# This is template for configuration file which is created after 'service mysql init'
+install %{SOURCE4} mysqld.conf
+install %{SOURCE5} $RPM_BUILD_ROOT/etc/mysql/clusters.conf
+install %{SOURCE6} $RPM_BUILD_ROOT/etc/monit
 touch $RPM_BUILD_ROOT/var/log/mysql/{err,log,update,isamlog.log}
 
+# remove innodb directives from mysqld.conf if mysqld is configured without
+%if %{without innodb}
+       cp mysqld.conf mysqld.tmp
+       awk 'BEGIN { RS="\n\n" } !/innodb/ { printf("%s\n\n", $0) }' < mysqld.tmp > mysqld.conf
+%endif
+
+# remove berkeley-db directives from mysqld.conf if mysqld is configured without
+%if %{without bdb}
+       cp mysqld.conf mysqld.tmp
+       awk 'BEGIN { RS="\n\n" } !/bdb/ { printf("%s\n\n", $0) }' < mysqld.tmp > mysqld.conf
+%endif
+
+install mysqld.conf $RPM_BUILD_ROOT%{_datadir}/mysql/mysqld.conf
+
+# NDB
+install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/mysql-ndb
+install %{SOURCE8} $RPM_BUILD_ROOT/etc/sysconfig/mysql-ndb
+install %{SOURCE9} $RPM_BUILD_ROOT/etc/rc.d/init.d/mysql-ndb-mgm
+install %{SOURCE10} $RPM_BUILD_ROOT/etc/sysconfig/mysql-ndb-mgm
+install %{SOURCE11} $RPM_BUILD_ROOT/etc/rc.d/init.d/mysql-ndb-cpc
+install %{SOURCE12} $RPM_BUILD_ROOT/etc/sysconfig/mysql-ndb-cpc
+
 # remove mysqld's *.po files
 find . $RPM_BUILD_ROOT%{_datadir}/%{name} -name \*.txt | xargs -n 100 rm -f
 mv -f $RPM_BUILD_ROOT%{_libdir}/mysql/lib* $RPM_BUILD_ROOT%{_libdir}
 %{__perl} -pi -e 's,%{_libdir}/mysql,%{_libdir},;' $RPM_BUILD_ROOT%{_libdir}/libmysqlclient.la
 
+rm -rf $RPM_BUILD_ROOT%{_prefix}/mysql-test
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %pre
-if [ -n "`getgid mysql`" ]; then
-       if [ "`getgid mysql`" != "89" ]; then
+if [ -n "`/usr/bin/getgid mysql`" ]; then
+       if [ "`/usr/bin/getgid mysql`" != "89" ]; then
                echo "Error: group mysql doesn't have gid=89. Correct this before installing mysql." 1>&2
                exit 1
        fi
 else
-       /usr/sbin/groupadd -g 89 -r -f mysql
+       /usr/sbin/groupadd -g 89 mysql
 fi
-if [ -n "`id -u mysql 2>/dev/null`" ]; then
-       if [ "`id -u mysql`" != "89" ]; then
+if [ -n "`/bin/id -u mysql 2>/dev/null`" ]; then
+       if [ "`/bin/id -u mysql`" != "89" ]; then
                echo "Error: user mysql doesn't have uid=89. Correct this before installing mysql." 1>&2
                exit 1
        fi
 else
-       /usr/sbin/useradd -M -o -r -u 89 \
+       /usr/sbin/useradd -u 89 \
                        -d %{_mysqlhome} -s /bin/sh -g mysql \
                        -c "MySQL Server" mysql 1>&2
 fi
@@ -463,40 +565,111 @@ fi
 %postun
 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 if [ "$1" = "0" ]; then
-       /usr/sbin/userdel mysql
-       /usr/sbin/groupdel mysql
+       %userremove mysql
+       %groupremove mysql
+fi
+
+%post ndb
+/sbin/chkconfig --add mysql-ndb
+if [ -f /var/lock/subsys/mysql-ndb ]; then
+        /etc/rc.d/init.d/mysql-ndb restart >&2
+else
+        echo "Run \"/etc/rc.d/init.d/mysql-ndb start\" to start mysql NDB engine." >&2
+fi
+
+%preun ndb
+if [ "$1" = "0" ]; then
+        if [ -f /var/lock/subsys/mysql-ndb ]; then
+                /etc/rc.d/init.d/mysql-ndb stop
+        fi
+        /sbin/chkconfig --del mysql-ndb
+fi
+
+%post ndb-mgm
+/sbin/chkconfig --add mysql-ndb-mgm
+if [ -f /var/lock/subsys/mysql-ndb-mgm ]; then
+        /etc/rc.d/init.d/mysql-ndb-mgm restart >&2
+else
+        echo "Run \"/etc/rc.d/init.d/mysql-ndb-mgm start\" to start mysql NDB management node." >&2
+fi
+
+%preun ndb-mgm
+if [ "$1" = "0" ]; then
+        if [ -f /var/lock/subsys/mysql-ndb-mgm ]; then
+                /etc/rc.d/init.d/mysql-ndb-mgm stop
+        fi
+        /sbin/chkconfig --del mysql-ndb-mgm
+fi
+
+%post ndb-cpc
+/sbin/chkconfig --add mysql-ndb-cpc
+if [ -f /var/lock/subsys/mysql-ndb-cpc ]; then
+        /etc/rc.d/init.d/mysql-ndb-cpc restart >&2
+else
+        echo "Run \"/etc/rc.d/init.d/mysql-ndb-cpc start\" to start mysql NDB CPC." >&2
+fi
+
+%preun ndb-cpc
+if [ "$1" = "0" ]; then
+        if [ -f /var/lock/subsys/mysql-ndb-cpc ]; then
+                /etc/rc.d/init.d/mysql-ndb-cpc stop
+        fi
+        /sbin/chkconfig --del mysql-ndb-cpc
 fi
 
 %post   libs -p /sbin/ldconfig
 %postun libs -p /sbin/ldconfig
 
+%triggerpostun -- mysql <= 4.0.20-2
+# For clusters in /etc/mysql/clusters.conf
+if [ -f "/etc/sysconfig/mysql" ]; then
+       . /etc/sysconfig/mysql
+       if [ -n "$MYSQL_DB_CLUSTERS" ]; then
+               for i in "$MYSQL_DB_CLUSTERS"; do
+                       echo "$i/mysqld.conf=$i" >> /etc/mysql/clusters.conf
+               done
+               echo "# Do not use **obsolete** option MYSQL_DB_CLUSTERS" >> /etc/sysconfig/mysql
+               echo "# USE /etc/mysql/clusters.conf instead" >> /etc/sysconfig/mysql
+               echo "Converted clusters from MYSQL_DB_CLUSTERS to /etc/mysql/clusters.conf."
+               echo "You NEED to fix your /etc/sysconfig/mysql and verify /etc/mysql/clusters.conf."
+       fi
+fi
+
 %files
 %defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/logrotate.d/mysql
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/mysql
 %attr(754,root,root) /etc/rc.d/init.d/mysql
-%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/mysql
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mysql
+%attr(751,root,root) %dir /etc/mysql
+%attr(640,root,mysql) %config(noreplace) %verify(not md5 mtime size) /etc/mysql/clusters.conf
+%attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/*.monitrc
 %attr(755,root,root) %{_bindir}/isamchk
 %attr(755,root,root) %{_bindir}/isamlog
 %attr(755,root,root) %{_bindir}/myisamchk
 %attr(755,root,root) %{_bindir}/myisamlog
 %attr(755,root,root) %{_bindir}/myisampack
+%attr(755,root,root) %{_bindir}/mysql_fix_privilege_tables
 %attr(755,root,root) %{_bindir}/pack_isam
 %attr(755,root,root) %{_sbindir}/mysqld
 %{_mandir}/man1/isamchk.1*
 %{_mandir}/man1/isamlog.1*
+%{_mandir}/man1/mysql_fix_privilege_tables.1*
 %{_mandir}/man1/mysqld.1*
 
 %attr(700,mysql,mysql) %{_mysqlhome}
+# root:root is proper here for AC mysql.rpm while mysql:mysql is potential security hole
 %attr(751,root,root) /var/lib/mysql
 %attr(750,mysql,mysql) %dir /var/log/mysql
 %attr(750,mysql,mysql) %dir /var/log/archiv/mysql
-%attr(640,mysql,mysql) %config(noreplace) %verify(not md5 size mtime) /var/log/mysql/*
+%attr(640,mysql,mysql) %config(noreplace) %verify(not md5 mtime size) /var/log/mysql/*
 
 %{_infodir}/mysql.info*
 %dir %{_datadir}/mysql
+# This is template for configuration file which is created after 'service mysql init'
 %{_datadir}/mysql/mysqld.conf
 %{_datadir}/mysql/charsets
 %{_datadir}/mysql/english
+%{_datadir}/mysql/mysql_fix_privilege_tables.sql
 %lang(cs) %{_datadir}/mysql/czech
 %lang(da) %{_datadir}/mysql/danish
 %lang(de) %{_datadir}/mysql/german
@@ -515,6 +688,7 @@ fi
 %lang(pt) %{_datadir}/mysql/portuguese
 %lang(ro) %{_datadir}/mysql/romanian
 %lang(ru) %{_datadir}/mysql/russian
+%lang(sr) %{_datadir}/mysql/serbian
 %lang(sk) %{_datadir}/mysql/slovak
 %lang(sv) %{_datadir}/mysql/swedish
 %lang(uk) %{_datadir}/mysql/ukrainian
@@ -522,12 +696,10 @@ fi
 %files extras
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/msql2mysql
-%attr(755,root,root) %{_bindir}/mysql_fix_privilege_tables
 %attr(755,root,root) %{_bindir}/perror
 %attr(755,root,root) %{_bindir}/my_print_defaults
 %attr(755,root,root) %{_bindir}/replace
 %attr(755,root,root) %{_bindir}/resolveip
-%{_mandir}/man1/mysql_fix_privilege_tables.1*
 %{_mandir}/man1/perror.1*
 %{_mandir}/man1/replace.1*
 
@@ -561,6 +733,7 @@ fi
 
 %files libs
 %defattr(644,root,root,755)
+%doc EXCEPTIONS-CLIENT
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
 
 %files devel
@@ -584,3 +757,25 @@ fi
 %files doc
 %defattr(644,root,root,755)
 %doc Docs/manual.html Docs/manual_toc.html
+
+%files ndb
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_sbindir}/ndbd
+%attr(754,root,root) /etc/rc.d/init.d/mysql-ndb
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mysql-ndb
+
+%files ndb-client
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/ndb_*
+
+%files ndb-mgm
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_sbindir}/ndb_mgmd
+%attr(754,root,root) /etc/rc.d/init.d/mysql-ndb-mgm
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mysql-ndb-mgm
+
+%files ndb-cpc
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_sbindir}/ndb_cpcd
+%attr(754,root,root) /etc/rc.d/init.d/mysql-ndb-cpc
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mysql-ndb-cpc
This page took 0.042826 seconds and 4 git commands to generate.