]> git.pld-linux.org Git - packages/kBuild.git/blobdiff - kBuild.spec
update to rev 2814
[packages/kBuild.git] / kBuild.spec
index 9beb3fb49db88290b9664718c4b1410418821c68..0be1669d4c843caa7eed1b74c4c219b00dcf1cae 100644 (file)
@@ -1,34 +1,40 @@
 #
 # Conditional build:
-%bcond_with    bootstrap               # build boostrap
+%bcond_with    bootstrap       # build boostrap
+%bcond_without verbose         # disable verbose build
 
-%define                svnrev 2577
+%define                ver     0.1.9998
+%define                svnrev  2814
 Summary:       A cross-platform build environment
+Summary(pl.UTF-8):     Wieloplatformowe środowisko budowania
 Name:          kBuild
-Version:       0.1.9998
+Version:       %{ver}.%{svnrev}
 Release:       1
 Group:         Development/Tools
 # Most tools are from NetBSD, some are from FreeBSD, and make and sed are from GNU
 License:       BSD and GPL v2+
-URL:           http://svn.netlabs.org/kbuild
 Source0:       %{name}-r%{svnrev}.tar.bz2
-# Source0-md5: d2ae623626f1e464333c384a2465a77a
+# Source0-md5: ff69b9b96c548bb87eae37936246bce2
 Source1:       get-source.sh
 Patch0:                %{name}-0.1.3-escape.patch
-Patch1:                %{name}-0.1.5-dprintf.patch
-Patch2:                %{name}-0.1.5-pthread.patch
+Patch1:                %{name}-0.1.5-pthread.patch
+Patch2:                x32.patch
+Patch3:                %{name}-bison.patch
+URL:           http://svn.netlabs.org/kbuild
 BuildRequires: acl-devel
-BuildRequires: autoconf
-BuildRequires: automake
-BuildRequires: byacc
-BuildRequires: cvs
+BuildRequires: bison
 BuildRequires: flex
-BuildRequires: gettext-devel
-%{!?with_bootstrap:BuildRequires:      kBuild}
-ExclusiveArch: %{x8664} %{ix86}
+%if %{with bootstrap}
+BuildRequires: autoconf >= 2.59
+BuildRequires: automake >= 1:1.9
+BuildRequires: gettext-tools >= 0.14
+BuildRequires: texinfo >= 4.0
+%else
+BuildRequires: kBuild
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%ifarch %{x8664}
+%ifarch %{x8664} x32
 %define                kbuild_arch     amd64
 %else
 %define                kbuild_arch     x86
@@ -40,7 +46,7 @@ tasks and portable versions of various UNIX tools to ensure
 cross-platform portability.
 
 The goals of the kBuild framework:
- - Similar behavior across all supported platforms
+- Similar behavior across all supported platforms
 - Flexibility, don't create unnecessary restrictions preventing ad-hoc
   solutions
 - Makefiles can be simple to write and maintain
@@ -50,11 +56,29 @@ The goals of the kBuild framework:
 - Tools and SDKs for helping out the templates with flexibility
 - Non-recursive makefile method by using sub-makefiles
 
+%description -l pl.UTF-8
+Ten pakiet to odgałęzienie GNU make'a wraz z zestawem skryptów
+upraszczających złożone zadania oraz przenośnych wersji różnych 
+narzędzi uniksowych w celu zapewnienia przenośności na wiele platform.
+
+Cele środowiska kBuild to:
+- podobne zachowanie na wszystkich obsługiwanych platformach
+- elastyczność, unikanie niepotrzebnych ograniczeń blokujących
+  rozwiązania doraźne
+- proste do napisania i utrzymania pliki Makefile
+- automatyczne dołączanie jednego pliku konfiguracyjnego na poddrzewo
+- szablony konfiguracji docelowej jako główny mechanizm upraszczający
+  pliki Makefile
+- narzędzia i SDK wspomagające szablony elastycznością
+- nierekurencyjny system wykorzystujący podpliki Makefile
+
 %prep
-%setup -q -n %{name}
+%setup -qc
+mv %{name} .tmp; mv .tmp/* .
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 cat > SvnInfo.kmk << EOF
 KBUILD_SVN_REV := %{svnrev}
@@ -63,47 +87,52 @@ EOF
 
 %{__sed} -i -e 's@_LDFLAGS\.%{kbuild_arch}*.*=@& %{rpmldflags}@g' Config.kmk
 
+%ifarch x32
+# probably should add full x32 configuration
+# but can't find place to submit code upstream, so this will do for now.
+# but then again, forcing -m64 is bad and pointless
+sed -i -e 's/-m64//' kBuild/tools/GCC64.kmk kBuild/tools/GXX64.kmk tests/Config.kmk Config.kmk
+%endif
+
 %build
-%define bootstrap_mflags %{?_smp_mflags} \\\
-               CC="%{__cc}" \\\
-               TOOL_GCC3_CC="%{__cc}" \\\
-               CFLAGS="%{rpmcflags}"                   \\\
-               KBUILD_VERBOSE=2                                \\\
-               KBUILD_VERSION_PATCH=999
-
-%define mflags %{bootstrap_mflags}      \\\
-               NIX_INSTALL_DIR=%{_prefix}        \\\
-               BUILD_TYPE=release                        \\\
-               MY_INST_MODE=0644                          \\\
+%define bootstrap_mflags %{?_smp_mflags} %{?with_verbose:KBUILD_VERBOSE=2} \\\
+               CC="%{__cc}" TOOL_GCC3_CC="%{__cc}" CFLAGS="%{rpmcflags}"
+
+%define mflags %{bootstrap_mflags} \\\
+               NIX_INSTALL_DIR=%{_prefix} \\\
+               BUILD_TYPE=release \\\
+               MY_INST_MODE=0644 \\\
                MY_INST_BIN_MODE=0755
 
 ver=$(awk '/^KBUILD_VERSION =/{print $3}' Config.kmk)
-test "$ver" = %{version}
+test "$ver" = %{ver}
 
+%if %{with bootstrap}
 cd src/kmk
-%{__libtoolize}
 %{__aclocal} -I config
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 cd ../sed
-%{__libtoolize}
+%{__gettextize}
 %{__aclocal} -I config
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 cd ../..
 
-%if %{with bootstrap}
 kBuild/env.sh --full \
-       %{__make} -f bootstrap.gmk %{bootstrap_mflags}
+       %{__make} -f bootstrap.gmk %{bootstrap_mflags} \
+               AUTORECONF=:
+
+kBuild/env.sh kmk clean
 %endif
 
-kBuild/env.sh kmk %{mflags} rebuild
+kBuild/env.sh kmk %{mflags} all \
+       PATH_INS=$RPM_BUILD_ROOT
 
 %install
 rm -rf $RPM_BUILD_ROOT
-export KBUILD_VERBOSE=2
 kBuild/env.sh kmk %{mflags} install \
        PATH_INS=$RPM_BUILD_ROOT
 
This page took 0.037482 seconds and 4 git commands to generate.