]> git.pld-linux.org Git - packages/kBuild.git/blobdiff - kBuild.spec
update to rev 2814
[packages/kBuild.git] / kBuild.spec
index 785df073f8ad1e8a4dab67be1b4cba4092e4bd56..0be1669d4c843caa7eed1b74c4c219b00dcf1cae 100644 (file)
@@ -1,40 +1,40 @@
 #
 # Conditional build:
-%bcond_with    bootstrap               # build boostrap
+%bcond_with    bootstrap       # build boostrap
 %bcond_without verbose         # disable verbose build
 
 %define                ver     0.1.9998
-%define                svnrev  2700
+%define                svnrev  2814
 Summary:       A cross-platform build environment
+Summary(pl.UTF-8):     Wieloplatformowe środowisko budowania
 Name:          kBuild
 Version:       %{ver}.%{svnrev}
-Release:       2
+Release:       1
 Group:         Development/Tools
 # Most tools are from NetBSD, some are from FreeBSD, and make and sed are from GNU
 License:       BSD and GPL v2+
-URL:           http://svn.netlabs.org/kbuild
 Source0:       %{name}-r%{svnrev}.tar.bz2
-# Source0-md5: 7c394fbe248f903d0bc1aabd235dc0a9
+# Source0-md5: ff69b9b96c548bb87eae37936246bce2
 Source1:       get-source.sh
 Patch0:                %{name}-0.1.3-escape.patch
-Patch1:                %{name}-0.1.5-dprintf.patch
-Patch2:                %{name}-0.1.5-pthread.patch
-Patch3:                re_string_fetch_byte_case-not-pure-attribute.patch
+Patch1:                %{name}-0.1.5-pthread.patch
+Patch2:                x32.patch
+Patch3:                %{name}-bison.patch
+URL:           http://svn.netlabs.org/kbuild
 BuildRequires: acl-devel
-BuildRequires: byacc
+BuildRequires: bison
 BuildRequires: flex
 %if %{with bootstrap}
-BuildRequires: autoconf
-BuildRequires: automake
-BuildRequires: gettext-autopoint
-BuildRequires: libtool
-BuildRequires: texinfo
+BuildRequires: autoconf >= 2.59
+BuildRequires: automake >= 1:1.9
+BuildRequires: gettext-tools >= 0.14
+BuildRequires: texinfo >= 4.0
 %else
 BuildRequires: kBuild
 %endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%ifarch %{x8664}
+%ifarch %{x8664} x32
 %define                kbuild_arch     amd64
 %else
 %define                kbuild_arch     x86
@@ -56,6 +56,22 @@ The goals of the kBuild framework:
 - Tools and SDKs for helping out the templates with flexibility
 - Non-recursive makefile method by using sub-makefiles
 
+%description -l pl.UTF-8
+Ten pakiet to odgałęzienie GNU make'a wraz z zestawem skryptów
+upraszczających złożone zadania oraz przenośnych wersji różnych 
+narzędzi uniksowych w celu zapewnienia przenośności na wiele platform.
+
+Cele środowiska kBuild to:
+- podobne zachowanie na wszystkich obsługiwanych platformach
+- elastyczność, unikanie niepotrzebnych ograniczeń blokujących
+  rozwiązania doraźne
+- proste do napisania i utrzymania pliki Makefile
+- automatyczne dołączanie jednego pliku konfiguracyjnego na poddrzewo
+- szablony konfiguracji docelowej jako główny mechanizm upraszczający
+  pliki Makefile
+- narzędzia i SDK wspomagające szablony elastycznością
+- nierekurencyjny system wykorzystujący podpliki Makefile
+
 %prep
 %setup -qc
 mv %{name} .tmp; mv .tmp/* .
@@ -71,6 +87,13 @@ EOF
 
 %{__sed} -i -e 's@_LDFLAGS\.%{kbuild_arch}*.*=@& %{rpmldflags}@g' Config.kmk
 
+%ifarch x32
+# probably should add full x32 configuration
+# but can't find place to submit code upstream, so this will do for now.
+# but then again, forcing -m64 is bad and pointless
+sed -i -e 's/-m64//' kBuild/tools/GCC64.kmk kBuild/tools/GXX64.kmk tests/Config.kmk Config.kmk
+%endif
+
 %build
 %define bootstrap_mflags %{?_smp_mflags} %{?with_verbose:KBUILD_VERBOSE=2} \\\
                CC="%{__cc}" TOOL_GCC3_CC="%{__cc}" CFLAGS="%{rpmcflags}"
@@ -86,13 +109,12 @@ test "$ver" = %{ver}
 
 %if %{with bootstrap}
 cd src/kmk
-%{__libtoolize}
 %{__aclocal} -I config
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 cd ../sed
-%{__libtoolize}
+%{__gettextize}
 %{__aclocal} -I config
 %{__autoconf}
 %{__autoheader}
@@ -100,7 +122,8 @@ cd ../sed
 cd ../..
 
 kBuild/env.sh --full \
-       %{__make} -f bootstrap.gmk %{bootstrap_mflags}
+       %{__make} -f bootstrap.gmk %{bootstrap_mflags} \
+               AUTORECONF=:
 
 kBuild/env.sh kmk clean
 %endif
This page took 0.066153 seconds and 4 git commands to generate.