]> git.pld-linux.org Git - packages/xqilla.git/blob - xqilla.spec
noarch apidocs
[packages/xqilla.git] / xqilla.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4
5 Summary:        XQilla - C++ implementation of XQuery and XPath 2.0 based on Xerces-C
6 Summary(pl.UTF-8):      XQilla - implementacja C++ XQuary i XPath 2.0 oparta na bibliotece Xerces-C
7 Name:           xqilla
8 Version:        2.3.0
9 Release:        5
10 License:        Apache v2.0
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/xqilla/XQilla-%{version}.tar.gz
13 # Source0-md5:  7261c7b4bb5a45cbf6270073976a51ce
14 Patch0:         %{name}-link.patch
15 URL:            http://xqilla.sourceforge.net/
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake
18 BuildRequires:  faxpp-devel
19 BuildRequires:  flex
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool
22 BuildRequires:  tidy-devel
23 BuildRequires:  xerces-c-devel >= 3
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 XQilla - C++ implementation of XQuery and XPath 2.0 based on Xerces-C.
28
29 %description -l pl.UTF-8
30 XQilla - implementacja C++ XQuary i XPath 2.0 oparta na bibliotece
31 Xerces-C.
32
33 %package devel
34 Summary:        Header files for XQilla library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki XQilla
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       faxpp-devel
39 Requires:       libstdc++-devel
40 Requires:       tidy-devel
41 Requires:       xerces-c-devel >= 3
42
43 %description devel
44 Header files for XQilla library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki XQilla.
48
49 %package static
50 Summary:        Static XQilla library
51 Summary(pl.UTF-8):      Statyczna biblioteka XQilla
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static XQilla library.
57
58 %description static -l pl.UTF-8
59 Statyczna biblioteka XQilla.
60
61 %package apidocs
62 Summary:        XQilla API documentation
63 Summary(pl.UTF-8):      Dokumentacja API biblioteki XQilla
64 Group:          Documentation
65 %if "%{_rpmversion}" >= "5"
66 BuildArch:      noarch
67 %endif
68
69 %description apidocs
70 API and internal documentation for XQilla library.
71
72 %description apidocs -l pl.UTF-8
73 Dokumentacja API biblioteki XQilla.
74
75 %prep
76 %setup -q -n XQilla-%{version}
77 %patch0 -p1
78
79 %build
80 %{__libtoolize}
81 %{__aclocal}
82 %{__autoconf}
83 %{__autoheader}
84 %{__automake}
85 %configure \
86         --with-faxpp=/usr \
87         --with-xerces=/usr
88
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc README TODO
105 %attr(755,root,root) %{_bindir}/xqilla
106 %attr(755,root,root) %{_libdir}/libxqilla.so.*.*.*
107 %attr(755,root,root) %ghost %{_libdir}/libxqilla.so.6
108
109 %files devel
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_libdir}/libxqilla.so
112 %{_libdir}/libxqilla.la
113 %{_includedir}/xqilla
114 %{_includedir}/xqc.h
115
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/libxqilla.a
119
120 %if %{with apidocs}
121 %files apidocs
122 %defattr(644,root,root,755)
123 %doc docs/{dom3-api,simple-api,xqc-api,*.html}
124 %endif
This page took 0.052752 seconds and 3 git commands to generate.