]> git.pld-linux.org Git - packages/xqilla.git/blob - xqilla.spec
- added gcc11 patch (fix for gcc 11+); release 3
[packages/xqilla.git] / xqilla.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4
5 Summary:        XQilla - C++ implementation of XQuery and XPath 2.0 based on Xerces-C
6 Summary(pl.UTF-8):      XQilla - implementacja C++ XQuary i XPath 2.0 oparta na bibliotece Xerces-C
7 Name:           xqilla
8 Version:        2.3.4
9 Release:        3
10 License:        Apache v2.0
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/xqilla/XQilla-%{version}.tar.gz
13 # Source0-md5:  9b77644c8b0d0741d895d3ccfbfe0016
14 Patch0:         %{name}-link.patch
15 Patch1:         %{name}-soname.patch
16 Patch2:         %{name}-gcc11.patch
17 URL:            http://xqilla.sourceforge.net/
18 BuildRequires:  autoconf >= 2.59
19 BuildRequires:  automake
20 BuildRequires:  faxpp-devel
21 BuildRequires:  flex
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtool >= 2:1.5
24 BuildRequires:  rpm-build >= 4.6
25 BuildRequires:  rpmbuild(macros) >= 1.752
26 BuildRequires:  tidy-devel
27 BuildRequires:  xerces-c-devel >= 3
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 XQilla - C++ implementation of XQuery and XPath 2.0 based on Xerces-C.
32
33 %description -l pl.UTF-8
34 XQilla - implementacja C++ XQuary i XPath 2.0 oparta na bibliotece
35 Xerces-C.
36
37 %package devel
38 Summary:        Header files for XQilla library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki XQilla
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       faxpp-devel
43 Requires:       libstdc++-devel
44 Requires:       tidy-devel
45 Requires:       xerces-c-devel >= 3
46
47 %description devel
48 Header files for XQilla library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki XQilla.
52
53 %package static
54 Summary:        Static XQilla library
55 Summary(pl.UTF-8):      Statyczna biblioteka XQilla
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static XQilla library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka XQilla.
64
65 %package apidocs
66 Summary:        XQilla API documentation
67 Summary(pl.UTF-8):      Dokumentacja API biblioteki XQilla
68 Group:          Documentation
69 BuildArch:      noarch
70
71 %description apidocs
72 API and internal documentation for XQilla library.
73
74 %description apidocs -l pl.UTF-8
75 Dokumentacja API biblioteki XQilla.
76
77 %prep
78 %setup -q -n XQilla-%{version}
79 %patch0 -p1
80 %patch1 -p1
81 %patch2 -p1
82
83 %build
84 %{__libtoolize}
85 %{__aclocal} -I autotools/m4
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         --with-faxpp=/usr \
91         --with-xerces=/usr
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc README TODO
110 %attr(755,root,root) %{_bindir}/xqilla
111 %attr(755,root,root) %{_libdir}/libxqilla.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libxqilla.so.6
113
114 %files devel
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_libdir}/libxqilla.so
117 %{_libdir}/libxqilla.la
118 %{_includedir}/xqilla
119 %{_includedir}/xqc.h
120
121 %files static
122 %defattr(644,root,root,755)
123 %{_libdir}/libxqilla.a
124
125 %if %{with apidocs}
126 %files apidocs
127 %defattr(644,root,root,755)
128 %doc docs/{dom3-api,simple-api,xqc-api,*.html}
129 %endif
This page took 0.077908 seconds and 4 git commands to generate.