]> git.pld-linux.org Git - packages/wget.git/blob - wget.spec
fix for double free in free_vec
[packages/wget.git] / wget.spec
1 # TODO
2 # - add --delete-remote patches:
3 #  - http://wget-bugs.ferrara.linux.it/issue9
4 #  - or http://osdir.com/ml/web.wget.patches/2005-09/msg00006.html
5 # - add http://article.gmane.org/gmane.comp.web.wget.patches/2333
6 #
7 # Conditional build:
8 %bcond_without  tests
9 %bcond_with     gnutls  # use GnuTLS (wget default) instead of OpenSSL
10 #
11 Summary:        A utility for retrieving files using the HTTP or FTP protocols
12 Summary(es.UTF-8):      Cliente en línea de comando para bajar archivos WWW/FTP con recursión opcional
13 Summary(fr.UTF-8):      Un utilitaire pour recuperer des fichiers en utilisant les protocoles HTTP ou FTP
14 Summary(pl.UTF-8):      Wsadowy klient HTTP/FTP
15 Summary(pt_BR.UTF-8):   Cliente na linha de comando para baixar arquivos WWW/FTP com recursão opcional
16 Summary(ru.UTF-8):      Утилита для получения файлов по протоколам HTTP и FTP
17 Summary(uk.UTF-8):      Утиліта для отримання файлів по протоколам HTTP та FTP
18 Summary(zh_CN.UTF-8):   [通讯]功能强大的下载程序,支持断点续传
19 Name:           wget
20 Version:        1.16.3
21 Release:        3
22 License:        GPL v3+ with OpenSSL exception
23 Group:          Networking/Utilities
24 Source0:        http://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.xz
25 # Source0-md5:  d2e4455781a70140ae83b54ca594ce21
26 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
27 # Source1-md5:  d8b2b56ec7461606c22edbafaf8a418f
28 Patch0:         %{name}-info.patch
29 Patch1:         %{name}-wgetrc_path.patch
30 Patch2:         %{name}-home_etc.patch
31 Patch3:         %{name}-ssl-certs.patch
32 Patch4:         user.xdg.origin.url.patch
33 Patch5:         %{name}-free.patch
34 URL:            http://www.gnu.org/software/wget/
35 BuildRequires:  attr-devel
36 BuildRequires:  autoconf >= 2.61
37 BuildRequires:  automake >= 1:1.9
38 BuildRequires:  gettext-tools >= 0.17
39 %{?with_gnutls:BuildRequires:   gnutls-devel}
40 BuildRequires:  libidn-devel
41 BuildRequires:  libpsl-devel
42 BuildRequires:  libuuid-devel
43 %{!?with_gnutls:BuildRequires:  openssl-devel >= 0.9.7m}
44 BuildRequires:  pcre-devel
45 BuildRequires:  perl-devel
46 BuildRequires:  tar >= 1:1.22
47 BuildRequires:  texinfo
48 BuildRequires:  xz
49 BuildRequires:  zlib-devel
50 %if %{with tests}
51 BuildRequires:  perl-HTTP-Daemon
52 BuildRequires:  perl-HTTP-Message
53 BuildRequires:  perl-IO-Socket-SSL
54 BuildRequires:  python3-modules >= 1:3.0
55 %endif
56 Provides:       webclient
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define         _noautoreqfiles         %{_bindir}/rmold
60
61 %description
62 GNU Wget is a file retrieval utility which can use either the HTTP or
63 FTP protocols. Wget features include the ability to work in the
64 background while you're logged out, recursive retrieval of
65 directories, file name wildcard matching, remote file timestamp
66 storage and comparison, use of Rest with FTP servers and Range with
67 HTTP servers to retrieve files over slow or unstable connections,
68 support for Proxy servers, and configurability.
69
70 %description -l es.UTF-8
71 GNU wget es una herramienta de red para bajar archivos usando HTTP y
72 FTP. Funciona en modo no interactivo, pudiendo trabajar en background.
73 Funciona muy bien, incluso en conexiones lentas o inestables, bajando
74 el archivo hasta que sea completamente recibido.
75
76 %description -l fr.UTF-8
77 GNU Wget est un utilitaire pour récupérer des fichiers qui peut
78 utiliser indifféremment les protocoles HTTP ou FTP. Parmi les
79 caractéristiques de Wget, citons la capacité à récupérer des fichiers
80 en arrière-plan alors que vous n'êtes pas connecté, la récupération
81 récursive de répertoires, la capacité de récupérer des fichiers en
82 appliquant un filtre sur le nom ou sur la date, la gestion de Rest
83 avec les serveurs FTP et de Range avec les serveurs HTTP pour
84 récupérer des fichiers avec une connexion lente ou instable, le
85 support des serveurs Proxy... Wget est particulièrement configurable.
86
87 %description -l ja.UTF-8
88 GNU wget は HTTP か FTP プロトコルのどちらかを使用することができる
89 ファイルを取得するユーティリティです。wget はログアウトしている
90 間にバックグラウンドで働く特徴をもっていること、ディレクトリの再帰的
91 取得、ファイルネームのワイルドカードマッチング、ファイルのタイムスタンプの
92 保存と比較、遅く不安定な接続で FTP サーバの Rest と HTTP サーバの
93 Range の使用、プロキシーサーバのサポートと設定の容易さを含んだ特徴を
94 もっています。
95
96 %description -l pl.UTF-8
97 Wget jest klientem FTP/HTTP przeznaczonym do ściągania zasobów
98 wsadowo. Umożliwia ściąganie zasobów z podkatalogami, a także ma opcje
99 umożliwiające wykonanie lokalnej kopii zasobów (mirror). W razie
100 niemożności dostania się do zasobów lub gdy połączenie z serwerem
101 FTP/HTTP zostanie zerwane, może automatycznie ponawiać próby
102 kopiowania. Jest także dobrze przystosowany do tego, żeby uruchamiać
103 go jako zadanie z crona.
104
105 %description -l pt_BR.UTF-8
106 O GNU wget é uma ferramenta de rede para baixar arquivos usando HTTP e
107 FTP. Ele funciona em modo não interativo, podendo trabalhar em
108 background. Funciona muito bem, mesmo em conexões lentas ou instáveis,
109 baixando o arquivo até que ele seja completamente recebido.
110
111 %description -l ru.UTF-8
112 GNU Wget - это утилита командной строки для получения файлов по
113 протоколам FTP и HTTP. Среди возможностей Wget - работа в фоновом
114 режиме когда вы выходите из системы, рекурсивное извлечение каталогов,
115 выбор файлов по шаблону, сравнение времени удаленных и локальных
116 файлов, сохранение времени удаленных файлов при загрузке,
117 использование REST с FTP серверами и Range с HTTP серверами для
118 загрузки файлов по медленным или нестабильным каналам, поддержка Proxy
119 серверов, конфигурируемость.
120
121 %description -l uk.UTF-8
122 GNU Wget - це утиліта командного рядка для отримання файлів по
123 протоколам FTP та HTTP. Серед можливостей Wget - робота в фоновому
124 режимі коли ви виходите із системи, рекурсивне отримання каталогів,
125 вибір файлів по шаблону, порівняння часу віддалених та локальних
126 файлів, збереження часу віддалених файлів при завантаженні,
127 використання REST з FTP серверами та Range з HTTP серверами для
128 завантаження файлів по повільним чи нестабільним каналам, підтримка
129 Proxy серверів, настроюваність.
130
131 %prep
132 %setup -q
133 %patch0 -p1
134 %patch1 -p1
135 %patch2 -p1
136 %patch3 -p1
137 %patch4 -p1
138 %patch5 -p1
139
140 %{__rm} doc/wget.info doc/sample.wgetrc.munged_for_texi_inclusion po/stamp-po
141
142 # temp hack for 1.13.4
143 test -e build-aux/bzr-version-gen || cat <<EOF > build-aux/bzr-version-gen
144 #!/bin/sh
145 echo -n %{version}
146 EOF
147 chmod +x build-aux/bzr-version-gen
148
149 %build
150 %{__gettextize}
151 %{__aclocal} -I m4
152 %{__autoheader}
153 %{__autoconf}
154 %{__automake}
155 %configure \
156         --with-ssl%{!?with_gnutls:=openssl}
157 %{__make}
158 tail -n 6 util/README >rmold.README
159
160 # 1.13.4 tarball was buggy and produced empty version.
161 grep %{version} src/version.c
162
163 %{?with_tests:%{__make} check}
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167 install -d $RPM_BUILD_ROOT%{_sysconfdir}
168
169 %{__make} install \
170         DESTDIR=$RPM_BUILD_ROOT \
171         GETTEXT_PACKAGE=wget
172
173 install -p util/rmold.pl $RPM_BUILD_ROOT%{_bindir}/rmold
174 cp -a doc/sample.wgetrc $RPM_BUILD_ROOT%{_sysconfdir}/wgetrc
175
176 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
177 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README*
178 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
179
180 %find_lang %{name}
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %post   -p /sbin/postshell
186 -/usr/sbin/fix-info-dir -c %{_infodir}
187
188 %postun -p /sbin/postshell
189 -/usr/sbin/fix-info-dir -c %{_infodir}
190
191 %files -f %{name}.lang
192 %defattr(644,root,root,755)
193 %doc AUTHORS ChangeLog NEWS README MAILING-LIST rmold.README
194 %verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/%{name}rc
195 %attr(755,root,root) %{_bindir}/rmold
196 %attr(755,root,root) %{_bindir}/wget
197 %{_mandir}/man1/wget.1*
198 %{_mandir}/hu/man1/wget.1*
199 %{_mandir}/pl/man1/wget.1*
200 %{_infodir}/wget.info*
This page took 0.058299 seconds and 4 git commands to generate.