]> git.pld-linux.org Git - packages/wget.git/blob - wget.spec
up to 1.21.4
[packages/wget.git] / wget.spec
1 # TODO
2 # - add --delete-remote patches:
3 #  - http://wget-bugs.ferrara.linux.it/issue9
4 #  - or http://osdir.com/ml/web.wget.patches/2005-09/msg00006.html
5 # - add http://article.gmane.org/gmane.comp.web.wget.patches/2333
6 #
7 # Conditional build:
8 %bcond_without  tests   # check target
9 %bcond_without  metalink # build without metalink support
10 %bcond_with     gnutls  # use GnuTLS (wget default) instead of OpenSSL
11
12 Summary:        A utility for retrieving files using the HTTP or FTP protocols
13 Summary(es.UTF-8):      Cliente en línea de comando para bajar archivos WWW/FTP con recursión opcional
14 Summary(fr.UTF-8):      Un utilitaire pour recuperer des fichiers en utilisant les protocoles HTTP ou FTP
15 Summary(pl.UTF-8):      Wsadowy klient HTTP/FTP
16 Summary(pt_BR.UTF-8):   Cliente na linha de comando para baixar arquivos WWW/FTP com recursão opcional
17 Summary(ru.UTF-8):      Утилита для получения файлов по протоколам HTTP и FTP
18 Summary(uk.UTF-8):      Утиліта для отримання файлів по протоколам HTTP та FTP
19 Summary(zh_CN.UTF-8):   [通讯]功能强大的下载程序,支持断点续传
20 Name:           wget
21 Version:        1.21.4
22 Release:        1
23 License:        GPL v3+ with OpenSSL exception
24 Group:          Networking/Utilities
25 Source0:        http://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.lz
26 # Source0-md5:  6d4ab603f1b905b6856a111c61078740
27 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
28 # Source1-md5:  d8b2b56ec7461606c22edbafaf8a418f
29 Patch0:         %{name}-info.patch
30 Patch1:         %{name}-wgetrc_path.patch
31 Patch2:         %{name}-home_etc.patch
32 Patch3:         %{name}-ssl-certs.patch
33 Patch4:         user.xdg.origin.url.patch
34 URL:            http://www.gnu.org/software/wget/
35 BuildRequires:  autoconf >= 2.64
36 BuildRequires:  autoconf-archive
37 BuildRequires:  automake >= 1:1.9
38 BuildRequires:  gettext-tools >= 0.21
39 # >= 3.6.3 for TLSv1.3
40 %{?with_gnutls:BuildRequires:   gnutls-devel >= 3.0.16}
41 %{?with_metalink:BuildRequires: gpgme-devel >= 0.4.2}
42 BuildRequires:  libidn2-devel >= 0.14.0
43 %{?with_metalink:BuildRequires: libmetalink-devel}
44 BuildRequires:  libpsl-devel >= 0.16.0
45 BuildRequires:  libuuid-devel
46 BuildRequires:  lzip
47 # >= 1.1.0 for TLSv1.3
48 %{!?with_gnutls:BuildRequires:  openssl-devel >= 1.0.1}
49 BuildRequires:  pcre2-8-devel
50 BuildRequires:  perl-devel
51 BuildRequires:  pkgconfig
52 BuildRequires:  tar >= 1:1.22
53 BuildRequires:  texinfo
54 BuildRequires:  zlib-devel
55 %if %{with tests}
56 BuildRequires:  perl-HTTP-Daemon
57 BuildRequires:  perl-HTTP-Message
58 BuildRequires:  perl-IO-Socket-SSL
59 BuildRequires:  python3-modules >= 1:3.0
60 %endif
61 Provides:       webclient
62 %{?with_gnutls:Requires:        gnutls-libs >= 3.0.16}
63 %{!?with_gnutls:Requires:       openssl >= 1.0.1}
64 Requires:       libidn2 >= 0.14.0
65 Requires:       libpsl >= 0.16.0
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %define         _noautoreqfiles         %{_bindir}/rmold
69
70 %description
71 GNU Wget is a file retrieval utility which can use either the HTTP or
72 FTP protocols. Wget features include the ability to work in the
73 background while you're logged out, recursive retrieval of
74 directories, file name wildcard matching, remote file timestamp
75 storage and comparison, use of Rest with FTP servers and Range with
76 HTTP servers to retrieve files over slow or unstable connections,
77 support for Proxy servers, and configurability.
78
79 %description -l es.UTF-8
80 GNU wget es una herramienta de red para bajar archivos usando HTTP y
81 FTP. Funciona en modo no interactivo, pudiendo trabajar en background.
82 Funciona muy bien, incluso en conexiones lentas o inestables, bajando
83 el archivo hasta que sea completamente recibido.
84
85 %description -l fr.UTF-8
86 GNU Wget est un utilitaire pour récupérer des fichiers qui peut
87 utiliser indifféremment les protocoles HTTP ou FTP. Parmi les
88 caractéristiques de Wget, citons la capacité à récupérer des fichiers
89 en arrière-plan alors que vous n'êtes pas connecté, la récupération
90 récursive de répertoires, la capacité de récupérer des fichiers en
91 appliquant un filtre sur le nom ou sur la date, la gestion de Rest
92 avec les serveurs FTP et de Range avec les serveurs HTTP pour
93 récupérer des fichiers avec une connexion lente ou instable, le
94 support des serveurs Proxy... Wget est particulièrement configurable.
95
96 %description -l ja.UTF-8
97 GNU wget は HTTP か FTP プロトコルのどちらかを使用することができる
98 ファイルを取得するユーティリティです。wget はログアウトしている
99 間にバックグラウンドで働く特徴をもっていること、ディレクトリの再帰的
100 取得、ファイルネームのワイルドカードマッチング、ファイルのタイムスタンプの
101 保存と比較、遅く不安定な接続で FTP サーバの Rest と HTTP サーバの
102 Range の使用、プロキシーサーバのサポートと設定の容易さを含んだ特徴を
103 もっています。
104
105 %description -l pl.UTF-8
106 Wget jest klientem FTP/HTTP przeznaczonym do ściągania zasobów
107 wsadowo. Umożliwia ściąganie zasobów z podkatalogami, a także ma opcje
108 umożliwiające wykonanie lokalnej kopii zasobów (mirror). W razie
109 niemożności dostania się do zasobów lub gdy połączenie z serwerem
110 FTP/HTTP zostanie zerwane, może automatycznie ponawiać próby
111 kopiowania. Jest także dobrze przystosowany do tego, żeby uruchamiać
112 go jako zadanie z crona.
113
114 %description -l pt_BR.UTF-8
115 O GNU wget é uma ferramenta de rede para baixar arquivos usando HTTP e
116 FTP. Ele funciona em modo não interativo, podendo trabalhar em
117 background. Funciona muito bem, mesmo em conexões lentas ou instáveis,
118 baixando o arquivo até que ele seja completamente recebido.
119
120 %description -l ru.UTF-8
121 GNU Wget - это утилита командной строки для получения файлов по
122 протоколам FTP и HTTP. Среди возможностей Wget - работа в фоновом
123 режиме когда вы выходите из системы, рекурсивное извлечение каталогов,
124 выбор файлов по шаблону, сравнение времени удаленных и локальных
125 файлов, сохранение времени удаленных файлов при загрузке,
126 использование REST с FTP серверами и Range с HTTP серверами для
127 загрузки файлов по медленным или нестабильным каналам, поддержка Proxy
128 серверов, конфигурируемость.
129
130 %description -l uk.UTF-8
131 GNU Wget - це утиліта командного рядка для отримання файлів по
132 протоколам FTP та HTTP. Серед можливостей Wget - робота в фоновому
133 режимі коли ви виходите із системи, рекурсивне отримання каталогів,
134 вибір файлів по шаблону, порівняння часу віддалених та локальних
135 файлів, збереження часу віддалених файлів при завантаженні,
136 використання REST з FTP серверами та Range з HTTP серверами для
137 завантаження файлів по повільним чи нестабільним каналам, підтримка
138 Proxy серверів, настроюваність.
139
140 %prep
141 %setup -q
142 %patch0 -p1
143 %patch1 -p1
144 %patch2 -p1
145 %patch3 -p1
146 %patch4 -p1
147
148 %{__rm} doc/wget.info doc/sample.wgetrc.munged_for_texi_inclusion po/stamp-po
149
150 # temp hack for 1.13.4
151 test -e build-aux/bzr-version-gen || cat <<EOF > build-aux/bzr-version-gen
152 #!/bin/sh
153 echo -n %{version}
154 EOF
155 chmod +x build-aux/bzr-version-gen
156
157 %{__sed} -i -e '1s,/usr/bin/env perl,%{__perl},' util/rmold.pl
158
159 %build
160 %{__gettextize}
161 %{__aclocal} -I m4
162 %{__autoheader}
163 %{__autoconf}
164 %{__automake}
165 %configure \
166         --enable-digest \
167         --enable-ipv6 \
168         --enable-iri \
169         --enable-largefile \
170         --enable-nls \
171         --enable-ntlm \
172         --enable-opie \
173         --enable-pcre \
174         --disable-silent-rules \
175         --disable-year2038 \
176         --with-libpsl \
177         %{__with_without metalink} \
178         --with-ssl%{!?with_gnutls:=openssl} \
179         --with-zlib \
180         %{nil}
181 %{__make}
182 tail -n 6 util/README >rmold.README
183
184 # 1.13.4 tarball was buggy and produced empty version.
185 grep %{version} src/version.c
186
187 %{?with_tests:%{__make} check}
188
189 %install
190 rm -rf $RPM_BUILD_ROOT
191 install -d $RPM_BUILD_ROOT%{_sysconfdir}
192
193 %{__make} install \
194         DESTDIR=$RPM_BUILD_ROOT \
195         GETTEXT_PACKAGE=wget
196
197 install -p util/rmold.pl $RPM_BUILD_ROOT%{_bindir}/rmold
198 cp -a doc/sample.wgetrc $RPM_BUILD_ROOT%{_sysconfdir}/wgetrc
199
200 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
201 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README*
202 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
203
204 # "wget" and "wget-gnulib" domains
205 %find_lang %{name} --all-name
206
207 %clean
208 rm -rf $RPM_BUILD_ROOT
209
210 %post   -p /sbin/postshell
211 -/usr/sbin/fix-info-dir -c %{_infodir}
212
213 %postun -p /sbin/postshell
214 -/usr/sbin/fix-info-dir -c %{_infodir}
215
216 %files -f %{name}.lang
217 %defattr(644,root,root,755)
218 %doc AUTHORS ChangeLog NEWS README MAILING-LIST rmold.README
219 %verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/wgetrc
220 %attr(755,root,root) %{_bindir}/rmold
221 %attr(755,root,root) %{_bindir}/wget
222 %{_mandir}/man1/wget.1*
223 %{_mandir}/hu/man1/wget.1*
224 %{_mandir}/pl/man1/wget.1*
225 %{_infodir}/wget.info*
This page took 0.069149 seconds and 3 git commands to generate.