]> git.pld-linux.org Git - packages/wavpack.git/blob - wavpack.spec
BR: gettext-tools for AM_ICONV
[packages/wavpack.git] / wavpack.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs
4
5 Summary:        Open audio compression codec
6 Summary(pl.UTF-8):      Otwarty kodek kompresji dźwięku
7 Name:           wavpack
8 Version:        5.6.0
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://www.wavpack.com/downloads.html
13 Source0:        https://www.wavpack.com/%{name}-%{version}.tar.xz
14 # Source0-md5:  cdcc70024f9687eb9757751d9f3d0e17
15 URL:            https://www.wavpack.com/
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake >= 1:1.15
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  docbook-style-xsl
20 BuildRequires:  gettext-tools
21 BuildRequires:  libtool >= 2:2
22 BuildRequires:  libxslt-progs
23 BuildRequires:  rpm-build >= 4.6
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 Requires:       %{name}-libs = %{version}-%{release}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 WavPack is a completely open audio compression format providing
31 lossless, high-quality lossy, and a unique hybrid compression mode.
32
33 Although the technology is loosely based on previous versions of
34 WavPack, the new version 4 format has been designed from the ground up
35 to offer unparalleled performance and functionality. In the default
36 lossless mode WavPack acts just like a WinZip compressor for audio
37 files. However, unlike MP3 or WMA encoding which can affect the sound
38 quality, not a single bit of the original information is lost, so
39 there's no chance of degradation. This makes lossless mode ideal for
40 archiving audio material or any other situation where quality is
41 paramount. The compression ratio depends on the source material, but
42 generally is between 30% and 70%.
43
44 The hybrid mode provides all the advantages of lossless compression
45 with an additional bonus. Instead of creating a single file, this mode
46 creates both a relatively small, high-quality lossy file that can be
47 used all by itself, and a "correction" file that (when combined with
48 the lossy file) provides full lossless restoration. For some users
49 this means never having to choose between lossless and lossy
50 compression!
51
52 %description -l pl.UTF-8
53 WavPack to całkowicie otwarty format kompresji dźwięku dostarczający
54 tryby kompresji: bezstratny, stratny wysokiej jakości oraz unikalny
55 hybrydowy.
56
57 Chociaż technologia jest luźno oparta na poprzednich wersjach
58 WavPacka, format nowej wersji 4 został zaprojektowany od nowa, aby
59 zaoferować niezrównaną wydajność i funkcjonalność. W domyślnym trybie
60 bezstratnym WavPack zachowuje się tak jak kompresor WinZip dla plików
61 dźwiękowych. Jednak w przeciwieństwie do kodowań MP3 czy WMA, które
62 wpływają na jakość dźwięku, żaden bit oryginalnej informacji nie jest
63 tracony, więc nie ma żadnych szans na degradację. Czyni to tryb
64 bezstratny idealnym do archiwizowania materiałów dźwiękowych oraz w
65 innych sytuacjach, gdzie jakość jest najważniejsza. Współczynnik
66 kompresji zależy od materiału źródłowego, ale zwykle jest pomiędzy
67 30% a 70%.
68
69 Tryb hybrydowy udostępnia wszystkie zalety kompresji bezstratnej z
70 dodatkowym ulepszeniem. Zamiast tworzenia pojedynczego pliku tryb ten
71 tworzy zarówno stosunkowo mały, wysokiej jakości plik stratny, który
72 może być używany jako taki oraz plik "poprawek", który (w połączeniu z
73 plikiem stratnym) odtwarza pełną jakość bez strat. Dla niektórych
74 użytkowników oznacza to, że nie muszą wybierać pomiędzy kompresją
75 bezstratną a stratną.
76
77 %package libs
78 Summary:        Wavpack library
79 Summary(pl.UTF-8):      Biblioteka Wavpack
80 Group:          Libraries
81 Requires:       %{name}-libs = %{version}-%{release}
82
83 %description libs
84 Wavpack library.
85
86 %description libs -l pl.UTF-8
87 Biblioteka Wavpack.
88
89 %package devel
90 Summary:        Header files for Wavpack
91 Summary(pl.UTF-8):      Pliki nagłówkowe Wavpack
92 Group:          Development/Libraries
93 Requires:       %{name}-libs = %{version}-%{release}
94
95 %description devel
96 Header files for Wavpack.
97
98 %description devel -l pl.UTF-8
99 Pliki nagłówkowe biblioteki Wavpack.
100
101 %package static
102 Summary:        Static Wavpack library
103 Summary(pl.UTF-8):      Statyczna biblioteka Wavpack
104 Group:          Development/Libraries
105 Requires:       %{name}-devel = %{version}-%{release}
106
107 %description static
108 Static Wavpack library.
109
110 %description static -l pl.UTF-8
111 Statyczna biblioteka Wavpack.
112
113 %package apidocs
114 Summary:        API documentation for Wavpack library
115 Summary(pl.UTF-8):      Dokumentacja API biblioteki Wavpack
116 Group:          Documentation
117 BuildArch:      noarch
118
119 %description apidocs
120 API documentation for Wavpack library.
121
122 %description apidocs -l pl.UTF-8
123 Dokumentacja API biblioteki Wavpack.
124
125 %prep
126 %setup -q
127
128 %build
129 %{__libtoolize}
130 %{__aclocal}
131 %{__autoconf}
132 %{__automake}
133 %configure \
134         --enable-legacy \
135         %{?with_static_libs:--enable-static}
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 # packaged as %doc
145 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wavpack
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   libs -p /sbin/ldconfig
151 %postun libs -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/wavpack
156 %attr(755,root,root) %{_bindir}/wvgain
157 %attr(755,root,root) %{_bindir}/wvtag
158 %attr(755,root,root) %{_bindir}/wvunpack
159 %{_mandir}/man1/wavpack.1*
160 %{_mandir}/man1/wvgain.1*
161 %{_mandir}/man1/wvtag.1*
162 %{_mandir}/man1/wvunpack.1*
163
164 %files libs
165 %defattr(644,root,root,755)
166 %doc AUTHORS COPYING ChangeLog README.md
167 %attr(755,root,root) %{_libdir}/libwavpack.so.*.*.*
168 %attr(755,root,root) %ghost %{_libdir}/libwavpack.so.1
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libwavpack.so
173 %{_libdir}/libwavpack.la
174 %{_includedir}/wavpack
175 %{_pkgconfigdir}/wavpack.pc
176
177 %if %{with static_libs}
178 %files static
179 %defattr(644,root,root,755)
180 %{_libdir}/libwavpack.a
181 %endif
182
183 %files apidocs
184 %defattr(644,root,root,755)
185 %doc doc/{WavPack*.pdf,wavpack_doc.html,style.css}
This page took 0.048455 seconds and 4 git commands to generate.