]> git.pld-linux.org Git - packages/quodlibet.git/blob - quodlibet.spec
- up to 0.13, added missing R: python-gstreamer, update banner
[packages/quodlibet.git] / quodlibet.spec
1 #
2 # TODO:
3 # - check what's up with gstreamer backend
4 #
5 # Conditional build:
6 %bcond_without  home_etc        # don't use home_etc
7 #
8 %define         date 20050731
9 #
10 Summary:        Quod Libet - GTK+-based audio player
11 Summary(pl):    Quod Libet - odtwarzacz d¼wiêku oparty na GTK+
12 Name:           quodlibet
13 Version:        0.13
14 Release:        0.1
15 License:        GPL v2
16 Group:          X11/Applications/Multimedia
17 Source0:        http://www.sacredchao.net/~piman/software/%{name}-%{version}.tar.gz
18 # Source0-md5:  24e81a7d41594372117e45053807b1fe
19 Patch1:         %{name}-home_etc.patch
20 URL:            http://www.sacredchao.net/quodlibet/wiki
21 BuildRequires:  python-devel
22 BuildRequires:  python-pygtk-devel
23 %pyrequires_eq  python-modules
24 Requires:       gtk+2 >= 2.6.0
25 Requires:       python-pygtk-gtk >= 2.6.0
26 Requires:       python-gstreamer
27 Requires:       GConf
28 Requires:       gstreamer-GConf
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Quod Libet is a GTK+-based audio player written in Python. It's
33 designed around the idea that you know better than we do how to
34 organize your music. It lets you make playlists based on regular
35 expressions (don't worry, regular searches work too). It lets you
36 display and edit any tags you want in the file. And it lets you do
37 this for all the file formats it supports -- Ogg Vorbis, FLAC, MP3,
38 Musepack, and MOD.
39
40 To use all of Quod Libet features (including audio playback) you will
41 also need the following packages: python-pyvorbis, python-pyao,
42 python-mad, python-pyid3lib.
43
44 %description -l pl
45 Quod Libet to oparty na GTK+ odtwarzacz d¼wiêku napisany w Pythonie.
46 Jest zaprojektowany w oparciu o ideê, ¿e sami wiemy lepiej, jak chcemy
47 organizowaæ swoj± muzykê. Odtwarzacz pozwala tworzyæ playlisty w
48 oparciu o wyra¿enia regularne (nie jest to powód do zmartwienia,
49 zwyk³e wyszukiwanie te¿ dzia³a). Pozwala wy¶wietlaæ i modyfikowaæ
50 dowolne znaczniki w pliku. Umo¿liwia to dla wszystkich obs³ugiwanych
51 formatów d¼wiêkowych: Ogg Vorbis, FLAC, MP3, Musepack i MOD.
52
53 Aby u¿ywaæ wszystkich mo¿liwo¶ci Quod Libet (w³±cznie z odtwarzaniem
54 d¼wiêku) potrzebne s± tak¿e nastêpuj±ce pakiety: python-pyvorbis,
55 python-pyao, python-mad, python-pyid3lib.
56
57 %prep
58 %setup -q
59 %{?with_home_etc:%patch1 -p1}
60
61 %build
62 %{__make} extensions
63 %{__make} po-data
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} install \
69         PREFIX=%{_prefix} \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %find_lang %{name}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post
78 %banner %{name} -e << EOF
79 Remember to install appropriate python modules for files
80 you want to play:
81 - python-mad and gstreamer-mad (for MP3s)
82 - python-pyvorbis and gstreamer-vorbis (for Ogg Vorbis)
83 and audio output:
84 - gstreamer-audiosink-(alsa|oss|esd) (for ALSA,OSS or ESD output)
85 EOF
86
87 %files -f %{name}.lang
88 %defattr(644,root,root,755)
89 %doc NEWS README
90 %attr(755,root,root) %{_bindir}/*
91 %dir %{_libdir}/%{name}
92 %attr(755,root,root) %{_libdir}/%{name}/*.py
93 %attr(755,root,root) %{_libdir}/%{name}/*.so
94 %{_libdir}/%{name}/*.png
95 %{_libdir}/%{name}/*.zip
96 %{_desktopdir}/*.desktop
97 %{_pixmapsdir}/*
98 %{_mandir}/man1/*
This page took 0.139349 seconds and 3 git commands to generate.