]> git.pld-linux.org Git - packages/quodlibet.git/blob - quodlibet.spec
rebuild with python 3.10
[packages/quodlibet.git] / quodlibet.spec
1 # TODO: /usr/share/gnome-shell/search-providers/quodlibet-search-provider.ini
2 #
3 %define         module          quodlibet
4 %define         egg_name        quodlibet
5 Summary:        Quod Libet - GTK+-based audio player
6 Summary(pl.UTF-8):      Quod Libet - odtwarzacz dźwięku oparty na GTK+
7 Name:           quodlibet
8 Version:        4.0.2
9 Release:        6
10 License:        GPL v2
11 Group:          X11/Applications/Multimedia
12 Source0:        https://github.com/quodlibet/quodlibet/releases/download/release-%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  f8f282e7cc43f2ec2148dd2e9d93808d
14 Patch0:         %{name}-nopy.patch
15 URL:            https://quodlibet.readthedocs.org
16 BuildRequires:  gettext-tools
17 BuildRequires:  intltool
18 BuildRequires:  python3-modules
19 BuildRequires:  python3-setuptools
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.719
22 Requires:       gdk-pixbuf2
23 Requires:       gobject-introspection
24 Requires:       gstreamer >= 1.0
25 #Requires:      gstreamer-GConf >= 1.0
26 Requires:       gstreamer-audio-effects-base >= 1.0
27 Requires:       gstreamer-plugins-base >= 1.0
28 Requires:       gtk+3
29 Requires:       pango
30 #Requires:      python-dbus
31 #Requires:      python-gstreamer >= 0.10.2-2
32 #Requires:      python-pygobject3
33 Requires:       python3-feedparser
34 Requires:       python3-mutagen >= 1.14
35 Suggests:       %{name}-plugins
36 Suggests:       gstreamer-audiosink
37 Suggests:       gstreamer-mad
38 Suggests:       gstreamer-musepack
39 Suggests:       gstreamer-vorbis
40 Suggests:       libgpod
41 Suggests:       libmodplug
42 #Suggests:      python-keybinder
43 Suggests:       udev-libs
44 Conflicts:      quodlibet-plugins < 2.9.82
45 BuildArch:      noarch
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Quod Libet is a GTK+-based audio player written in Python. It's
50 designed around the idea that you know better than we do how to
51 organize your music. It lets you make playlists based on regular
52 expressions (don't worry, regular searches work too). It lets you
53 display and edit any tags you want in the file. And it lets you do
54 this for all the file formats it supports -- Ogg Vorbis, FLAC, MP3,
55 Musepack, and MOD.
56
57 To use all of Quod Libet features (including audio playback) you will
58 also need the following packages: python-pyvorbis, python-pyao,
59 python-mad, python-pyid3lib.
60
61 %description -l pl.UTF-8
62 Quod Libet to oparty na GTK+ odtwarzacz dźwięku napisany w Pythonie.
63 Jest zaprojektowany w oparciu o ideę, że sami wiemy lepiej, jak chcemy
64 organizować swoją muzykę. Odtwarzacz pozwala tworzyć playlisty w
65 oparciu o wyrażenia regularne (nie jest to powód do zmartwienia,
66 zwykłe wyszukiwanie też działa). Pozwala wyświetlać i modyfikować
67 dowolne znaczniki w pliku. Umożliwia to dla wszystkich obsługiwanych
68 formatów dźwiękowych: Ogg Vorbis, FLAC, MP3, Musepack i MOD.
69
70 Aby używać wszystkich możliwości Quod Libet (włącznie z odtwarzaniem
71 dźwięku) potrzebne są także następujące pakiety: python-pyvorbis,
72 python-pyao, python-mad, python-pyid3lib.
73
74 %package -n exfalso
75 Summary:        Tag editor for various music files
76 Group:          X11/Applications/Multimedia
77 Requires:       gnome-icon-theme-symbolic
78 Requires:       gtk+3 >= 3.18
79 Requires:       gtk-webkit4
80 Requires:       hicolor-icon-theme
81 Requires:       libsoup >= 2.44
82 Requires:       pkgconfig
83 Requires:       python-pygobject3 >= 3.18
84 Requires:       python3 >= 1:3.5
85 Requires:       python3-feedparser
86 Requires:       python3-mutagen >= 1.14
87 # for musicbrainz plugin
88 #Requires:      python3-musicbrainzngs
89
90 %description -n exfalso
91 Ex Falso is a tag editor with the same tag editing interface as Quod
92 Libet, but it does not play files. Supported file formats include Ogg
93 Vorbis, MP3, FLAC, MOD/XM/IT, Musepack, Wavpack, and MPEG-4 AAC.
94
95 %prep
96 %setup -q
97 #%patch0 -p1
98
99 %build
100 %py3_build
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 %py3_install
105
106 # adjust for pld path (no vendor support yet)
107 install -d $RPM_BUILD_ROOT%{zsh_compdir}
108 mv $RPM_BUILD_ROOT{%{_datadir}/zsh/vendor-completions,%{zsh_compdir}}/_quodlibet
109
110 %find_lang %{name}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %files -f %{name}.lang
116 %defattr(644,root,root,755)
117 %doc NEWS README
118 %attr(755,root,root) %{_bindir}/operon
119 %attr(755,root,root) %{_bindir}/quodlibet
120 %{_mandir}/man1/operon.1*
121 %{_mandir}/man1/quodlibet.1*
122 %{_desktopdir}/quodlibet.desktop
123 %{_iconsdir}/hicolor/*/apps/quodlibet.png
124 %{_iconsdir}/hicolor/scalable/apps/quodlibet-symbolic.svg
125 %{_iconsdir}/hicolor/scalable/apps/quodlibet.svg
126 %{_datadir}/appdata/quodlibet.appdata.xml
127 %{_datadir}/dbus-1/services/net.sacredchao.QuodLibet.service
128 %{zsh_compdir}/_quodlibet
129 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
130 %{py3_sitescriptdir}/%{module}
131
132 %files -n exfalso
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_bindir}/exfalso
135 %{_mandir}/man1/exfalso.1*
136 %{_desktopdir}/exfalso.desktop
137 %{_iconsdir}/hicolor/*/apps/exfalso.png
138 %{_iconsdir}/hicolor/scalable/apps/exfalso-symbolic.svg
139 %{_iconsdir}/hicolor/scalable/apps/exfalso.svg
140 %{_datadir}/appdata/exfalso.appdata.xml
This page took 0.134438 seconds and 4 git commands to generate.