]> git.pld-linux.org Git - packages/qt5-qtx11extras.git/blob - qt5-qtx11extras.spec
up to 5.14.1
[packages/qt5-qtx11extras.git] / qt5-qtx11extras.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Documentation
4
5 %define         orgname         qtx11extras
6 %define         qtbase_ver      %{version}
7 %define         qttools_ver     %{version}
8 Summary:        The Qt5 X11 Extras library
9 Summary(pl.UTF-8):      Biblioteka Qt5 X11 Extras
10 Name:           qt5-%{orgname}
11 Version:        5.14.1
12 Release:        1
13 License:        LGPL v2.1 with Digia Qt LGPL Exception v1.1 or GPL v3.0
14 Group:          X11/Libraries
15 Source0:        http://download.qt.io/official_releases/qt/5.14/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
16 # Source0-md5:  aad7b6bd9c037d16c6906e43cc8063e3
17 URL:            http://www.qt.io/
18 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
19 BuildRequires:  Qt5Gui-devel >= %{qtbase_ver}
20 %if %{with doc}
21 BuildRequires:  qt5-assistant >= %{qttools_ver}
22 %endif
23 BuildRequires:  qt5-build >= %{qtbase_ver}
24 BuildRequires:  qt5-qmake >= %{qtbase_ver}
25 BuildRequires:  rpmbuild(macros) >= 1.654
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         specflags       -fno-strict-aliasing
31 %define         qt5dir          %{_libdir}/qt5
32
33 %description
34 Qt is a cross-platform application and UI framework. Using Qt, you can
35 write web-enabled applications once and deploy them across desktop,
36 mobile and embedded systems without rewriting the source code.
37
38 This package contains Qt5 X11 Extras library.
39
40 %description -l pl.UTF-8
41 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
42 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
43 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
44 źródłowego.
45
46 Ten pakiet zawiera bibliotekę Qt5 X11 Extras.
47
48 %package -n Qt5X11Extras
49 Summary:        The Qt5 X11 Extras library
50 Summary(pl.UTF-8):      Biblioteka Qt5 X11 Extras
51 Group:          Libraries
52 Requires:       Qt5Core >= %{qtbase_ver}
53 Requires:       Qt5Gui >= %{qtbase_ver}
54 Obsoletes:      qt5-qtx11extas
55
56 %description -n Qt5X11Extras
57 Qt5 X11 Extras library provides classes for developing for the X11
58 platform.
59
60 %description -n Qt5X11Extras -l pl.UTF-8
61 Biblioteka Qt5 X11 Extras dostarcza klasy do tworzenia oprogramowania
62 dla platformy X11.
63
64 %package -n Qt5X11Extras-devel
65 Summary:        Qt5 X11 Extras - development files
66 Summary(pl.UTF-8):      Biblioteka Qt5 X11 Extras - pliki programistyczne
67 Group:          X11/Development/Libraries
68 Requires:       OpenGL-devel
69 Requires:       Qt5Core-devel >= %{qtbase_ver}
70 Requires:       Qt5Gui-devel >= %{qtbase_ver}
71 Requires:       Qt5X11Extras = %{version}-%{release}
72 Obsoletes:      qt5-qtx11extas-devel
73
74 %description -n Qt5X11Extras-devel
75 Qt5 X11 Extras - development files.
76
77 %description -n Qt5X11Extras-devel -l pl.UTF-8
78 Biblioteka Qt5 X11 Extras - pliki programistyczne.
79
80 %package doc
81 Summary:        Qt5 X11 Extras documentation in HTML format
82 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 X11 Extras w formacie HTML
83 Group:          Documentation
84 Requires:       qt5-doc-common >= %{qtbase_ver}
85 %if "%{_rpmversion}" >= "5"
86 BuildArch:      noarch
87 %endif
88
89 %description doc
90 Qt5 X11 Extras documentation in HTML format.
91
92 %description doc -l pl.UTF-8
93 Dokumentacja do biblioteki Qt5 X11 Extras w formacie HTML.
94
95 %package doc-qch
96 Summary:        Qt5 X11 Extras documentation in QCH format
97 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 X11 Extras w formacie QCH
98 Group:          Documentation
99 Requires:       qt5-doc-common >= %{qtbase_ver}
100 %if "%{_rpmversion}" >= "5"
101 BuildArch:      noarch
102 %endif
103
104 %description doc-qch
105 Qt5 X11 Extras documentation in QCH format.
106
107 %description doc-qch -l pl.UTF-8
108 Dokumentacja do biblioteki Qt5 X11 Extras w formacie QCH.
109
110 %prep
111 %setup -q -n %{orgname}-everywhere-src-%{version}
112
113 %build
114 qmake-qt5
115 %{__make}
116 %{?with_doc:%{__make} docs}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 %{__make} install \
121         INSTALL_ROOT=$RPM_BUILD_ROOT
122
123 %if %{with doc}
124 %{__make} install_docs \
125         INSTALL_ROOT=$RPM_BUILD_ROOT
126 %endif
127
128 # useless symlinks
129 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
130 # actually drop *.la, follow policy of not packaging them when *.pc exist
131 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post   -n Qt5X11Extras -p /sbin/ldconfig
137 %postun -n Qt5X11Extras -p /sbin/ldconfig
138
139 %files -n Qt5X11Extras
140 %defattr(644,root,root,755)
141 %doc LICENSE.GPL3-EXCEPT dist/changes-*
142 %attr(755,root,root) %{_libdir}/libQt5X11Extras.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libQt5X11Extras.so.5
144
145 %files -n Qt5X11Extras-devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libQt5X11Extras.so
148 %{_libdir}/libQt5X11Extras.prl
149 %{_includedir}/qt5/QtX11Extras
150 %{_pkgconfigdir}/Qt5X11Extras.pc
151 %{_libdir}/cmake/Qt5X11Extras
152 %{qt5dir}/mkspecs/modules/qt_lib_x11extras.pri
153 %{qt5dir}/mkspecs/modules/qt_lib_x11extras_private.pri
154
155 %if %{with doc}
156 %files doc
157 %defattr(644,root,root,755)
158 %{_docdir}/qt5-doc/qtx11extras
159
160 %files doc-qch
161 %defattr(644,root,root,755)
162 %{_docdir}/qt5-doc/qtx11extras.qch
163 %endif
This page took 0.08284 seconds and 3 git commands to generate.