]> git.pld-linux.org Git - packages/qt5-qtx11extras.git/blob - qt5-qtx11extras.spec
up to 5.15.13
[packages/qt5-qtx11extras.git] / qt5-qtx11extras.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Documentation
4
5 %define         orgname         qtx11extras
6 %define         qtbase_ver      %{version}
7 %define         qttools_ver     %{version}
8 Summary:        The Qt5 X11 Extras library
9 Summary(pl.UTF-8):      Biblioteka Qt5 X11 Extras
10 Name:           qt5-%{orgname}
11 Version:        5.15.13
12 Release:        1
13 License:        LGPL v3 or GPL v2 or GPL v3 or commercial
14 Group:          X11/Libraries
15 Source0:        https://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-opensource-src-%{version}.tar.xz
16 # Source0-md5:  64af7703ab3648b6698afe2cad313a65
17 URL:            https://www.qt.io/
18 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
19 BuildRequires:  Qt5Gui-devel >= %{qtbase_ver}
20 %if %{with doc}
21 BuildRequires:  qt5-assistant >= %{qttools_ver}
22 %endif
23 BuildRequires:  qt5-build >= %{qtbase_ver}
24 BuildRequires:  qt5-qmake >= %{qtbase_ver}
25 BuildRequires:  rpm-build >= 4.6
26 BuildRequires:  rpmbuild(macros) >= 2.016
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         specflags       -fno-strict-aliasing
32 %define         qt5dir          %{_libdir}/qt5
33
34 %description
35 Qt is a cross-platform application and UI framework. Using Qt, you can
36 write web-enabled applications once and deploy them across desktop,
37 mobile and embedded systems without rewriting the source code.
38
39 This package contains Qt5 X11 Extras library.
40
41 %description -l pl.UTF-8
42 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
43 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
44 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
45 źródłowego.
46
47 Ten pakiet zawiera bibliotekę Qt5 X11 Extras.
48
49 %package -n Qt5X11Extras
50 Summary:        The Qt5 X11 Extras library
51 Summary(pl.UTF-8):      Biblioteka Qt5 X11 Extras
52 Group:          Libraries
53 %requires_eq_to Qt5Core Qt5Core-devel
54 Requires:       Qt5Gui >= %{qtbase_ver}
55 Obsoletes:      qt5-qtx11extras < 5.2.0-1
56
57 %description -n Qt5X11Extras
58 Qt5 X11 Extras library provides classes for developing for the X11
59 platform.
60
61 %description -n Qt5X11Extras -l pl.UTF-8
62 Biblioteka Qt5 X11 Extras dostarcza klasy do tworzenia oprogramowania
63 dla platformy X11.
64
65 %package -n Qt5X11Extras-devel
66 Summary:        Qt5 X11 Extras - development files
67 Summary(pl.UTF-8):      Biblioteka Qt5 X11 Extras - pliki programistyczne
68 Group:          X11/Development/Libraries
69 Requires:       Qt5Core-devel >= %{qtbase_ver}
70 Requires:       Qt5Gui-devel >= %{qtbase_ver}
71 Requires:       Qt5X11Extras = %{version}-%{release}
72 Obsoletes:      qt5-qtx11extras-devel < 5.2.0-1
73
74 %description -n Qt5X11Extras-devel
75 Qt5 X11 Extras - development files.
76
77 %description -n Qt5X11Extras-devel -l pl.UTF-8
78 Biblioteka Qt5 X11 Extras - pliki programistyczne.
79
80 %package doc
81 Summary:        Qt5 X11 Extras documentation in HTML format
82 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 X11 Extras w formacie HTML
83 Group:          Documentation
84 Requires:       qt5-doc-common >= %{qtbase_ver}
85 BuildArch:      noarch
86
87 %description doc
88 Qt5 X11 Extras documentation in HTML format.
89
90 %description doc -l pl.UTF-8
91 Dokumentacja do biblioteki Qt5 X11 Extras w formacie HTML.
92
93 %package doc-qch
94 Summary:        Qt5 X11 Extras documentation in QCH format
95 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 X11 Extras w formacie QCH
96 Group:          Documentation
97 Requires:       qt5-doc-common >= %{qtbase_ver}
98 BuildArch:      noarch
99
100 %description doc-qch
101 Qt5 X11 Extras documentation in QCH format.
102
103 %description doc-qch -l pl.UTF-8
104 Dokumentacja do biblioteki Qt5 X11 Extras w formacie QCH.
105
106 %prep
107 %setup -q -n %{orgname}-everywhere-src-%{version}
108
109 %build
110 %{qmake_qt5}
111 %{__make}
112 %{?with_doc:%{__make} docs}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         INSTALL_ROOT=$RPM_BUILD_ROOT
119
120 %if %{with doc}
121 %{__make} install_docs \
122         INSTALL_ROOT=$RPM_BUILD_ROOT
123 %endif
124
125 # useless symlinks
126 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
127 # actually drop *.la, follow policy of not packaging them when *.pc exist
128 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -n Qt5X11Extras -p /sbin/ldconfig
134 %postun -n Qt5X11Extras -p /sbin/ldconfig
135
136 %files -n Qt5X11Extras
137 %defattr(644,root,root,755)
138 %doc LICENSE.GPL3-EXCEPT dist/changes-*
139 %attr(755,root,root) %{_libdir}/libQt5X11Extras.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libQt5X11Extras.so.5
141
142 %files -n Qt5X11Extras-devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/libQt5X11Extras.so
145 %{_libdir}/libQt5X11Extras.prl
146 %{_includedir}/qt5/QtX11Extras
147 %{_pkgconfigdir}/Qt5X11Extras.pc
148 %{_libdir}/cmake/Qt5X11Extras
149 %{qt5dir}/mkspecs/modules/qt_lib_x11extras.pri
150 %{qt5dir}/mkspecs/modules/qt_lib_x11extras_private.pri
151
152 %if %{with doc}
153 %files doc
154 %defattr(644,root,root,755)
155 %{_docdir}/qt5-doc/qtx11extras
156
157 %files doc-qch
158 %defattr(644,root,root,755)
159 %{_docdir}/qt5-doc/qtx11extras.qch
160 %endif
This page took 0.083933 seconds and 4 git commands to generate.