]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- unify kernel macros
[packages/qemu.git] / qemu.spec
1 #
2 # TODO:
3 # - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4 #
5 # Conditional build:
6 %bcond_without  kqemu                   # disable KQEMU ACCELERATOR support in QEMU
7 %bcond_with     cflags_passing          # with passing rpmcflags to Makefiles
8 %bcond_with     dosguest                # add special patch when use with DOS as guest os
9 %bcond_with     nosdlgui                # do not use SDL gui (use X11 instead)
10 # Note that gcc4 build is very problematic and not supported by qemu team
11 %bcond_with     gcc4                    # use gcc4 patches (broke build on gcc33)
12 %bcond_without  dist_kernel             # without distribution kernel
13 %bcond_without  kernel                  # build kqemu KERNEL MODULES
14 %bcond_without  up                      # don't build up module
15 %bcond_without  smp                     # don't build SMP module
16 %bcond_without  userspace               # don't build userspace utilities
17 %bcond_with     grsec_kernel    # build for kernel-grsecurity
18 #
19 # no kernel kqemu module for ppc
20 %ifarch ppc
21 %undefine      with_kqemu
22 %undefine      with_kernel
23 %endif
24 #
25 %if %{without kernel}
26 %undefine       with_dist_kernel
27 %endif
28 #
29 %if %{with kernel} && %{with dist_kernel} && %{with grsec_kernel}
30 %define alt_kernel      grsecurity
31 %endif
32
33 %define _kqemu_version  1.3.0pre11
34 %define         _rel    55
35 Summary:        QEMU CPU Emulator
36 Summary(pl):    QEMU - emulator procesora
37 Name:           qemu
38 Version:        0.9.0
39 Release:        %{_rel}%{?with_kqemu:k}
40 License:        GPL
41 Group:          Applications/Emulators
42 #Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
43 Source0:        http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
44 # Source0-md5:  ab11a03ba30cf4a70641f0f170473d69
45 Source1:        http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
46 # Source1-md5:  970521874ef8b1ba4598925ace5936c3
47 Patch0:         %{name}-nostatic.patch
48 Patch1:         %{name}-cc.patch
49 Patch3:         %{name}-dot.patch
50 Patch4:         %{name}-gcc4_x86.patch
51 Patch5:         %{name}-gcc4_ppc.patch
52 Patch6:         %{name}-nosdlgui.patch
53 Patch7:         %{name}-ifup.patch
54 # Proof of concept, for reference, do not remove
55 Patch8:         %{name}-kde_virtual_workspaces_hack.patch
56 # http://gwenole.beauchesne.info/en/projects/qemu
57 Patch9:         %{name}-0.8.0-gcc4-hacks.patch
58 Patch11:        %{name}-0.7.2-gcc4-opts.patch
59 #Patch12:       %{name}-0.7.2-dyngen-check-stack-clobbers.patch
60 Patch13:        %{name}-dosguest.patch
61 # Fix crash when using qemu instances with NICs connected via socket
62 # This patch will be obsolete in versions after 0.9.0
63 Patch14:        %{name}-0.9.0-remove-iohandlers.patch
64 URL:            http://fabrice.bellard.free.fr/qemu/
65 %if %{with kernel}
66 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.7}
67 BuildRequires:  rpmbuild(macros) >= 1.330
68 %endif
69 %if %{with userspace}
70 BuildRequires:  SDL-devel >= 1.2.1
71 BuildRequires:  alsa-lib-devel
72 %{!?with_gcc4:BuildRequires:    gcc < 5:4.0}
73 BuildRequires:  perl-tools-pod
74 BuildRequires:  tetex
75 BuildRequires:  sed >= 4.0
76 %endif
77 Requires:       SDL >= 1.2.1
78 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
79 ExclusiveArch:  %{ix86} %{x8664} %{!?with_kqemu:ppc}
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 # some SPARC boot image in ELF format
83 %define         _noautostrip    .*%{_datadir}/qemu/openbios-sparc32
84
85 %description
86 QEMU is a FAST! processor emulator. By using dynamic translation it
87 achieves a reasonnable speed while being easy to port on new host
88 CPUs. QEMU has two operating modes:
89
90 - User mode emulation. In this mode, QEMU can launch Linux processes
91   compiled for one CPU on another CPU. Linux system calls are converted
92   because of endianness and 32/64 bit mismatches. Wine (Windows
93   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
94
95 - Full system emulation. In this mode, QEMU emulates a full system,
96   including a processor and various peripherials. It can also be used to
97   provide virtual hosting of several virtual PC on a single server.
98
99 %description -l pl
100 QEMU to szybki(!) emulator procesora. Poprzez u¿ycie dynamicznego
101 t³umaczenia osi±ga rozs±dn± szybko¶æ i jest ³atwy do przeportowania,
102 aby dzia³a³ na kolejnych procesorach. QEMU ma dwa tryby pracy:
103
104 - Emulacja trybu u¿ytkownika. W tym trybie QEMU mo¿e uruchamiaæ
105   procesy linuksowe skompilowane dla jednego procesora na innym
106   procesorze. Linuksowe wywo³ania systemowe s± t³umaczone ze wzglêdu na
107   niezgodno¶æ kolejno¶ci bajtów w s³owie i 32/64-bitowego rozmiaru
108   s³owa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to g³ówne
109   cele QEMU.
110
111 - Pe³na emulacja systemu. W tym trybie QEMU emuluje ca³y system,
112   w³±czaj±c w to procesor i ró¿ne urz±dzenia peryferyjne. Mo¿e byæ tak¿e
113   u¿ywane do wirtualnego hostowania kilku wirtualnych pecetów na
114   pojedynczym serwerze.
115
116 %package -n kernel%{_alt_kernel}-misc-kqemu
117 Summary:        kqemu - kernel module
118 Summary(pl):    kqemu - modu³ j±dra
119 Version:        %{_kqemu_version}
120 Release:        %{_rel}@%{_kernel_ver_str}
121 Group:          Base/Kernel
122 %{?with_dist_kernel:%requires_releq_kernel_up}
123 License:        GPL v2
124 Requires(post,postun):  /sbin/depmod
125 Requires:       module-init-tools >= 3.2.2-2
126
127 %description -n kernel%{_alt_kernel}-misc-kqemu
128 kqemu - kernel module.
129
130 %description -n kernel%{_alt_kernel}-misc-kqemu -l pl
131 kqemu - modu³ j±dra.
132
133 %package -n kernel%{_alt_kernel}-smp-misc-kqemu
134 Summary:        kqemu - SMP kernel module
135 Summary(pl):    kqemu - modu³ j±dra SMP
136 Version:        %{_kqemu_version}
137 Release:        %{_rel}@%{_kernel_ver_str}
138 Group:          Base/Kernel
139 %{?with_dist_kernel:%requires_releq_kernel_smp}
140 License:        GPL v2
141 Requires(post,postun):  /sbin/depmod
142 Requires:       module-init-tools >= 3.2.2-2
143
144 %description -n kernel%{_alt_kernel}-smp-misc-kqemu
145 kqemu - SMP kernel module.
146
147 %description -n kernel%{_alt_kernel}-smp-misc-kqemu -l pl
148 kqemu - modu³ j±dra SMP.
149
150 %prep
151 %if %{with kernel}
152 %if %{with dist_kernel} && %{without up} && %{without smp}
153 %{error:%{name}: If building kernel module You need to enable at least one of up or smp}
154 exit 1
155 %endif
156 %endif
157
158 %setup -q %{?with_kernel:-a1}
159 %patch0 -p1
160 %patch1 -p1
161 %patch3 -p1
162 %if %{with gcc4}
163 %patch9 -p1
164 %patch11 -p1
165 #%patch12 -p1
166 #%patch4 -p0
167 %patch5 -p1
168 %endif
169 %{?with_nosdlgui:%patch6 -p1}
170 %patch7 -p1
171 #%patch8 -p1
172 %patch14 -p1
173
174 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
175 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
176
177 # cannot use optflags on x86 - they cause "no register to spill" errors
178 %if %{with cflags_passing}
179 %{__sed} -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
180 %else
181 %{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
182 %endif
183
184 %if %{with kernel}
185 echo -n > kqemu-%{_kqemu_version}/install.sh
186
187 cat <<'EOF' > modprobe.conf
188 # enable dynamic major
189 options kqemu major=0
190 # for autoloading from static dev
191 #alias char-major-250 kqemu
192 EOF
193
194 cat <<'EOF' > udev.conf
195 KERNEL=="kqemu", NAME="%k", MODE="0666"
196 EOF
197 %endif
198
199 %if %{with dosguest}
200 %patch13 -p1
201 %endif
202
203 %build
204 %if %{with kernel}
205 cd kqemu-%{_kqemu_version}
206
207 %{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
208 %ifarch %{x8664}
209 %{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
210 %{__make} -C common -j1
211 mv -f kqemu-mod-x86_64.o{,.bin}
212 %else
213 %{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
214 %{__make} -C common -j1
215 mv -f kqemu-mod-i386.o{,.bin}
216 %endif
217
218 mv -f kqemu-linux.c{,.orig}
219 cat > Makefile <<'EOF'
220 obj-m := kqemu.o
221 kqemu-objs:= kqemu-linux.o kqemu-mod.o
222
223 $(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
224         cp $< $@
225 EOF
226
227 %build_kernel_modules -m kqemu <<'EOF'
228 if grep -q "CONFIG_PREEMPT_RT" o/.config; then
229         sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
230                 kqemu-linux.c.orig > kqemu-linux.c
231 else
232         cat kqemu-linux.c.orig > kqemu-linux.c
233 fi
234 EOF
235 cd -
236 %endif
237
238 %if %{with userspace}
239 # --extra-cflags don't work (overridden by CFLAGS in Makefile*)
240 # they can be passed if the cflags_passing bcond is used
241 ./configure \
242         --prefix=%{_prefix} \
243         --cc="%{__cc}" \
244         --host-cc="%{__cc}" \
245         --make="%{__make}" \
246 %if %{with kqemu}
247         --kernel-path=%{_kernelsrcdir} \
248 %else
249         --disable-kqemu \
250 %endif
251         %{?with_gcc4:--disable-gcc-check} \
252         --enable-alsa \
253         --interp-prefix=%{_libdir}/%{name}
254 %{__make}
255 %endif
256
257 %install
258 rm -rf $RPM_BUILD_ROOT
259
260 %if %{with userspace}
261 %{__make} install \
262         DESTDIR=$RPM_BUILD_ROOT
263
264 install -d $RPM_BUILD_ROOT/sbin
265 cat <<'EOF' > $RPM_BUILD_ROOT/sbin/qemu-ifup
266 #!/bin/sh
267 if [ -f /etc/sysconfig/qemu ]; then
268         . /etc/sysconfig/qemu
269 fi
270 # of course this will work only for one interface. a lot possible to involve
271 sudo /sbin/ifconfig $1 ${INTERFACE_ADDR:-172.20.0.1}
272 EOF
273 %endif
274
275 %if %{with kernel}
276 %install_kernel_modules -m kqemu-%{_kqemu_version}/kqemu -d misc
277 install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
278 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
279 %if %{with smp} && %{with dist_kernel}
280 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}smp/kqemu.conf
281 %endif
282 install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
283 %endif
284
285 # already packaged
286 rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
287
288 %clean
289 rm -rf $RPM_BUILD_ROOT
290
291 %if %{with kernel}
292 %post
293 %banner %{name} -e <<EOF
294 To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
295 modprobe kqemu
296 EOF
297 %endif
298
299 %post   -n kernel%{_alt_kernel}-misc-kqemu
300 %depmod %{_kernel_ver}
301
302 %postun -n kernel%{_alt_kernel}-misc-kqemu
303 %depmod %{_kernel_ver}
304
305 %post   -n kernel%{_alt_kernel}-smp-misc-kqemu
306 %depmod %{_kernel_ver}smp
307
308 %postun -n kernel%{_alt_kernel}-smp-misc-kqemu
309 %depmod %{_kernel_ver}smp
310
311 %if %{with userspace}
312 %files
313 %defattr(644,root,root,755)
314 %doc README qemu-doc.html qemu-tech.html
315 %attr(755,root,root) /sbin/qemu-ifup
316 %attr(755,root,root) %{_bindir}/*
317 %{_datadir}/qemu
318 %{_mandir}/man1/qemu.1*
319 %{_mandir}/man1/qemu-img.1*
320 %endif
321
322 %if %{with kernel}
323 %if %{with up} || %{without dist_kernel}
324 %files -n kernel%{_alt_kernel}-misc-kqemu
325 %defattr(644,root,root,755)
326 %doc kqemu-%{_kqemu_version}/LICENSE
327 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
328 %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
329 /lib/modules/%{_kernel_ver}/misc/kqemu.ko*
330 %endif
331
332 %if %{with smp} && %{with dist_kernel}
333 %files -n kernel%{_alt_kernel}-smp-misc-kqemu
334 %defattr(644,root,root,755)
335 %doc kqemu-%{_kqemu_version}/LICENSE
336 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
337 %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}smp/kqemu.conf
338 /lib/modules/%{_kernel_ver}smp/misc/kqemu.ko*
339 %endif
340 %endif
This page took 0.098755 seconds and 4 git commands to generate.