]> git.pld-linux.org Git - packages/python-nss.git/blob - python-nss.spec
- updated to 1.0.0; python3 module added
[packages/python-nss.git] / python-nss.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Python 2 bindings for NSS and NSPR
7 Summary(pl.UTF-8):      Wiązania Pythona 2 do bibliotek NSS i NSPR
8 Name:           python-nss
9 Version:        1.0.0
10 Release:        1
11 License:        MPL v2.0 or GPL v2+ or LGPL v2+
12 Group:          Development/Languages/Python
13 Source0:        http://ftp.mozilla.org/pub/security/python-nss/releases/PYNSS_RELEASE_1_0_0/src/%{name}-%{version}.tar.bz2
14 # Source0-md5:  2159793d207f8d1f15556fd7fcfddc48
15 URL:            http://www.mozilla.org/projects/security/pki/nss/
16 BuildRequires:  nspr-devel >= 4
17 BuildRequires:  nss-devel >= 3
18 %{?with_python2:BuildRequires:  python-devel >= 1:2.7}
19 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.714
22 Requires:       python-libs >= 1:2.7
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Python 2 bindings for Network Security Services (NSS) and Netscape
27 Portable Runtime (NSPR).
28
29 %description -l pl.UTF-8
30 Wiązania Pythona 2 do bibliotek NSS (Network Security Services) oraz
31 NSPR (Netscape Portable Runtime).
32
33 %package -n python3-nss
34 Summary:        Python 3 bindings for NSS and NSPR
35 Summary(pl.UTF-8):      Wiązania Pythona 3 do bibliotek NSS i NSPR
36 Group:          Development/Languages/Python
37 Requires:       python3-libs >= 1:3.2
38
39 %description -n python3-nss
40 Python 3 bindings for Network Security Services (NSS) and Netscape
41 Portable Runtime (NSPR).
42
43 %description -n python3-nss -l pl.UTF-8
44 Wiązania Pythona 3 do bibliotek NSS (Network Security Services) oraz
45 NSPR (Netscape Portable Runtime).
46
47 %prep
48 %setup -q
49
50 %build
51 %if %{with python2}
52 %py_build
53 %endif
54
55 %if %{with python3}
56 %py3_build
57 %endif
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %if %{with python2}
63 %py_install
64
65 %py_postclean
66 %endif
67
68 %if %{with python3}
69 %py3_install
70 %endif
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %if %{with python2}
76 %files
77 %defattr(644,root,root,755)
78 %doc README doc/ChangeLog
79 %dir %{py_sitedir}/nss
80 %{py_sitedir}/nss/__init__.py[co]
81 %attr(755,root,root) %{py_sitedir}/nss/error.so
82 %attr(755,root,root) %{py_sitedir}/nss/io.so
83 %attr(755,root,root) %{py_sitedir}/nss/nss.so
84 %attr(755,root,root) %{py_sitedir}/nss/ssl.so
85 %{py_sitedir}/python_nss-%{version}-py*.egg-info
86 %endif
87
88 %if %{with python3}
89 %files -n python3-nss
90 %defattr(644,root,root,755)
91 %doc README doc/ChangeLog
92 %dir %{py3_sitedir}/nss
93 %{py3_sitedir}/nss/__init__.py
94 %{py3_sitedir}/nss/__pycache__
95 %attr(755,root,root) %{py3_sitedir}/nss/error.cpython-*.so
96 %attr(755,root,root) %{py3_sitedir}/nss/io.cpython-*.so
97 %attr(755,root,root) %{py3_sitedir}/nss/nss.cpython-*.so
98 %attr(755,root,root) %{py3_sitedir}/nss/ssl.cpython-*.so
99 %{py3_sitedir}/python_nss-%{version}-py*.egg-info
100 %endif
This page took 0.072582 seconds and 3 git commands to generate.