]> git.pld-linux.org Git - packages/perl-XML-DOM.git/blob - perl-XML-DOM.spec
- initial release
[packages/perl-XML-DOM.git] / perl-XML-DOM.spec
1
2 # Conditional build:
3 %bcond_without tests    # do not perform "make test"
4
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    XML
7 %define pnam    DOM
8 Summary:        Build DOM Level 1 compliant document structures
9 Name:           perl-XML-DOM
10 Version:        1.43
11 Release:        1
12 License:        Unknown
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  e4c3fdd46e7ada0f9db326b493058d4d
16 BuildRequires:  perl-devel >= 5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 %if %{with tests}
19 BuildRequires:  perl-XML-RegExp
20 BuildRequires:  perl-libxml >= 0.07
21 BuildRequires:  perl-libwww
22 BuildRequires:  perl-XML-Parser >= 2.30
23 %endif
24 Obsoletes:      perl-libxml-enno
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 #%define                _noautoreq      'perl(XML::DOM)' 'perl-(
29
30 %description
31 This is a Perl extension to XML::Parser. It adds a new 'Style' to
32 XML::Parser, called 'Dom', that allows XML::Parser to build an Object
33 Oriented datastructure with a DOM Level 1 compliant interface.
34 However, there is a new DOM module, XML::GDOME which is under active
35 development and significantly faster than XML::DOM, since it is based
36 on the libgdome C library.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44
45 %{__make}
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %dir %{perl_vendorlib}/XML/DOM
61 %{perl_vendorlib}/XML/DOM.pm
62 %{perl_vendorlib}/XML/DOM/*.pm
63 %{perl_vendorlib}/XML/Handler/*
64 %{_mandir}/man3/*
This page took 0.042445 seconds and 3 git commands to generate.