]> git.pld-linux.org Git - packages/perl-XML-Catalog.git/blob - perl-XML-Catalog.spec
- new
[packages/perl-XML-Catalog.git] / perl-XML-Catalog.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    XML
6 %define         pnam    Catalog
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        XML::Catalog - Resolve public identifiers and remap system identifiers
9 Summary(pl.UTF-8):      XML::Catalog - rozwiązywanie identyfikatorów publicznych i przemapowywanie systemowych
10 Name:           perl-XML-Catalog
11 Version:        1.0.0
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-v%{version}.tar.gz
17 # Source0-md5:  8f36caf66a7f977804efa325cb09cbac
18 URL:            http://search.cpan.org/dist/XML-Catalog/
19 BuildRequires:  perl-Module-Build
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-libwww
24 BuildRequires:  perl-Test-Simple
25 BuildRequires:  perl-URI
26 BuildRequires:  perl-XML-Parser
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This module implements draft 0.4 of John Cowan's XML Catalog (formerly
33 known as XCatalog) proposal 
34 (<http://www.ccil.org/~cowan/XML/XCatalog.html>). Catalogs may be
35 written in either SOCAT or XML syntax (see the proposal for syntax
36 details); XML::Catalog will assume SOCAT syntax if the catalog is not
37 in well-formed XML syntax.
38
39 This module, as of 1.0.0, also supports Oasis XML catalogs.
40
41 %description -l pl.UTF-8
42 Ten moduł implementuje szkic (draft) wersji 0.4 propozycji XML Catalog
43 Johna Cowana (wcześniej znanej jako XCatalog:
44 <http://www.ccil.org/~cowan/XML/XCatalog.html>). Katalogi mogą być
45 pisane z użyciem składni SOCAT lub XML (szczegóły w propozycji;
46 XML::Catalog zakłada składnię SOCAT, jeśli katalog nie jest dobrze
47 sformułowanym XML-em).
48
49 Ten moduł w wersji 1.0.0 obsługuje także katalogi Oasis XML.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-v%{version}
53
54 %build
55 %{__perl} Build.PL \
56         destdir=$RPM_BUILD_ROOT \
57         installdirs=vendor
58 ./Build
59
60 %{?with_tests:./Build test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 ./Build install
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes README
73 %{perl_vendorlib}/XML/Catalog.pm
74 %{_mandir}/man3/XML::Catalog.3pm*
This page took 0.059797 seconds and 4 git commands to generate.