]> git.pld-linux.org Git - packages/perl-Test-Class.git/blob - perl-Test-Class.spec
- added R:
[packages/perl-Test-Class.git] / perl-Test-Class.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Class
8 Summary:        Test::Class - easily create test classes in an xUnit style
9 Summary(pl):    Test::Class - ³atwe tworzenie testowych klas w stylu xUnit
10 Name:           perl-Test-Class
11 Version:        0.20
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  66a96dd9acfc2256b54012a3487ccf87
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Attribute-Handlers >= 0.77
22 BuildRequires:  perl-Class-ISA >= 0.32
23 BuildRequires:  perl-Devel-Symdump
24 BuildRequires:  perl-Test-Simple >= 0.46
25 BuildRequires:  perl-Test-Builder-Tester >= 0.09
26 BuildRequires:  perl-Test-Differences >= 0.43
27 BuildRequires:  perl-Test-Exception >= 0.10
28 %endif
29 Requires:       perl(IO::File) >= 1.14
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Test::Class provides a simple way of creating classes and objects to
35 test your code in an xUnit style.
36
37 %description -l pl
38 Test::Class udostêpnia prosty sposób tworzenia klas i obiektów,
39 testuj±cych Twój kod w stylu xUnit.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %{perl_vendorlib}/%{pdir}/*.pm
63 %{perl_vendorlib}/%{pdir}/%{pnam}
64 %{_mandir}/man3/*
This page took 0.026249 seconds and 3 git commands to generate.