]> git.pld-linux.org Git - packages/perl-Test-Class.git/blob - perl-Test-Class.spec
- updated to 0.52
[packages/perl-Test-Class.git] / perl-Test-Class.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    Class
7 Summary:        Test::Class - easily create test classes in an xUnit style
8 Summary(pl.UTF-8):      Test::Class - łatwe tworzenie testowych klas w stylu xUnit
9 Name:           perl-Test-Class
10 Version:        0.52
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  dc70accee2dec2baa95d6df6f231dfa9
17 URL:            https://metacpan.org/release/Test-Class
18 BuildRequires:  perl-devel >= 1:5.8.1
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl-Attribute-Handlers >= 0.77
23 BuildRequires:  perl-Class-ISA >= 0.32
24 BuildRequires:  perl-Devel-Symdump
25 BuildRequires:  perl-MRO-Compat >= 0.11
26 BuildRequires:  perl-Module-Runtime
27 BuildRequires:  perl-Storable >= 2.04
28 BuildRequires:  perl-Test-Simple >= 0.78
29 BuildRequires:  perl-Test-Builder-Tester >= 1.04
30 BuildRequires:  perl-Test-Exception >= 0.25
31 BuildRequires:  perl-Try-Tiny
32 %endif
33 Requires:       perl(IO::File) >= 1.14
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Test::Class provides a simple way of creating classes and objects to
39 test your code in an xUnit style.
40
41 %description -l pl.UTF-8
42 Test::Class udostępnia prosty sposób tworzenia klas i obiektów,
43 testujących Twój kod w stylu xUnit.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %{perl_vendorlib}/Test/Class.pm
67 %{perl_vendorlib}/Test/Class
68 %{_mandir}/man3/Test::Class.3pm*
69 %{_mandir}/man3/Test::Class::*.3pm*
This page took 0.055441 seconds and 4 git commands to generate.