]> git.pld-linux.org Git - packages/perl-Test-Class.git/blob - perl-Test-Class.spec
- updated to 0.50
[packages/perl-Test-Class.git] / perl-Test-Class.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Class
8 Summary:        Test::Class - easily create test classes in an xUnit style
9 Summary(pl.UTF-8):      Test::Class - łatwe tworzenie testowych klas w stylu xUnit
10 Name:           perl-Test-Class
11 Version:        0.50
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  4cc3aaad36b72f424ed90122701d2451
18 URL:            http://search.cpan.org/dist/Test-Class/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Attribute-Handlers >= 0.77
23 BuildRequires:  perl-Class-ISA >= 0.32
24 BuildRequires:  perl-Devel-Symdump
25 BuildRequires:  perl-Test-Simple >= 0.46
26 BuildRequires:  perl-Test-Builder-Tester >= 1.04
27 BuildRequires:  perl-Test-Differences >= 0.43
28 BuildRequires:  perl-Test-Exception >= 0.10
29 %endif
30 Requires:       perl(IO::File) >= 1.14
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Test::Class provides a simple way of creating classes and objects to
36 test your code in an xUnit style.
37
38 %description -l pl.UTF-8
39 Test::Class udostępnia prosty sposób tworzenia klas i obiektów,
40 testujących Twój kod w stylu xUnit.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %{perl_vendorlib}/Test/Class.pm
64 %{perl_vendorlib}/Test/Class
65 %{_mandir}/man3/Test::Class.3pm*
66 %{_mandir}/man3/Test::Class::*.3pm*
This page took 0.111427 seconds and 3 git commands to generate.