]> git.pld-linux.org Git - packages/perl-Term-ReadLine-Gnu.git/blob - perl-Term-ReadLine-Gnu.spec
- updated for 1.17a
[packages/perl-Term-ReadLine-Gnu.git] / perl-Term-ReadLine-Gnu.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (require a working X connection)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Term
7 %define         pnam    ReadLine-Gnu
8 Summary:        Term::ReadLine::Gnu Perl module
9 Summary(cs.UTF-8):      Modul Term::ReadLine::Gnu pro Perl
10 Summary(da.UTF-8):      Perlmodul Term::ReadLine::Gnu
11 Summary(de.UTF-8):      Term::ReadLine::Gnu Perl Modul
12 Summary(es.UTF-8):      Módulo de Perl Term::ReadLine::Gnu
13 Summary(fr.UTF-8):      Module Perl Term::ReadLine::Gnu
14 Summary(it.UTF-8):      Modulo di Perl Term::ReadLine::Gnu
15 Summary(ja.UTF-8):      Term::ReadLine::Gnu Perl モジュール
16 Summary(ko.UTF-8):      Term::ReadLine::Gnu 펄 모줄
17 Summary(nb.UTF-8):      Perlmodul Term::ReadLine::Gnu
18 Summary(pl.UTF-8):      Moduł Perla Term::ReadLine::Gnu
19 Summary(pt.UTF-8):      Módulo de Perl Term::ReadLine::Gnu
20 Summary(pt_BR.UTF-8):   Módulo Perl Term::ReadLine::Gnu
21 Summary(ru.UTF-8):      Модуль для Perl Term::ReadLine::Gnu
22 Summary(sv.UTF-8):      Term::ReadLine::Gnu Perlmodul
23 Summary(uk.UTF-8):      Модуль для Perl Term::ReadLine::Gnu
24 Summary(zh_CN.UTF-8):   Term::ReadLine::Gnu Perl 模块
25 Name:           perl-Term-ReadLine-Gnu
26 Version:        1.17a
27 Release:        1
28 # same as perl
29 License:        GPL v1+ or Artistic
30 Group:          Development/Languages/Perl
31 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
32 # Source0-md5:  acdd3ded64423390824f31149ebfdf5c
33 Patch0:         %{name}-paths.patch
34 BuildRequires:  ncurses-devel >= 5.2
35 BuildRequires:  perl-devel >= 1:5.8.0
36 BuildRequires:  readline-devel >= 4.2
37 BuildRequires:  rpm-perlprov >= 4.1-13
38 Provides:       perl(Term::ReadLine::Gnu::XS)
39 Obsoletes:      perl-Term-Readline-Gnu
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Perl Term::ReadLine::Gnu module.
44
45 This is an implementation of the interface to the GNU Readline
46 Library. This module gives you input line editing facility, input
47 history management facility, word completion facility, etc. It uses
48 the real GNU Readline Library. And this module has the interface with
49 the almost all variables and functions which are documented in the GNU
50 Readline/History Library. So you can program your custom editing
51 function, your custom completion function, and so on with Perl. This
52 may be useful for prototyping before programming with C.
53
54 %description -l pl.UTF-8
55 Moduł Perla Term::ReadLine::Gnu. Jest on implementacją interfejsu do
56 biblioteki GNU Readline. Udostępnia linię wprowadzania tekstu z
57 możliwością edycji, zarządzania historią, automatycznym dopełnianiem
58 itp. Używa biblioteki GNU Readline, ma interfejs do prawie wszystkich
59 zmiennych i funkcji bibliotek Readline i History - można więc
60 oprogramować własne funkcje edycji, dopełniania itp.
61
62 %prep
63 %setup -q -n %{pdir}-%{pnam}-1.17
64 #%patch0 -p1
65
66 %build
67 %{__perl} Makefile.PL \
68         INSTALLDIRS=vendor
69 %{__make} \
70         CC="%{__cc}" \
71         OPTIMIZE="%{rpmcflags} -DPERL_POLLUTE"
72
73 %{?with_tests:%{__make} test}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78
79 %{__make} \
80         CC="%{__cc}" \
81         install DESTDIR=$RPM_BUILD_ROOT
82 rm -f eg/*.orig
83 install eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc README
91 %dir %{perl_vendorarch}/Term/ReadLine
92 %{perl_vendorarch}/Term/ReadLine/Gnu*
93 %dir %{perl_vendorarch}/auto/Term/ReadLine
94 %dir %{perl_vendorarch}/auto/Term/ReadLine/Gnu
95 %attr(755,root,root) %{perl_vendorarch}/auto/Term/ReadLine/Gnu/*.so
96 %{perl_vendorarch}/auto/Term/ReadLine/Gnu/*.bs
97 # empty autosplit.ix, but requred
98 %dir %{perl_vendorarch}/auto/Term/ReadLine/Gnu/XS
99 %{perl_vendorarch}/auto/Term/ReadLine/Gnu/XS/autosplit.ix
100 %{_mandir}/man3/*
101 %dir %{_examplesdir}/%{name}-%{version}
102 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*
This page took 0.052425 seconds and 3 git commands to generate.