]> git.pld-linux.org Git - packages/perl-Term-ReadLine-Gnu.git/blob - perl-Term-ReadLine-Gnu.spec
perl 5.38.0 rebuild
[packages/perl-Term-ReadLine-Gnu.git] / perl-Term-ReadLine-Gnu.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (require a working X connection)
4 #
5 %define         pdir    Term
6 %define         pnam    ReadLine-Gnu
7 Summary:        Term::ReadLine::Gnu - Perl interface for the GNU Readline/History library
8 Summary(pl.UTF-8):      Term::ReadLine::Gnu - perlowy interfejs do biblioteki GNU Readline/History
9 Name:           perl-Term-ReadLine-Gnu
10 Version:        1.36
11 Release:        7
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Term/HAYASHI/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  f8636c8e17b3266f3a686521a0c06886
17 URL:            http://search.cpan.org/dist/Term-ReadLine-Gnu/
18 BuildRequires:  ncurses-devel >= 5.2
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  readline-devel >= 4.2
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 Provides:       perl(Term::ReadLine::Gnu::XS)
23 Obsoletes:      perl-Term-Readline-Gnu
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Term::ReadLine::Gnu Perl module is an implementation of the interface
28 to the GNU Readline Library. This module gives you input line editing
29 facility, input history management facility, word completion facility,
30 etc. It uses the real GNU Readline Library. And this module has the
31 interface with the almost all variables and functions which are
32 documented in the GNU Readline/History Library. So you can program
33 your custom editing function, your custom completion function, and so
34 on with Perl. This may be useful for prototyping before programming
35 with C.
36
37 %description -l pl.UTF-8
38 Moduł Perla Term::ReadLine::Gnu jest implementacją interfejsu do
39 biblioteki GNU Readline. Udostępnia linię wprowadzania tekstu z
40 możliwością edycji, zarządzania historią, automatycznym dopełnianiem
41 itp. Używa biblioteki GNU Readline, ma interfejs do prawie wszystkich
42 zmiennych i funkcji bibliotek Readline i History - można więc
43 oprogramować własne funkcje edycji, dopełniania itp.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make} \
52         CC="%{__cc}" \
53         OPTIMIZE="%{rpmcflags} -DPERL_POLLUTE"
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %{__make} install \
62         CC="%{__cc}" \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 rm -f eg/*.orig
66 install eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc README
74 %dir %{perl_vendorarch}/Term/ReadLine
75 %{perl_vendorarch}/Term/ReadLine/Gnu*
76 %dir %{perl_vendorarch}/auto/Term/ReadLine
77 %dir %{perl_vendorarch}/auto/Term/ReadLine/Gnu
78 %attr(755,root,root) %{perl_vendorarch}/auto/Term/ReadLine/Gnu/Gnu.so
79 # empty autosplit.ix and *.al files, but requred
80 %dir %{perl_vendorarch}/auto/Term/ReadLine/Gnu/XS
81 %{perl_vendorarch}/auto/Term/ReadLine/Gnu/XS/*.al
82 %{perl_vendorarch}/auto/Term/ReadLine/Gnu/XS/autosplit.ix
83 %{_mandir}/man3/Term::ReadLine::Gnu.3pm*
84 %dir %{_examplesdir}/%{name}-%{version}
85 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*
This page took 0.155111 seconds and 4 git commands to generate.