]> git.pld-linux.org Git - packages/perl-Term-ReadLine-Gnu.git/blob - perl-Term-ReadLine-Gnu.spec
- release 3
[packages/perl-Term-ReadLine-Gnu.git] / perl-Term-ReadLine-Gnu.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (require a working X connection)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Term
7 %define         pnam    ReadLine-Gnu
8 Summary:        Term::ReadLine::Gnu - Perl interface for the GNU Readline/History library
9 Summary(pl.UTF-8):      Term::ReadLine::Gnu - perlowy interfejs do biblioteki GNU Readline/History
10 Name:           perl-Term-ReadLine-Gnu
11 Version:        1.19
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Term/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  e591287af62e000256893c84d01abebe
18 Patch0:         %{name}-paths.patch
19 URL:            http://search.cpan.org/dist/Term-ReadLine-Gnu/
20 BuildRequires:  ncurses-devel >= 5.2
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  readline-devel >= 4.2
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 Provides:       perl(Term::ReadLine::Gnu::XS)
25 Obsoletes:      perl-Term-Readline-Gnu
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Term::ReadLine::Gnu Perl module is an implementation of the interface
30 to the GNU Readline Library. This module gives you input line editing
31 facility, input history management facility, word completion facility,
32 etc. It uses the real GNU Readline Library. And this module has the
33 interface with the almost all variables and functions which are
34 documented in the GNU Readline/History Library. So you can program
35 your custom editing function, your custom completion function, and so
36 on with Perl. This may be useful for prototyping before programming
37 with C.
38
39 %description -l pl.UTF-8
40 Moduł Perla Term::ReadLine::Gnu jest implementacją interfejsu do
41 biblioteki GNU Readline. Udostępnia linię wprowadzania tekstu z
42 możliwością edycji, zarządzania historią, automatycznym dopełnianiem
43 itp. Używa biblioteki GNU Readline, ma interfejs do prawie wszystkich
44 zmiennych i funkcji bibliotek Readline i History - można więc
45 oprogramować własne funkcje edycji, dopełniania itp.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49 %patch0 -p1
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make} \
55         CC="%{__cc}" \
56         OPTIMIZE="%{rpmcflags} -DPERL_POLLUTE"
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63
64 %{__make} \
65         CC="%{__cc}" \
66         install DESTDIR=$RPM_BUILD_ROOT
67 rm -f eg/*.orig
68 install eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc README
76 %dir %{perl_vendorarch}/Term/ReadLine
77 %{perl_vendorarch}/Term/ReadLine/Gnu*
78 %dir %{perl_vendorarch}/auto/Term/ReadLine
79 %dir %{perl_vendorarch}/auto/Term/ReadLine/Gnu
80 %attr(755,root,root) %{perl_vendorarch}/auto/Term/ReadLine/Gnu/*.so
81 %{perl_vendorarch}/auto/Term/ReadLine/Gnu/*.bs
82 # empty autosplit.ix, but requred
83 %dir %{perl_vendorarch}/auto/Term/ReadLine/Gnu/XS
84 %{perl_vendorarch}/auto/Term/ReadLine/Gnu/XS/autosplit.ix
85 %{_mandir}/man3/*
86 %dir %{_examplesdir}/%{name}-%{version}
87 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*
This page took 0.06174 seconds and 3 git commands to generate.