]> git.pld-linux.org Git - packages/perl-Sys-Hostname-FQDN.git/blob - perl-Sys-Hostname-FQDN.spec
- updated to 0.07
[packages/perl-Sys-Hostname-FQDN.git] / perl-Sys-Hostname-FQDN.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Sys
7 %define         pnam    Hostname-FQDN
8 Summary:        Sys::Hostname::FQDN - extract full host name
9 Summary(pl):    Sys::Hostname::FQDN - uzyskiwanie pe³nej nazwy hosta
10 Name:           perl-Sys-Hostname-FQDN
11 Version:        0.07
12 Release:        0.1
13 License:        GPL v2+
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ab6b00e3f0781b3e074daa53160d1815
17 Patch0:         %{name}-segv.patch
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Sys::Hostname::FQDN uses the host C library to discover the (usually)
24 short host name, then uses (perl) gethostbyname to extract the real
25 hostname.
26
27 The results from gethostbyname are exported as gethostinfo and
28 asciihostinfo as a convenience since they are available. Similarly,
29 the C library functions inet_ntoa and inet_aton are exported.
30
31 %description -l pl
32 Sys::Hostname::FQDN u¿ywa biblioteki C do uzyskania (zwykle) krótkiej
33 nazwy hosta, a nastêpnie u¿ywa (perlowej) funkcji gethostbyname aby
34 uzyskaæ prawdziw± nazwê hosta.
35
36 Wyniki z gethostbyname s± dla wygody eksportowane jako gethostinfo i
37 asciihostinfo, poniewa¿ s± dostêpne. Podobnie s± wyeksportowane
38 funkcje biblioteki C inet_ntoa i inet_aton.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42 #%patch -p1
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make} \
48         OPTIMIZE="%{rpmcflags}"
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %dir %{perl_vendorarch}/Sys/Hostname
65 %{perl_vendorarch}/Sys/Hostname/FQDN.pm
66 # do we really need these ?
67 #%dir %{perl_vendorarch}/auto/Sys/Hostname
68 #%dir %{perl_vendorarch}/auto/Sys/Hostname/FQDN
69 #%{perl_vendorarch}/auto/Sys/Hostname/FQDN/autosplit.ix
70 #%{perl_vendorarch}/auto/Sys/Hostname/FQDN/FQDN.bs
71 %attr(755,root,root) %{perl_vendorarch}/auto/Sys/Hostname/FQDN/FQDN.so
72 %{_mandir}/man3/*
This page took 0.118685 seconds and 3 git commands to generate.