]> git.pld-linux.org Git - packages/perl-Sys-Hostname-FQDN.git/blob - perl-Sys-Hostname-FQDN.spec
perl 5.38.0 rebuild
[packages/perl-Sys-Hostname-FQDN.git] / perl-Sys-Hostname-FQDN.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Sys
6 %define         pnam    Hostname-FQDN
7 Summary:        Sys::Hostname::FQDN - extract full host name
8 Summary(pl.UTF-8):      Sys::Hostname::FQDN - uzyskiwanie pełnej nazwy hosta
9 Name:           perl-Sys-Hostname-FQDN
10 Version:        0.12
11 Release:        6
12 License:        GPL v2+
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Sys/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  b66ba140adaac6a738b5d02b4b5c3240
16 URL:            http://search.cpan.org/dist/Sys-Hostname-FQDN/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Sys::Hostname::FQDN uses the host C library to discover the (usually)
23 short host name, then uses (perl) gethostbyname to extract the real
24 hostname.
25
26 The results from gethostbyname are exported as gethostinfo and
27 asciihostinfo as a convenience since they are available. Similarly,
28 the C library functions inet_ntoa and inet_aton are exported.
29
30 %description -l pl.UTF-8
31 Sys::Hostname::FQDN używa biblioteki C do uzyskania (zwykle) krótkiej
32 nazwy hosta, a następnie używa (perlowej) funkcji gethostbyname aby
33 uzyskać prawdziwą nazwę hosta.
34
35 Wyniki z gethostbyname są dla wygody eksportowane jako gethostinfo i
36 asciihostinfo, ponieważ są dostępne. Podobnie są wyeksportowane
37 funkcje biblioteki C inet_ntoa i inet_aton.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make} \
46         CC="%{__cc}" \
47         OPTIMIZE="%{rpmcflags}"
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} pure_install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Sys/Hostname/FQDN/.packlist
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %dir %{perl_vendorarch}/Sys/Hostname
66 %{perl_vendorarch}/Sys/Hostname/FQDN.pm
67 %dir %{perl_vendorarch}/auto/Sys/Hostname
68 %dir %{perl_vendorarch}/auto/Sys/Hostname/FQDN
69 %attr(755,root,root) %{perl_vendorarch}/auto/Sys/Hostname/FQDN/FQDN.so
70 %{_mandir}/man3/*
This page took 0.139175 seconds and 4 git commands to generate.