]> git.pld-linux.org Git - packages/perl-SQL-Statement.git/blob - perl-SQL-Statement.spec
- BR: perl-devel; do not BR: perl
[packages/perl-SQL-Statement.git] / perl-SQL-Statement.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    SQL
7 %define         pnam    Statement
8 Summary:        SQL::Statement - SQL parsing and processing engine
9 Summary(pl):    SQL::Statement - silnik do przetwarzania i analizy SQL
10 Name:           perl-SQL-Statement
11 Version:        1.005
12 Release:        2
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 Patch0:         %{name}-warning.patch
17 BuildRequires:  perl-devel >= 5.6
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Modules from this package can be used stand-alone to parse SQL
24 statements or used with DBI and DBD::CSV, DBD::AnyData or other
25 drivers to create, modify, and query data in many kinds of formats
26 including XML, CSV, Fixed Length, Excel Spreadsheets and many others.
27
28 %description -l pl
29 Modu³y z tego pakietu mog± byæ u¿ywane samodzielnie do analizy
30 poleceñ SQL, jak te¿ razem ze sterownikami DBI i DBD::CSV,
31 DBD::AnyData lub innymi, do tworzenia i modyfikacji danych oraz
32 do wykonywania zapytañ przy u¿yciu danych w wielu formatach, w³±czaj±c
33 XML, CSV, dane o sta³ym rozmiarze, arkusze Excela i wiele innych.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37 %patch0 -p1
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor 
42 %{__make}
43
44 %{!?_without_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorlib}/SQL/Dialects
58 %{perl_vendorlib}/SQL/Statement
59 %{perl_vendorlib}/SQL/*.pm
60 %{_mandir}/man3/*
This page took 0.087885 seconds and 3 git commands to generate.